What did you do to your TJ today? - Page 6052 - JeepForum.com
 129Likes
 
LinkBack Thread Tools
post #90766 of 109779 Old 11-21-2013, 05:24 AM
97TJGUZZY
Registered User
 
97TJGUZZY's Avatar
1997 TJ Wrangler 
 
Join Date: Feb 2003
Location: Columbia
Posts: 1,796
Quote:
Originally Posted by carbert View Post
How's that handel work..looka very sturdy
Its this latch. You pull down to open and push forward to close it. The spring loaded pull pin with the black ball on the end holds the handle in place.

http://www.polyperformance.com/shop/...y-p-19993.html


For info on outdoor adventures in South Carolina check out OffroadSC.com
97TJGUZZY is offline  
Sponsored Links
Advertisement
 
post #90767 of 109779 Old 11-21-2013, 05:47 AM
bhikku
Registered User
2004 TJ Wrangler 
 
Join Date: Aug 2012
Location: SLC
Posts: 447
damn thing won't start. crankshaft sensor CEL, fml

2004 Rocky Mountain Edition Wrangler
Utah Jeep Crew #152
US Navy 04-08
bhikku is offline  
post #90768 of 109779 Old 11-21-2013, 06:11 AM
jetmech59
Registered User
 
Join Date: Oct 2013
Location: Prole
Posts: 12
Finished the fenders and painted the body. Should I keep the grill black or paint it OD to match the body?
jetmech59 is offline  
post #90769 of 109779 Old 11-21-2013, 06:13 AM
wwch99tj
Registered User
1999 TJ Wrangler 
 
Join Date: Apr 2010
Location: Felton
Posts: 3,476
Quote:
Originally Posted by jetmech59 View Post
Finished the fenders and painted the body. Should I keep the grill black or paint it OD to match the body?
Looks good black

Sent from my Samsung Galaxy S3 using JeepForum
wwch99tj is offline  
post #90770 of 109779 Old 11-21-2013, 06:37 AM
jrallen
Registered User
2000 TJ Wrangler 
 
Join Date: Jun 2011
Location: Prattville
Posts: 1,032
Garage
Quote:
Originally Posted by wwch99tj View Post

Looks good black

Sent from my Samsung Galaxy S3 using JeepForum
x2. I love me some OD and flat black together
jrallen is offline  
post #90771 of 109779 Old 11-21-2013, 06:43 AM
Tonellin
Registered User
2006 LJ Wrangler 
 
Join Date: Feb 2010
Location: Boston, MA
Posts: 2,098
Quote:
Originally Posted by jetmech59 View Post
Finished the fenders and painted the body. Should I keep the grill black or paint it OD to match the body?
Either paint it OD, or repaint your sway bar cover black. I think it looks kinda funky mismatched, puts a lot of emphasis on the sway bar cover.

06 LJ Rubicon
http://www.jeep-owner.com/index.php/topic,748.0.html
Tonellin is online now  
post #90772 of 109779 Old 11-21-2013, 08:10 AM
TrailJ
Registered User
2006 LJ Wrangler 
 
Join Date: Oct 2011
Posts: 366
Replaced under warranty. Lasted two years. Maybe I'll get for total, then move up to agm.1385046639436.jpg
TrailJ is offline  
post #90773 of 109779 Old 11-21-2013, 12:47 PM
The_Dealer
Registered User
2003 KJ Liberty 
 
Join Date: Jan 2011
Location: Macon
Posts: 1,579
Did the case seals, and sye. Waiting on the rtv to dry

My build
http://www.jeepforum.com/forum/f22/the_dealers-soft-core-build-1476982/
The_Dealer is offline  
post #90774 of 109779 Old 11-21-2013, 01:41 PM
Cptjeeves
Registered User
2003 TJ Wrangler 
 
Join Date: Jan 2012
Location: Porcupine
Posts: 132
Changed out to the little winter tires haha
Attached Images
   
Cptjeeves is offline  
post #90775 of 109779 Old 11-21-2013, 02:15 PM
vanillathrilla
Registered User
1999 TJ Wrangler 
 
Join Date: Jun 2010
Location: Roanoke, VA
Posts: 2,310
I finally got my new starter today... I'm ashamed to say it's still not finished several hours later. I'm a big guy and it's hard for me to snake my arms through some of those crevices and twist in certain directions that you need to in order to access the starter. Carpal tunnel is also kicking my *** right now... I got it in, and it fires right up, but it makes a grinding noise when it's starting. I took it back out and checked the connections because I was afraid it wasn't sitting correctly and grinding against the flywheel or something. Checked alignment, and bolted it back up--but it still makes the noise.

Now I do want to mention one thing... The starter I pulled out might very well be the original starter, and there was only one bolt in it. It was only attached via the lower bolt near the transmission and oil pan. Obviously I want to get another bolt to install it the way it's meant to be, but it never made a grinding noise like that before and it was already only bolted in with one bolt.

Should I be alarmed? Or is it probably just that simple and I just need another bolt? ...or worse, am I going to have to return the starter and repeat this process again?

edit: after doing some searching, it does sound like flywheel grinding... I guess I need to look into shimming the starter. Agreed?

'99 TJ Sport | Rampage Frameless | 33x12.50x15 Goodyear MTR/K's | Poweraid TBS | Flowmaster 40 series | Herculined | 15% tint | LED interior lighting | AtoZ front/rear bumper | AtoZ tube rocker guards | Kenwood Excelon KDC-X993BT | Kicker 6.5's in soundbar | Alpine Type-R 4x6's in dash.
vanillathrilla is offline  
post #90776 of 109779 Old 11-21-2013, 03:46 PM
sjones26573
Registered User
2004 TJ Wrangler 
 
Join Date: Aug 2011
Location: Concord/Harmony/Raleigh
Posts: 9,835
Well today was pretty dang successful. I'm pretty confident we will have doubled our membership by time everyone joins up. There was also a large amount of people taking pictures from afar so I'm sure those will make it on Facebook and Twitter. Also sounds like we're going to have quite the crowd at our Dec 5-7 Uwharrie run.



The Offroad Club @ NC State; Founder
The Yellowtail Build
Jeep-Owner.com
sjones26573 is offline  
post #90777 of 109779 Old 11-21-2013, 05:03 PM
0IIIIIII0
Registered User
2003 TJ Wrangler 
 
Join Date: Jul 2008
Location: Marietta
Posts: 2,823
Noticed a clunking on acceleration and then a machine one again upon deceleration driving home today

I'm thinking control arms, but not sure yet.

Sent from my TJ

If ye love wealth better than liberty, the tranquility of servitude better than the animating contest of freedom, go home from us in peace. We ask not your counsels or arms. Crouch down and lick the hands which feed you. May your chains set lightly upon you, and may posterity forget that ye were our countrymen.
- Samuel Adams
0IIIIIII0 is offline  
post #90778 of 109779 Old 11-21-2013, 05:38 PM
jeepwrangler97
Registered User
1997 TJ Wrangler 
 
Join Date: Jul 2008
Location: FL
Posts: 3,736
Quote:
Originally Posted by vanillathrilla View Post
I finally got my new starter today... I'm ashamed to say it's still not finished several hours later. I'm a big guy and it's hard for me to snake my arms through some of those crevices and twist in certain directions that you need to in order to access the starter. Carpal tunnel is also kicking my *** right now... I got it in, and it fires right up, but it makes a grinding noise when it's starting. I took it back out and checked the connections because I was afraid it wasn't sitting correctly and grinding against the flywheel or something. Checked alignment, and bolted it back up--but it still makes the noise.

Now I do want to mention one thing... The starter I pulled out might very well be the original starter, and there was only one bolt in it. It was only attached via the lower bolt near the transmission and oil pan. Obviously I want to get another bolt to install it the way it's meant to be, but it never made a grinding noise like that before and it was already only bolted in with one bolt.

Should I be alarmed? Or is it probably just that simple and I just need another bolt? ...or worse, am I going to have to return the starter and repeat this process again?

edit: after doing some searching, it does sound like flywheel grinding... I guess I need to look into shimming the starter. Agreed?
I'm not an expert...but maybe the starter isn't disengaging fast enough or something.

I'd put the other bolt in & then I'd swap it for another one if it still grinds, before I'd start shimming it. My experience is sometimes parts store reman parts are hit or miss.

Sucks about having to squeeze back in there...Haha I'm not a big guy, if I were close I'd help ya out

Sent by a messenger bird
jeepwrangler97 is offline  
post #90779 of 109779 Old 11-21-2013, 05:43 PM
jeepwrangler97
Registered User
1997 TJ Wrangler 
 
Join Date: Jul 2008
Location: FL
Posts: 3,736
Quote:
Originally Posted by sjones26573 View Post
Well today was pretty dang successful. I'm pretty confident we will have doubled our membership by time everyone joins up. There was also a large amount of people taking pictures from afar so I'm sure those will make it on Facebook and Twitter. Also sounds like we're going to have quite the crowd at our Dec 5-7 Uwharrie run.

That's awesome...there were like 8ish jeeps that were at my school & maybe 2-3 that wheeled...but I went to a small school.

Sent by a messenger bird
jeepwrangler97 is offline  
post #90780 of 109779 Old 11-21-2013, 05:44 PM
Altonymous
Registered User
2015 JK Wrangler 
 
Join Date: Jun 2012
Location: None
Posts: 402
Technically not today.. But last weekend...

Installed a back seat
Swapped exhaust manifold
Swapped both front wheel bearings
Swapped the track bar
Swapped air filter
Swapped in new spark plugs
Changed oil and filter
Got a new set of 4 steel wheels
Rotated tires
Got aligned and balanced

GOT RID OF THE DEATH WOBBLE!
Altonymous is offline  
Reply

Tags
modifications , tj

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 11 (4 members and 7 guests)
calsouthjeep , Coyote1 , Mud Machine , RedJeepJim
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
I had fun today! Burnerman YJ Wrangler Technical Forum 9 06-18-2014 06:12 PM
Not a good day today. :( CHRRRIS TJ Wrangler Technical Forum 35 09-17-2013 02:39 PM
what i did to my tj today? shovelhead Wrangler General Discussion 6 11-05-2012 12:22 PM
Hit by Bus Today Cooneys08JK JK Wrangler Technical Forum 32 01-07-2012 03:30 PM
New today AZGreenMonster YJ Wrangler Technical Forum 7 09-02-2010 07:52 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome