TPS Sensor - JeepForum.com

 
LinkBack Thread Tools
post #1 of 8 Old 08-19-2013, 12:53 PM Thread Starter
pwatson74
Registered User
1997 TJ Wrangler 
 
Join Date: Oct 2012
Location: Madison
Posts: 6
TPS Sensor

So I just replaced the TPS sensor on my 97 Wrangler SE and had the check engine light reset. About 2 days later the check engine light came on again and when I checked it again it was for the TPS sensor. I did double check to make sure that the sensor was correct for my jeepers.

Any thoughts on why it keeps faulting?


pwatson74 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 08-19-2013, 01:07 PM
AdamLC
Registered User
2003 TJ Wrangler 
 
Join Date: Jan 2013
Location: Oklahoma City
Posts: 69
I had a TPS issue once where it said i had low voltage I had bad luck with the Borge Warner TPS it made me have erratic idle and high idle. I disconnected battery and touched the terminals together like suggested to clear pcm capacitor so it would relearn still no luck. Ended up going back to my original and its fine. May try battery cable trick. If no luck there I would go with Mopar part. Ive hear of a lot of problems with parts store house brand TPS.
AdamLC is offline  
post #3 of 8 Old 08-19-2013, 02:26 PM
samiam_va
Registered User
1997 TJ Wrangler 
 
Join Date: Oct 2012
Location: Alexandria
Posts: 52
Battery healthy? I have had problems with ECU and poor battery charge.
samiam_va is offline  
post #4 of 8 Old 08-19-2013, 02:29 PM
bcash616
Registered User
1999 TJ Wrangler 
 
Join Date: Jun 2011
Location: simpsonville
Posts: 437
Quote:
Originally Posted by samiam_va View Post
Battery healthy? I have had problems with ECU and poor battery charge.
I had a bad ground that causes some issues.....
bcash616 is offline  
post #5 of 8 Old 08-20-2013, 05:58 AM
wesboy
Registered User
1997 TJ Wrangler 
 
Join Date: Aug 2010
Location: Australia
Posts: 391
I've been through 4 TPS on my 97 recently.
Original TPS stopped working so replaced it with an after-market TPS - worked OK for a short time, then crapped out.
Replaced with another after-market TPS (Crown). Same deal - worked OK for a while, then crapped out.
Then replaced with a genuine Mopar TPS 6 months ago - haven't had any problems since.

97 TJ Sport 4.0L Auto RHD
wesboy is offline  
post #6 of 8 Old 08-20-2013, 11:18 AM
chadridesabike
Registered User
1998 TJ Wrangler 
 
Join Date: Sep 2011
Posts: 81
Try disconnecting the positive terminal, then shorting the wire to ground. This will reset the ECU. I had a similar issue when I replaced my TPS, and this replaced it.
chadridesabike is offline  
post #7 of 8 Old 08-20-2013, 07:43 PM
Sudcalifornio
Registered User
2004 TJ Wrangler 
 
Join Date: Jan 2013
Location: Riverbank
Posts: 139
Garage
check battery terminal i had the same problems changing the tps, dont get stuff from autozone ur gonna ended up buying more often. try to get the original
Sudcalifornio is offline  
post #8 of 8 Old 08-20-2013, 09:48 PM
GilaMtnJeep
It Should Have Been MEG!!
 
GilaMtnJeep's Avatar
2003 TJ Wrangler 
 
Join Date: Aug 2008
Location: Silver City
Posts: 4,249
If you're going to buy aftermarket sensors the ONLY ones that are as good as the Mopar sensors are sold by NAPA. The Echelin brand is good quality. I bought my TPS from them over a year ago and had zero problems after replacing mine.

Silence is Golden, Duct tape comes in Many Colors.

Journeyman Meterman IBEW Local 611

Work with enthusiasm as though you were working for the Lord rather than for man.

http://www.treadlightly.org/

Siena Jeep Owner's Member 25

/l ,[____],
l---L -0lllllll0-

()_) ()_)-O-)_)
GilaMtnJeep is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome