TPS Sensor - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > TPS Sensor

ROCK BOTTOM prices on LIFT KITS at Rockridge4wd!! WANT TO Savvy FREE SHIPPING!Year End Clearance Sale! Save 20%

Reply
Unread 08-19-2013, 01:53 PM   #1
pwatson74
Registered User
1997 TJ Wrangler 
 
Join Date: Oct 2012
Location: Madison, WI
Posts: 6
TPS Sensor

So I just replaced the TPS sensor on my 97 Wrangler SE and had the check engine light reset. About 2 days later the check engine light came on again and when I checked it again it was for the TPS sensor. I did double check to make sure that the sensor was correct for my jeepers.

Any thoughts on why it keeps faulting?


pwatson74 is offline   Reply With Quote Quick reply to this message
Unread 08-19-2013, 02:07 PM   #2
AdamLC
Registered User
2003 TJ Wrangler 
 
Join Date: Jan 2013
Location: Oklahoma City, Oklahoma
Posts: 68
I had a TPS issue once where it said i had low voltage I had bad luck with the Borge Warner TPS it made me have erratic idle and high idle. I disconnected battery and touched the terminals together like suggested to clear pcm capacitor so it would relearn still no luck. Ended up going back to my original and its fine. May try battery cable trick. If no luck there I would go with Mopar part. Ive hear of a lot of problems with parts store house brand TPS.
AdamLC is offline   Reply With Quote Quick reply to this message
Unread 08-19-2013, 03:26 PM   #3
samiam_va
Registered User
1997 TJ Wrangler 
 
Join Date: Oct 2012
Location: Alexandria, VA
Posts: 52
Battery healthy? I have had problems with ECU and poor battery charge.
samiam_va is offline   Reply With Quote Quick reply to this message
Unread 08-19-2013, 03:29 PM   #4
bcash616
Registered User
1999 TJ Wrangler 
 
Join Date: Jun 2011
Location: simpsonville, sc
Posts: 423
Quote:
Originally Posted by samiam_va View Post
Battery healthy? I have had problems with ECU and poor battery charge.
I had a bad ground that causes some issues.....
bcash616 is offline   Reply With Quote Quick reply to this message
Unread 08-20-2013, 06:58 AM   #5
wesboy
Registered User
1997 TJ Wrangler 
 
Join Date: Aug 2010
Location: Australia
Posts: 391
I've been through 4 TPS on my 97 recently.
Original TPS stopped working so replaced it with an after-market TPS - worked OK for a short time, then crapped out.
Replaced with another after-market TPS (Crown). Same deal - worked OK for a while, then crapped out.
Then replaced with a genuine Mopar TPS 6 months ago - haven't had any problems since.
__________________
97 TJ Sport 4.0L Auto RHD
wesboy is offline   Reply With Quote Quick reply to this message
Unread 08-20-2013, 12:18 PM   #6
chadridesabike
Registered User
1998 TJ Wrangler 
 
Join Date: Sep 2011
Location: , MI
Posts: 81
Try disconnecting the positive terminal, then shorting the wire to ground. This will reset the ECU. I had a similar issue when I replaced my TPS, and this replaced it.
chadridesabike is offline   Reply With Quote Quick reply to this message
Unread 08-20-2013, 08:43 PM   #7
Sudcalifornio
Registered User
2004 TJ Wrangler 
 
Join Date: Jan 2013
Location: Riverbank, Ca
Posts: 79
check battery terminal i had the same problems changing the tps, dont get stuff from autozone ur gonna ended up buying more often. try to get the original
Sudcalifornio is offline   Reply With Quote Quick reply to this message
Unread 08-20-2013, 10:48 PM   #8
WhiteMtnJeep
The Punk Made My Day.....
 
WhiteMtnJeep's Avatar
2003 TJ Wrangler 
 
Join Date: Aug 2008
Location: Lakeside, Arizona
Posts: 3,459
If you're going to buy aftermarket sensors the ONLY ones that are as good as the Mopar sensors are sold by NAPA. The Echelin brand is good quality. I bought my TPS from them over a year ago and had zero problems after replacing mine.
__________________
Silence is Golden, Duct tape comes in Many Colors.

Journeyman Polyphase Meterman IBEW Local 387

Work with enthusiasm as though you were working for the Lord rather than for man.

http://www.treadlightly.org/

Siena Jeep Owner's Member 25

/l ,[____],
l---L -0lllllll0-

()_) ()_)-O-)_)
WhiteMtnJeep is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.