TJ Sudden loss of power while accellerating - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > TJ Sudden loss of power while accellerating

Black Friday Sale - Deep Discounts from ExtremeTerrain.com6th Annual, Beat Your Wife to the Credit Card Sale!FS: Wrangler RGB Multicolor Fog Light LEDs: Awesome Effect

Reply
Unread 06-27-2010, 12:28 PM   #1
mike m2
Registered User
1999 TJ Wrangler 
 
Join Date: Feb 2008
Location: Ottawa
Posts: 89
TJ Sudden loss of power while accellerating

I have a 99 TJ with about 200Km on it. Every now and then when I accellerate from a standstill, in first, second, and third gear, around 1800 rpm the jeep will just lose all power for a few seconds. I can let off the gas quickly, then get back on it and things go away. It's getting really frustrating.

Also occasionally I will get a really crappy idle. It will be reallllly rough, and rumbly. After I drive a few feet it idles as usual.

I had the check engine light come on when this problem started... P0135 O2 Sensor heater circuit bank 1, sensor 1.

I erased the code and it didn't come back, and obviously the problem was still there. I changed the upstream 02 sensor yesterday and it didn't seem to solve anything. The old 02 sensor had a cut in 2 of 4 the wires running from it, not completely through, but just enough to expose some of the metal. I thought for sure this would cure it after seeing the cut wires... Nope. Still exactly the same.

There is no pending codes at all after driving around for about 30 minutes.

What do I do now? change the other 02 sensor?? Can I repair the wires on the 02 sensor I took out and toss it in the second 02 sensors location to try and narrow down the problem?

mike m2 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.