TJ a no go please help - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > TJ a no go please help

JKS Now Available at www.baseline4x4.com, Trackbars, SkidsFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 04-02-2014, 10:35 AM   #1
Chedda
Registered User
 
Join Date: Apr 2014
Location: Blackstock, Ontario
Posts: 1
TJ a no go please help

I have a 98 TJ 2.5L 5 speed that will not run doesn't even fire. Before it would fire up and run until warm then lose all power till it stalls out completely. I have changed the cam sensor and tried 3 crank sensor as well as the PCM throttle position sensor MAP sensor as well as many other parts and still no luck I've seen in places that on the 5 speeds the Cam sensor doesn't use the paper gasket? It has kicked a code saying that its not reading the Crank sensor which is why I've tried three now also is most recently kicking a code saying the Ignition/ Distribution speed is high thank you for you're time and help

Chedda is offline   Reply With Quote
Unread 04-02-2014, 11:12 AM   #2
rda616
Registered User
1998 TJ Wrangler 
 
Join Date: Nov 2008
Location: Allegan, Michigan
Posts: 2,997
Check all of the ground wires. I would remove them and clean them. Also check for continuity from the crankshaft position sensor to the PCM. The wiring could be corroded or broken.
rda616 is offline   Reply With Quote
Unread 04-02-2014, 11:15 AM   #3
bigred33
Registered User
1999 TJ Wrangler 
 
Join Date: Apr 2009
Location: duluth, georgia
Posts: 1,142
Could also be the coil.
bigred33 is offline   Reply With Quote
Unread 04-02-2014, 11:53 AM   #4
IlliniJeeper
Registered User
1998 TJ Wrangler 
 
Join Date: Apr 2004
Location: Central IL
Posts: 430
If you are getting a crank sensor error, check the harness as well. Could have a wire rubbed through.
__________________
'98 Jeep TJ Sport
IlliniJeeper is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.