TJ 4.0 Stumble? - Page 4 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > TJ 4.0 Stumble?

ROCKRIDGE4WD Introduces a NEW Jeep Wrangler JK *led* tail Ruffstuff XJ Unirail Channel Reinforcement....Rugged Ridge Modular XHD Snorkel Now for both 3.8L and 3.6

Reply
Unread 07-30-2013, 07:28 AM   #46
jeeptjrn
Registered User
2005 TJ Wrangler 
 
Join Date: Jan 2012
Location: Flint, Michigan
Posts: 86
I just replaced 02 sensor with no code and hasn't stumbled since

jeeptjrn is offline   Reply With Quote Quick reply to this message
Unread 06-09-2014, 07:54 PM   #47
bmxboy809
Registered User
1999 TJ Wrangler 
 
Join Date: May 2011
Location: Manitowoc, WI
Posts: 90
ITS BACK!

Similar symptoms, it stutters on the highway or under heavy load. It has been steadily getting worse over the last few weeks, and now has gotten to the point I cant drive it to work. One new symptom is a P1391 trouble code.

So far I changed the CKP sensor and tested the TPS. New cap and rotor.

I pulled the Ignition pickup off the distributor and when I bend/roll the wires it sounds like they may be cracked, possible from heat? I am replacing the Pickup under warranty tomorrow.

also when I was looking around today, I noticed the ECM was pretty warm. I just got back from a 20 min highway ride from work but the ECM seemed exceptionally hot. Should I be concerned about this?
__________________
1999 Wrangler TJ 4.0 5spd -- 6" LA , 35" MTZ's , Ford 8.8 , 4.88 gears , SYE , Tom woods CV shaft
bmxboy809 is offline   Reply With Quote Quick reply to this message
Unread 06-12-2014, 05:48 AM   #48
Bville-Bud
Registered User
 
Join Date: Feb 2008
Location: Berryville Virginia
Posts: 117
Just a heads up, I had a 98 Cherokee with similar issues. Changed the front O2 sensor and fixed it.
http://www.jeepforum.com/forum/f11/c...n-cold-759038/
Bville-Bud is offline   Reply With Quote Quick reply to this message
Reply

Tags
4.0 , missfire , o2 sensor , stumble , surge

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.