Stuttering - JeepForum.com

 
LinkBack Thread Tools
post #1 of 9 Old 03-12-2008, 04:53 PM Thread Starter
CALITJ
Registered User
 
Join Date: Aug 2007
Posts: 6
Stuttering

My jeep runs great until the check engine light come on and then the engine will stutter. The light will come and go with the stuttering. Any suggestions on what the problem is and how I can fix it?

CALITJ is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 03-12-2008, 04:58 PM
jcm11881
Registered User
1998 TJ Wrangler 
 
Join Date: Jan 2007
Location: New York
Posts: 167
My jeep would sputter at start up for the first 2 minutes or so at idle, or until I drove it and mashed the gas pedal down. I replaced the O2 sensors and the problem was solved. I had 78K miles at that point.
jcm11881 is offline  
post #3 of 9 Old 03-12-2008, 05:16 PM Thread Starter
CALITJ
Registered User
 
Join Date: Aug 2007
Posts: 6
It usually happens after I've been driving it. Sometimes, after leaving it over night the problem will go away when I get in the next morning. It's never consistant.
CALITJ is offline  
post #4 of 9 Old 03-12-2008, 05:31 PM
dz1087
Registered User
 
dz1087's Avatar
1999 XJ Cherokee 
 
Join Date: Jul 2006
Location: Florida
Posts: 1,748
You need to have the computer read and see what codes it has thrown. That would clear it up pretty quick. I think Autozone reads 'em for free.


Air Force Jeep Club - Tail# JF037AD
'03 TJ Sport, Black on White, Stock. [[Gone]]
'99 XJ, Purple, Stock but with new wheels.

Running Doorless? Check your state's Mirror Laws!!
http://www.jeepforum.com/forum/f176/list-state-mirror-laws-565361/

There can be no fifty-fifty Americanism in this country. There is room here for only 100% Americanism, only for those who are Americans and nothing else.
Theodore Roosevelt
dz1087 is offline  
post #5 of 9 Old 03-12-2008, 06:49 PM
Rollin
Registered User
1998 XJ Cherokee 
 
Join Date: Feb 2007
Location: NH
Posts: 1,249
What year is your Jeep? We need more info.

1998 Jeep Cherokee Classic: Bull Bar, TracLock Chrysler 8.25"
Rollin is offline  
post #6 of 9 Old 03-12-2008, 07:05 PM Thread Starter
CALITJ
Registered User
 
Join Date: Aug 2007
Posts: 6
01 Wrangler sport 4ltr
CALITJ is offline  
post #7 of 9 Old 07-13-2008, 02:50 PM
Thunderstrike
Web Wheeler
 
Thunderstrike's Avatar
2009 JK Wrangler 
 
Join Date: Dec 2005
Location: Montgomery, AL
Posts: 3,168
Quote:
Originally Posted by jcm11881 View Post
My jeep would sputter at start up for the first 2 minutes or so at idle, or until I drove it and mashed the gas pedal down. I replaced the O2 sensors and the problem was solved. I had 78K miles at that point.
Which O2 sensor did you replace?

2009 JK Rubicon (Former Daily Driver); 2014 VW Jetta GLI Autobahn w NAV.
Auto, Power, Remote Start, Towing Package, MyGig Navigation with Lockpick, Rear View Camera, B&M 70268 Transmission Cooler, Aeroforce Interceptor, Valentine 1, Tub Sound-Deadened with Raamat and Ensolite, Hard Top Heat Insulated with 1/2" Styrofoam Insulation, Bilstein Shocks Front & Rear, PIAA Dual Horns, IPF 920H4 Headlights.
Protection: Skid Row Engine Skid, Lower Control Arm skid & Evaporator Skid; Rock Hard Gas Tank Skid; Warn Stainless Steel Differential Skid Front & Rear.
Recovery Gear: Warn 9.5Ti Winch, 11,000# Pull-Pal.
Communication: Uniden 520XL CB, Diesel External Speaker, 3' FireStik Whip.
Shrockworks Mid-width Front Bumper with Warn 9.5Ti Winch -- Ordered 7/17/2009; Bumper Received 12/4/2009.
1" Coil Spacer Front & 1/2" Coil Spacer Rear restored OEM Rake.
4x4 Trips:
Moab - 4/2006, 5/2008, 4/2009, 5/2011, 4/2013
Ouray - 8/2007
Rubicon - 9/2008
Gone, but not forgotten: 2004 TJ, 1999 Audi A4, 1992 VW Jetta GL 5 Speed
Thunderstrike is offline  
post #8 of 9 Old 07-13-2008, 07:32 PM
BenJmn
Registered User
1999 TJ Wrangler 
 
Join Date: May 2008
Location: North Carolina
Posts: 18
My '99 has the same issue...problem comes and goes.

Plugged in at Autozone and showed a bad TPS.
BenJmn is offline  
post #9 of 9 Old 07-13-2008, 11:46 PM
smidgeon36
Registered User
1998 TJ Wrangler 
 
Join Date: Jul 2008
Location: Corvallis, OR
Posts: 37
I'm having a same problem with my '98 Sport, but sadly I don't know as much as I'd like to. If someone could tell me what exactly having the codes read from Autozone will do, what the bad TPS implies, and how severe of a problem this is, that'd be cool.

Or I'd be perfectly willing to accept some free online reading material on the subject if anyone knows where I can find it.

Thanks!
smidgeon36 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
TJ Stuttering.. esad_b TJ Wrangler Technical Forum 36 08-23-2009 04:38 AM
2.5L stuttering at 50 MPH... burnz34 TJ Wrangler Technical Forum 1 08-02-2009 05:37 PM
A bit of stuttering... Hardtop99 TJ Wrangler Technical Forum 0 06-17-2008 06:45 PM
TJ stuttering Piratejonh TJ Wrangler Technical Forum 3 01-15-2007 04:16 PM
Stuttering hbmex858 YJ Wrangler Technical Forum 1 01-03-2007 11:12 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome