Speedometer stopped working after "light" off-roading... - JeepForum.com
 
LinkBack Thread Tools
post #1 of 8 Old 04-18-2010, 05:10 PM Thread Starter
shdwtek
Registered User
2001 TJ Wrangler 
 
Join Date: Feb 2010
Location: East Hampton, CT
Posts: 22
Speedometer stopped working after "light" off-roading...

My speedometer died today after doing some "light" off-roading. I'm not sure if I broke something, or if it was coincidence, since it seems to be a common problem. All the other gauges work fine, with the exception of the shift arrow light. It comes on even when I'm in 5th gear. I pulled the cluster, and clean the connections. No luck so far. Any suggestions?

Jeep is a 2001 Wrangler Sport. Also.. ever since I had the Jeep, the 4wd lights never worked.

shdwtek is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 04-18-2010, 05:22 PM
GOLENJEEPTJ
Running Secretly Amok!
 
GOLENJEEPTJ's Avatar
2002 TJ Wrangler 
 
Join Date: May 2007
Location: Ventura ,CA.
Posts: 9,712
Check sensor plug at transfer case first.Could be torn up gear or bad sensor gear plugs into.
GOLENJEEPTJ is offline  
post #3 of 8 Old 04-18-2010, 05:47 PM Thread Starter
shdwtek
Registered User
2001 TJ Wrangler 
 
Join Date: Feb 2010
Location: East Hampton, CT
Posts: 22
Thank you, I'll check it out.

Is it possible I could have broke it somehow offroading? Like a tree branch or something?
shdwtek is offline  
post #4 of 8 Old 04-18-2010, 05:58 PM
GOLENJEEPTJ
Running Secretly Amok!
 
GOLENJEEPTJ's Avatar
2002 TJ Wrangler 
 
Join Date: May 2007
Location: Ventura ,CA.
Posts: 9,712
Only if you wacked the rear of transfer case and maybe hit the plug at sensor? but I really doubt that.Good luck let us know.
GOLENJEEPTJ is offline  
post #5 of 8 Old 04-18-2010, 06:05 PM Thread Starter
shdwtek
Registered User
2001 TJ Wrangler 
 
Join Date: Feb 2010
Location: East Hampton, CT
Posts: 22
Ok. I look around tomorrow when it's light out. I did hear some noises here and there, like I kicked up a rock, or branch or something. ...Dragged a pretty big branch at one point.

Sorry for any stupid questions. This is my first Jeep, and I haven't had an issue like this before.
shdwtek is offline  
post #6 of 8 Old 04-19-2010, 09:31 AM Thread Starter
shdwtek
Registered User
2001 TJ Wrangler 
 
Join Date: Feb 2010
Location: East Hampton, CT
Posts: 22
Well, I checked underneath, and it looks like it broke off. Now it wants to stall at a stop unless I give it gas, and then it's ok.
shdwtek is offline  
post #7 of 8 Old 04-19-2010, 11:33 AM
gtstricky
Registered User
2005 TJ Wrangler 
 
Join Date: Mar 2010
Location: Kennett Sq, PA
Posts: 251
Should be an easy fix. There is only one bolt holding the speedo gear into the transfer case. Unbolt it and pull everything apart. See what part is broke and get a new one. Probably $20 - $60 and about 30 minutes total.

Must reads for new TJ Owners:

TJ Boot Camp Threads

Winch Basics

Lift Basics
gtstricky is offline  
post #8 of 8 Old 04-19-2010, 11:45 AM
GOLENJEEPTJ
Running Secretly Amok!
 
GOLENJEEPTJ's Avatar
2002 TJ Wrangler 
 
Join Date: May 2007
Location: Ventura ,CA.
Posts: 9,712
Quote:
Originally Posted by shdwtek View Post
Well, I checked underneath, and it looks like it broke off. Now it wants to stall at a stop unless I give it gas, and then it's ok.
Your stalling could be a dirty IAC valve on your throttle body.You could pick up a can of throttle body cleaner at the parts store for under $10 bucks.Follow the directions. Is your plug still in good condition that goes to the speedometer sensor?
GOLENJEEPTJ is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Help! My Speedometer Stopped Working and Check Engine Light is On Too 95GreenWrangler YJ Wrangler Technical Forum 22 04-22-2010 05:08 PM
Brakes are spongy, "BRAKE" light is on when stopped, flashes when moving rsoby TJ Wrangler Technical Forum 13 10-09-2009 09:40 AM
Speedometer stopped working MaxPower49 TJ Wrangler Technical Forum 0 09-25-2009 07:01 PM
Speedometer stopped working....... NewhampshireYJ YJ Wrangler Technical Forum 1 01-01-2008 08:46 PM
speedometer not working after off roading jeepYJ.TO YJ Wrangler Technical Forum 6 04-06-2006 12:28 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome