Smell of gas, and extreme sputtering - JeepForum.com
 
LinkBack Thread Tools
post #1 of 11 Old 11-01-2010, 11:09 PM Thread Starter
sxysouthtx
Registered User
1993 YJ Wrangler 
 
Join Date: Oct 2009
Location: Winnsboro
Posts: 906
Smell of gas, and extreme sputtering

I tried the search and I found nothing. So here it goes. I'm assuming it's my Throttle Position Sensor. But it's dark out and I have no way of checking until light. I was driving home from UTI, and all of a sudden it went from normal(the engine) to almost a rod knock. Little bit of power loss, smell of gas, and vibration of the engine heavier than lost timing. Has anyone had the problem. I need this fixed asap. I have a 2000TJ 4.0 Sport. Oh yeah, happens hot or cold, and at any RPM range.

I don't know if I lost timing, cam timing gear got jacked, TPS, computer......but I've never had these symptoms in another vehicle, so I'm officially stumped. Thanks for the input.


Not much motion in the ocean, but I'm the captain.
sxysouthtx is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 11-02-2010, 12:13 AM
Jeepster83
Registered User
2003 TJ Wrangler 
 
Join Date: May 2008
Location: Aurora
Posts: 3,340
where is the smell of gas coming from? under the hood or from the exhaust?

injector stuck open flooding a cylinder and fouling a plug? if so, shorted wire on the injector.

Quote:
Originally Posted by mrblaine View Post
Being right has nothing to do with arrogance. It's only perceived that way by those that are wrong.
WyoTech West Sacramento - Graduated 8/19/2011

Back into my Jeep... finally.
Jeepster83 is offline  
post #3 of 11 Old 11-02-2010, 12:32 AM Thread Starter
sxysouthtx
Registered User
1993 YJ Wrangler 
 
Join Date: Oct 2009
Location: Winnsboro
Posts: 906
I can't quite tell where it's coming from. I do know that when I popped the hood walked to my front door to get a flashlight, I could smell gas and exhaust fume for a long distance. Now, if the problem is what you suggest.....would that also cause a knocking like feel and sound? I'll check this in the morning when I have light. I'm sure I could pull the plugs and probably see which one it is. Man I hope it's that simple, for the love of god and all that is holy.

Not much motion in the ocean, but I'm the captain.
sxysouthtx is offline  
 
post #4 of 11 Old 11-02-2010, 09:04 AM
Jeepster83
Registered User
2003 TJ Wrangler 
 
Join Date: May 2008
Location: Aurora
Posts: 3,340
well youd have 5 of the 6 cylinders firing making your engine run rough at the least.

check your vacuum lined under the hood as well including your evap canister. i believe yours is still under the hood whereas newer TJ like mine have the canister in the passenger rear quarter panel behind the lail light.

open your oil cap and smell for gas. if it is a failed (or failing) injector you might have gas in your engine oil and you should definitely not drive it like that. youll wash away all the oil from bearings and other components and youll be buying an engine in the near future for a failed engine.

check your purge solenoid as well. itll be part of your evap system on the driver side of the engine bay.

good luck man. i know that with the both of us going to Wyotech we cant afford buying a new or even a used 4.0!

Quote:
Originally Posted by mrblaine View Post
Being right has nothing to do with arrogance. It's only perceived that way by those that are wrong.
WyoTech West Sacramento - Graduated 8/19/2011

Back into my Jeep... finally.
Jeepster83 is offline  
post #5 of 11 Old 11-02-2010, 09:12 AM Thread Starter
sxysouthtx
Registered User
1993 YJ Wrangler 
 
Join Date: Oct 2009
Location: Winnsboro
Posts: 906
Well, I checked the oil. There is a heavy smell of fuel in the oil. And I am worried as hell about my cylinder walls. but I have absolutely no smoke what so ever. I'll run those checks. Appreciate the help. I go to school at the UTI campus in Avondale,AZ. i figure if all else fails, take it to the guys there who know best. But I'm going to do everything I can from my end first.

Not much motion in the ocean, but I'm the captain.
sxysouthtx is offline  
post #6 of 11 Old 11-02-2010, 12:23 PM
Jeepster83
Registered User
2003 TJ Wrangler 
 
Join Date: May 2008
Location: Aurora
Posts: 3,340
dont drive it. do you know someone with a flatbed truck or trailer?


P.S. wyotech...uti...same certificates.

Quote:
Originally Posted by mrblaine View Post
Being right has nothing to do with arrogance. It's only perceived that way by those that are wrong.
WyoTech West Sacramento - Graduated 8/19/2011

Back into my Jeep... finally.
Jeepster83 is offline  
post #7 of 11 Old 11-02-2010, 12:29 PM Thread Starter
sxysouthtx
Registered User
1993 YJ Wrangler 
 
Join Date: Oct 2009
Location: Winnsboro
Posts: 906
Ha, alright....check this out. So I fixed it. You wouldn't believe what it was. Now, I'm going to get some new coil packs, but I just replaced the plugs and it started quicker than usual...but the funny thing is when this guy walks around the corner and peeks in my hood and yells..."You coil pack is sending spark to one of your upper radiator hoses...lifts it off the coil, and bingo....all fixed. I'm going to do something about the grounding out. But I can't believe it was that simple. Thanks for all the help though. And jeepster, the answer is yes I do know someone with a flat bed, and thank god I didn't have to call him.

Not much motion in the ocean, but I'm the captain.
sxysouthtx is offline  
post #8 of 11 Old 11-02-2010, 12:48 PM
Jeepster83
Registered User
2003 TJ Wrangler 
 
Join Date: May 2008
Location: Aurora
Posts: 3,340
change your oil as soon as possible. gasoline is a solvent and will destroy your rod bearings if its driven too much. also you mentioned checking your cylinder walls - thats probably a very good idea. having gas in the oil is a death sentence for any engine. i would suggest an oil flush instead of a simple change.

Quote:
Originally Posted by mrblaine View Post
Being right has nothing to do with arrogance. It's only perceived that way by those that are wrong.
WyoTech West Sacramento - Graduated 8/19/2011

Back into my Jeep... finally.
Jeepster83 is offline  
post #9 of 11 Old 11-02-2010, 01:54 PM Thread Starter
sxysouthtx
Registered User
1993 YJ Wrangler 
 
Join Date: Oct 2009
Location: Winnsboro
Posts: 906
Way ahead of you, just changed my oil. My buddy ran his escort with I'd say, about 1/2 quart of gas in it for god knows how long. Long story short......New engine.

Not much motion in the ocean, but I'm the captain.
sxysouthtx is offline  
post #10 of 11 Old 11-02-2010, 03:12 PM
Jeepster83
Registered User
2003 TJ Wrangler 
 
Join Date: May 2008
Location: Aurora
Posts: 3,340
if i were you id change the oil again in about 500 - 1000 miles. better safe than sorry right?

Quote:
Originally Posted by mrblaine View Post
Being right has nothing to do with arrogance. It's only perceived that way by those that are wrong.
WyoTech West Sacramento - Graduated 8/19/2011

Back into my Jeep... finally.
Jeepster83 is offline  
post #11 of 11 Old 11-03-2010, 11:40 AM Thread Starter
sxysouthtx
Registered User
1993 YJ Wrangler 
 
Join Date: Oct 2009
Location: Winnsboro
Posts: 906
I ran a detergent. I should be good, however my oil pressure seems a little high.

Not much motion in the ocean, but I'm the captain.
sxysouthtx is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Sputtering gives off smell mightydog78 TJ Wrangler Technical Forum 18 07-11-2011 07:55 PM
Pro Come Extreme A/T JeepPilot88 JK Wrangler Technical Forum 1 03-26-2008 06:43 PM
Extreme Fix?? COmtns TJ Wrangler Technical Forum 17 05-01-2007 09:51 AM
Extreme 4x4 supertj4415 TJ Wrangler Technical Forum 2 08-30-2004 03:25 PM
RE 4.5 Extreme for a YJ agtkgv YJ Wrangler Technical Forum 4 03-11-2003 10:52 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome