Should CEL come on during startup? - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 04-26-2007, 12:26 PM Thread Starter
Brandon Iain
Registered User
 
Join Date: Apr 2007
Location: Portland, Oregon
Posts: 17
Should CEL come on during startup?

I'm having a couple issues with my 99 Wrangler w/2.5L that I'm trying to work through.

But a question came up in my searches on the forums. My CEL doesn't light up when I turn the ignition to on. Should it light up like my "Check Guages" and "Airbag" lights light up?

I took it to AutoZone not too long ago and didn't get any codes, but I'm just curious if I might be missing something here. I searched and searched, can't find anything, just need a quick confirmation.


Thanks.

Brandon Iain is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 04-26-2007, 01:05 PM
Ludedude
Registered User
2000 TJ Wrangler 
 
Join Date: Feb 2007
Location: Vegas Baby, Vegas
Posts: 149
Yes it should. As a matter of fact, in states that do OBDII inspections, that light failing to come on at startup is an instant fail.
Ludedude is offline  
post #3 of 3 Old 04-26-2007, 01:12 PM
Rocky529
Jeep
 
Rocky529's Avatar
2004 TJ Wrangler 
 
Join Date: Jul 2004
Location: Park City
Posts: 13,185
I belive your 1999 TJ still uses a light bulb comapred to later model TJs that use LEDs. Your light bulb could be simply burned out. I would double check the light bulb is working properly before investigating other remedies.

2004 Jeep Wrangler Sport - 5 speed

Silver Metallic finish with black dual tops - Dana 44 Rear
2.25" Suspension Lift with Old Man Emu Shocks
Performance Accessories 1" Body Lift
Daystar 1" Motor Mount Lift
Spidertrax 1.25" Wheel Spacers - 32"x11.5" MT/R Tires
Rocky529 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
oil pressure lag at startup? .apollodorus. TJ Wrangler Technical Forum 10 07-05-2007 03:39 PM
A/C screach at startup vato_loco_quas TJ Wrangler Technical Forum 5 11-04-2005 06:26 PM
TJ Stalls as Startup supr_bikr_99 TJ Wrangler Technical Forum 2 08-26-2005 08:11 AM
Startup RPM Alfons YJ Wrangler Technical Forum 10 08-22-2005 08:48 PM
rough on startup seachange TJ Wrangler Technical Forum 1 08-07-2005 09:11 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome