Running too rich, P0170 or P070? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > Running too rich, P0170 or P070?

Trailing Arms!JK Vent Covers - NalinMFGComponent speaker deal for your dash - NalinMFG

Reply
Unread 06-21-2011, 07:18 PM   #1
mightydog78
Registered User
2013 JK Wrangler 
 
Join Date: Jan 2009
Location: Charlotte/Winston-salem, NC
Posts: 1,989
Running too rich, P0170 or P070?

I got my codes checked today because the check engine light came on.

ive been having tons of trouble with rough idle and horrible gas smells.
I wrote the code down but can't remember if it was 0170 or 070 or 0107. but underneath the reader it said "System is too rich"

So I have a list of things that I think could be the problem (in order of most likely):
1. Clogged cat. (getting a new exhaust this weekend)
2. Bad O2 sensors (due to clogged cat.?)
3. fuel filter
4. vacuum leak
5. bad spark plugs
6. bad fuel injectors
7. dirty throttle body
8. TPS or MAP sensor

looks like I have my hands full, need opinions!

__________________
2013 JKU Sahara

Charlotte, NC / Southport, NC

Mechanical Engineer
mightydog78 is offline   Reply With Quote Quick reply to this message
Unread 06-21-2011, 07:39 PM   #2
mightydog78
Registered User
2013 JK Wrangler 
 
Join Date: Jan 2009
Location: Charlotte/Winston-salem, NC
Posts: 1,989
i will be checking to vacuum hoses near the throttle body tomorrow and will update as well. as well as the battery grounds (shouldnt be that sense my lights dont flicker)

need advice on what you guys think
__________________
2013 JKU Sahara

Charlotte, NC / Southport, NC

Mechanical Engineer
mightydog78 is offline   Reply With Quote Quick reply to this message
Unread 06-22-2011, 03:12 PM   #3
mightydog78
Registered User
2013 JK Wrangler 
 
Join Date: Jan 2009
Location: Charlotte/Winston-salem, NC
Posts: 1,989
dang... anyone?
__________________
2013 JKU Sahara

Charlotte, NC / Southport, NC

Mechanical Engineer
mightydog78 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.