Rough Idle when cold - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > Rough Idle when cold

GEARSHADE Pocket Tops in stock and available at ROCKRIDGE The ULTIMATE "Selectable" Locker System! BroughFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 07-28-2008, 03:39 PM   #1
firefighter1
Registered User
 
Join Date: Jan 2006
Location: New Jersey
Posts: 43
Rough Idle when cold

I have a 98 TJ, 4.0/Auto. Jeep would crank but not start. Shows a bad crank position sensor-changed that and jeep starts but runs rough with a miss. Changed the cap,rotor,plugs,wires,still runs rough when cold but does get better once it's warm. Now it throws a code that says the crank and cam aren't in sync'. Once warmed up it throws no code. I'm baffled,please help

firefighter1 is offline   Reply With Quote
Unread 04-22-2013, 08:25 PM   #2
yjsapper
Registered User
1989 YJ Wrangler 
 
Join Date: Sep 2012
Location: morganton, nc
Posts: 18
my brothers o2 tj does the same thing with the same codes. we have replace the crank sensor, plugs, all the 02 sensors, checked for vacuum leaks, cleaned the throttle body and IAC. Still does it when its a cold start and around 40 degrees ambiet temp. Totaly lost now.
yjsapper is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.