Rough Idle and #2 Misfire - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > Rough Idle and #2 Misfire

Introducing MONSTALINER UV Permanent DIY Roll On Bed LineThe ULTIMATE "Selectable" Locker System! BroughFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 03-27-2014, 07:25 AM   #1
Duck Vader
Yep...
 
Duck Vader's Avatar
2006 LJ Wrangler 
 
Join Date: Aug 2006
Location: Beaverton, Oregon
Posts: 613
Rough Idle and #2 Misfire

2006 LJ Rubicon. 4.0. Auto. 86k miles

For the last couple of months I have been battling a rough idle and a #2 misfire (code p0302). I have done plenty of searches, and I have tried many things, but it is still an issue.

Things I have tried to rectify the issue:

New exhaust (cats and cat-back)
New 02 sensors
New DP plugs
New TPS
New air filter
Cleaned throttle body and IAC
Checked injector o-rings
Checked hoses for leaks

Things I am doing today:

Stopping by AutoZone to get the code read (been using the "trick" to read the codes)to make sure nothing else is popping up.
Going to swap out the #2 injector with another one to see if the misfire changes.
Check plug on #2 (even though this was happening before the new plugs).

The problem seems to happen when I am doing a lot of errands in one day. A lot of short trips with a a lot of turning the engine on and off. The idle will get rougher and rougher and eventually a misfire will happen on #2.

Besides what I plan on doing today, is there anything else I should check for or any ideas on what is causing the issue?

__________________
I'm sorry, did you say something?
Duck Vader is offline   Reply With Quote
Unread 03-27-2014, 07:37 AM   #2
XTRyan
ExtremeTerrain.com
 
XTRyan's Avatar
2012 JK Wrangler 
 
Join Date: Dec 2012
Location: Malvern, PA
Posts: 903
Quote:
Originally Posted by Duck Vader View Post
2006 LJ Rubicon. 4.0. Auto. 86k miles

For the last couple of months I have been battling a rough idle and a #2 misfire (code p0302). I have done plenty of searches, and I have tried many things, but it is still an issue.

Things I have tried to rectify the issue:

New exhaust (cats and cat-back)
New 02 sensors
New DP plugs
New TPS
New air filter
Cleaned throttle body and IAC
Checked injector o-rings
Checked hoses for leaks

Things I am doing today:

Stopping by AutoZone to get the code read (been using the "trick" to read the codes)to make sure nothing else is popping up.
Going to swap out the #2 injector with another one to see if the misfire changes.
Check plug on #2 (even though this was happening before the new plugs).

The problem seems to happen when I am doing a lot of errands in one day. A lot of short trips with a a lot of turning the engine on and off. The idle will get rougher and rougher and eventually a misfire will happen on #2.

Besides what I plan on doing today, is there anything else I should check for or any ideas on what is causing the issue?
I think you have it right switching the injector and checking the plug. Did you do wires when you did the plugs?

The next step for me would be a leak down test. This will let you know if the valves are sealing and everything is ok in mechanically in the head the cylinder. I did everything you did and when I finally did the leak down, I found that I had to have my valves reworked/replaced. Good Luck!

-Ryan
__________________
Ryan H. | ExtremeTerrain.com Off-Road Outfitters
Toll Free: 800-988-4605 | Mon-Fri 10AM-6PM EST
Free Shipping on Orders Over $75!
PM me for our JeepForum Discount Code (must have 25 posts) or Price-Matching!
GET YOUR FREE JEEP PARTS CATALOG!
XTRyan is offline   Reply With Quote
Unread 03-27-2014, 07:52 AM   #3
Duck Vader
Yep...
 
Duck Vader's Avatar
2006 LJ Wrangler 
 
Join Date: Aug 2006
Location: Beaverton, Oregon
Posts: 613
Coil rail on the 06, no wires.

Pretty sure I heard an exhaust leak this morning on my way to work. I will check that tonight as well.
__________________
I'm sorry, did you say something?
Duck Vader is offline   Reply With Quote
Unread 03-27-2014, 05:47 PM   #4
Duck Vader
Yep...
 
Duck Vader's Avatar
2006 LJ Wrangler 
 
Join Date: Aug 2006
Location: Beaverton, Oregon
Posts: 613
Replaced the coil rail, switched #2 and #4 plugs, and switched #2 and #3 injectors. Tightened down loose exhaust and fixed the leak. Seafoamed everything. So far so good, but since I had to disconnect the battery, only time will tell if it worked or not. Hopefully it did, but if it didn't hopefully it shows me if the plug was bad or if the injector was bad, and not something internal in #2.

I do have the Mopar Added Care Plus warranty though, so if something internal, it should be covered.
__________________
I'm sorry, did you say something?
Duck Vader is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.