rough country bar pin eliminator rough ride after? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > rough country bar pin eliminator rough ride after?

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineSavvy Billet LED Tail LightsLight up the holidays with LED lights from JeepHut

Reply
Unread 02-21-2009, 02:38 PM   #1
emahan01
Registered User
1999 TJ Wrangler 
 
Join Date: Sep 2008
Location: Parsippany
Posts: 328
rough country bar pin eliminator rough ride after?

i installed the rear bar pin eliminators and after i did that my suspension totaly sucks when my rear his a bump it literarly is like spine crushing. when i go under the truck all is well but i can find that between the rc 2.2 shocks and there rubber bump stops i only have about a inch and a half this is because the bar pin elimnator moved the top mount down closer to the bottom thus shortening and screwing up the shocks. any solutions because ive snapped bar pins before and i dont wana have to deal with it.

emahan01 is offline   Reply With Quote Quick reply to this message
Unread 02-21-2009, 04:15 PM   #2
Imped
Web Wheeler
 
Imped's Avatar
2004 TJ Wrangler 
 
Join Date: Feb 2008
Location: Indianapolis
Posts: 19,673
Sounds like the decreased travel of the shocks have really messed the shock's ability to absorb loads. I would love to do BPE's but the RC shocks just don't have enough piston showing to make me comfortable doing it. With that said, I have had zero problems with the bar pins.
__________________
OlllllllO
Float Test Build
IndyORV
Imped is offline   Reply With Quote Quick reply to this message
Unread 02-21-2009, 04:27 PM   #3
vector6
Registered User
2001 TJ Wrangler 
 
Join Date: Nov 2005
Location: MGTN, WV
Posts: 1,043
add about 3 more inches of lift and you will be good...
vector6 is offline   Reply With Quote Quick reply to this message
Unread 02-21-2009, 10:05 PM   #4
emahan01
Registered User
1999 TJ Wrangler 
 
Join Date: Sep 2008
Location: Parsippany
Posts: 328
anyone have a decent solution to this? or ne one have the same issue
emahan01 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.