Rough cold idle -

LinkBack Thread Tools
post #1 of 2 Old 11-09-2004, 09:40 PM Thread Starter
Registered User
2013 JK Wrangler 
Join Date: Aug 2004
Location: Moab
Posts: 22
Rough cold idle

I have a 2001 Wrangler Sport 4.0

Lately it seems to have a much rougher idle when first started cold.

Does anyone have an opinion as to what this may be? Simple fuel filter, or is there a cold start valve that goes out occassionally?


ckcarr is offline  
Sponsored Links
post #2 of 2 Old 11-10-2004, 03:45 AM
Red J
Registered User
2001 TJ Wrangler 
Join Date: Oct 2004
Location: West Palm Beach
Posts: 43
I had the same exact problem. Two years ago Jeep came out with a technical service bulletin (TSB) to fix this. I believe it is only with certain 2001s. I went to the dealership and asked them to look it up. It did the trick.

Latest Obsession
2001 Red TJ Sport 4.0 Liter
31" BFG T/A KOs, Dana 44 3.73
2" Skyjacker Lift with Hydro shocks
Smittybuilt Tube Bumpers and Sides
Life is Good!
Red J is offline  

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Rough Idle when cold firefighter1 TJ Wrangler Technical Forum 1 04-22-2013 08:25 PM
Rough Idle when Cold Titleistprov21 TJ Wrangler Technical Forum 3 11-05-2009 10:54 AM
Rough Idle on Cold Start rugbynut YJ Wrangler Technical Forum 15 03-13-2008 12:37 PM
Rough idle on cold/first startup of the morning. abnormal TJ Wrangler Technical Forum 18 08-15-2007 10:09 AM
Rough Idle on cold engine fire-up 69440dart TJ Wrangler Technical Forum 6 09-09-2003 05:43 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome