Replaced ignition now nothing happens -

LinkBack Thread Tools
post #1 of 1 Old 01-21-2010, 05:53 PM Thread Starter
Registered User
1999 TJ Wrangler 
Join Date: Jun 2007
Location: Pitkin, LA
Posts: 21
Replaced ignition now nothing happens

I have 99 TJ 4.0 auto tranny. I replaced the ignition switch because the radio/blinkers stopped working with this one from JC Whittney Item Number: 1JA 280225. Now the brake light and passenger air bag off light are lit with the ignition switch in the off position. When the ignition switch is turned to start nothing happens. The jeep has been sitting up for about 2 months before I finally installed the switch and I verifed that I have good battery voltage and during the 2 months I have been starting the jeep. Any ideas on where to start.

aklsufan is offline  

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Epic Ignition Battle (replaced everything but the ignition switch!) thechadwick YJ Wrangler Technical Forum 10 08-27-2009 11:02 PM
94 YJ 4.0L ignition problems, I've replaced everything I can think of ltjblalo YJ Wrangler Technical Forum 10 04-21-2009 07:40 AM
No spark..replaced crankshaft sensor, ignition coil, distributor(rotor and cap) amsgwp YJ Wrangler Technical Forum 4 03-08-2009 09:16 PM
Replaced stereo and that annoying ignition buzzer isnt working? Roach YJ Wrangler Technical Forum 7 12-07-2005 01:58 PM
HELP!!! Replaced Ignition Module, won't run! bidnizman YJ Wrangler Technical Forum 5 10-12-2004 07:24 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome