Opened up the exhaust and there is no catalyc converter. Need your help - JeepForum.com

 
LinkBack Thread Tools
post #1 of 6 Old 08-11-2012, 02:10 AM Thread Starter
Dreso
Registered User
2001 TJ Wrangler 
 
Join Date: Aug 2008
Location: Iceland/Poland
Posts: 365
Opened up the exhaust and there is no catalyc converter. Need your help

Opened up the exhaust and there is no catalyc converter. My car has two lambda sensors and the catalic is empty. The muffler is also empty so my questions is. Could that affect how the car runs. It is a 2.5 liter. For now I want to wait with buying a new catalyc because in europe they are expensive.
Is it ok to put a emulator on the secoond lambda sensor?

Dreso is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 08-11-2012, 06:26 AM
Unlimited04
This post/info=my opinion
 
Unlimited04's Avatar
2004 LJ Wrangler 
 
Join Date: Dec 2005
Location: Colorado
Posts: 24,178
Unlimited04 is offline  
post #3 of 6 Old 08-11-2012, 07:21 AM
10Xk
Registered User
2014 WK 
 
Join Date: Apr 2012
Posts: 1,092
Quote:
Originally Posted by Dreso
Opened up the exhaust and there is no catalyc converter. My car has two lambda sensors and the catalic is empty. The muffler is also empty so my questions is. Could that affect how the car runs. It is a 2.5 liter. For now I want to wait with buying a new catalyc because in europe they are expensive.
Is it ok to put a emulator on the secoond lambda sensor?
Whats the problem? Yes it could effect how it runs, more air flow, more power.
10Xk is offline  
post #4 of 6 Old 08-11-2012, 09:07 AM Thread Starter
Dreso
Registered User
2001 TJ Wrangler 
 
Join Date: Aug 2008
Location: Iceland/Poland
Posts: 365
There is no CE light.
Had it connected to a computer and also there were no faults.
Dreso is offline  
post #5 of 6 Old 08-11-2012, 04:44 PM
10Xk
Registered User
2014 WK 
 
Join Date: Apr 2012
Posts: 1,092
Quote:
Originally Posted by Dreso
There is no CE light.
Had it connected to a computer and also there were no faults.
I wouldn't mess with it, if it ain't broken don't fix it!
10Xk is offline  
post #6 of 6 Old 08-11-2012, 05:02 PM
LJameson
Registered User
1990 YJ Wrangler 
 
Join Date: Jun 2008
Location: Central Oregon!
Posts: 3,830
My guess is somebody (assuming you're not the original owner) gutted the cat because they thought they'd get more power, then maybe put o2 simulators so there wasn't a CEL.

OR, the cat broke down over time and the down stream O2 sensor is bad, thus making the cat monitor think everything is ok.

1990 YJ-The wheeler
2015 JK- The DD
LJameson is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
where to buy exhaust/catalytic converter for a 95 yj 2.5 jpnelson1978 Wrangler General Discussion 2 10-08-2009 09:47 PM
cat converter and exhaust ryanvolk81 TJ Wrangler Technical Forum 8 03-19-2007 10:27 AM
Catalytic Converter/Exhaust dhenigin TJ Wrangler Technical Forum 10 03-13-2007 06:20 AM
Rust Converter on Exhaust? Rick5150 TJ Wrangler Technical Forum 11 12-16-2006 04:15 AM
After-Market Exhaust, Original Converter? GreatGatsby YJ Wrangler Technical Forum 4 09-28-2006 02:58 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome