Opened up the exhaust and there is no catalyc converter. Need your help - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > Opened up the exhaust and there is no catalyc converter. Need your help

The Original 3/8" Ruffstuff Diff Cover!Building a Bumper?Introducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 08-11-2012, 02:10 AM   #1
Dreso
Registered User
2001 TJ Wrangler 
 
Join Date: Aug 2008
Location: Iceland/Poland
Posts: 331
Opened up the exhaust and there is no catalyc converter. Need your help

Opened up the exhaust and there is no catalyc converter. My car has two lambda sensors and the catalic is empty. The muffler is also empty so my questions is. Could that affect how the car runs. It is a 2.5 liter. For now I want to wait with buying a new catalyc because in europe they are expensive.
Is it ok to put a emulator on the secoond lambda sensor?

Dreso is offline   Reply With Quote
Unread 08-11-2012, 06:26 AM   #2
Unlimited04
This post/info=my opinion
 
Unlimited04's Avatar
2004 LJ Wrangler 
 
Join Date: Dec 2005
Location: Colorado
Posts: 23,241
any check engine lights?
Unlimited04 is offline   Reply With Quote
Unread 08-11-2012, 07:21 AM   #3
10Xk
Registered User
2010 XK Commander 
 
Join Date: Apr 2012
Location: , USA
Posts: 659
Quote:
Originally Posted by Dreso
Opened up the exhaust and there is no catalyc converter. My car has two lambda sensors and the catalic is empty. The muffler is also empty so my questions is. Could that affect how the car runs. It is a 2.5 liter. For now I want to wait with buying a new catalyc because in europe they are expensive.
Is it ok to put a emulator on the secoond lambda sensor?
Whats the problem? Yes it could effect how it runs, more air flow, more power.
10Xk is offline   Reply With Quote
Unread 08-11-2012, 09:07 AM   #4
Dreso
Registered User
2001 TJ Wrangler 
 
Join Date: Aug 2008
Location: Iceland/Poland
Posts: 331
There is no CE light.
Had it connected to a computer and also there were no faults.
Dreso is offline   Reply With Quote
Unread 08-11-2012, 04:44 PM   #5
10Xk
Registered User
2010 XK Commander 
 
Join Date: Apr 2012
Location: , USA
Posts: 659
Quote:
Originally Posted by Dreso
There is no CE light.
Had it connected to a computer and also there were no faults.
I wouldn't mess with it, if it ain't broken don't fix it!
10Xk is offline   Reply With Quote
Unread 08-11-2012, 05:02 PM   #6
LJameson
Registered User
1990 YJ Wrangler 
 
Join Date: Jun 2008
Location: Elizabeth Lake, CA
Posts: 3,747
My guess is somebody (assuming you're not the original owner) gutted the cat because they thought they'd get more power, then maybe put o2 simulators so there wasn't a CEL.

OR, the cat broke down over time and the down stream O2 sensor is bad, thus making the cat monitor think everything is ok.
__________________
"Anything to do with the land, I love."
"So it's probably eighty percent luck and twenty percent skill."

-Chris LeDoux

I never could figure what the sky was thinking, but the soil, she don't keep too many secrets.
LJameson is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.