post #1 of Old 10-31-2009, 08:31 PM Thread Starter
jeffa187
Registered User
2001 TJ Wrangler 
 
Join Date: Jul 2009
Location: Lubbock, TX
Posts: 249
Not really a build thread







Sorry the pics are dark I JUST finished

It took me ALL day to put on RC 2.5" SL/1.25" BL/MML/2.2 Steering Stabilizer and 33" TSL's on some wheels I got on Craigslist for $50 and then spray painted flat black (I had to use the chrome lugs and center caps from my old wheels).

After I took it for a test drive I had no vibes up to 75 MPH I know that is how it supposed to work but knowing myself I figured something would go wrong.

All my gears on the bottom of the shifter (2nd, 4th and reverse) seem further away but still go in easily. Should I adjust something or is this OK?

My speedometer is also perfect (according to my handheld GPS) with the 4.88's and 33's.

The only thing I forgot was to screw the gas filler back in and put the gas cap on I saw it after the test drive when I smelled gas in the garage

Now I just need to go out and do some hard wheelin and break my turdy5 so I have a NEED for a S35/D44

Overall, I'm pretty happy with it! What do ya'll think?

jeffa187 is offline  
post #2 of Old 10-31-2009, 09:03 PM
PurpleTJ
Registered User
1998 TJ Wrangler 
 
Join Date: Mar 2009
Location: Okemos
Posts: 1,812
very nice, it looks great. be sure to get some day pics up once you can.

Quote:
Originally Posted by TheDustMan View Post
I took a poo once, and when I stood up, there was nothing in the toilet. I was positively terrified.
Quote:
Originally Posted by solarpower View Post
Get a good tummy tuck with engine skid and treat it like a pimp does a crack whore.
Purple Jeep Club member #8

My Purple People Eater Build
PurpleTJ is offline  
post #3 of Old 11-01-2009, 11:02 AM Thread Starter
jeffa187
Registered User
2001 TJ Wrangler 
 
Join Date: Jul 2009
Location: Lubbock, TX
Posts: 249
OK daytime pics



jeffa187 is offline  
post #4 of Old 11-01-2009, 04:18 PM
tulman22
Registered User
2005 TJ Wrangler 
 
Join Date: Jun 2008
Location: SE Atl, Ga
Posts: 475
Nice looking Jeep. Also great score on the rims from Craiglist!

US Navy "SPOOK" RETIRED
Impact Orange member # 39
tulman22 is offline  
post #5 of Old 11-01-2009, 04:59 PM
bddisi
Registered User
1997 TJ Wrangler 
 
Join Date: Sep 2008
Location: Cleveland TN.
Posts: 906
Nice work, Now clean that rig up some.
Also I was first.http://www.jeepforum.com/forum/f9/no...thread-828965/

Scorpion-Offroad-Concepts
bddisi is offline  
post #6 of Old 11-01-2009, 06:41 PM
Eric554
Registered User
 
Join Date: Jan 2009
Location: Colorado
Posts: 334
Hows the ride? I've heard Rough Country shocks can get a bit firm.
Eric554 is offline  
post #7 of Old 11-01-2009, 08:54 PM Thread Starter
jeffa187
Registered User
2001 TJ Wrangler 
 
Join Date: Jul 2009
Location: Lubbock, TX
Posts: 249
Quote:
Originally Posted by bddisi View Post
Nice work, Now clean that rig up some.
Also I was first.http://www.jeepforum.com/forum/f9/no...thread-828965/
Yeah needs a bath, but I went wheelin today and hopefully again tomorrow, then a bath. maybe.

And you win.
jeffa187 is offline  
post #8 of Old 11-01-2009, 08:55 PM Thread Starter
jeffa187
Registered User
2001 TJ Wrangler 
 
Join Date: Jul 2009
Location: Lubbock, TX
Posts: 249
Quote:
Originally Posted by Eric554 View Post
Hows the ride? I've heard Rough Country shocks can get a bit firm.
It is definitely stiffer but it seems like it is from the springs, not the shocks. It is a good ride.
jeffa187 is offline  
post #9 of Old 07-01-2010, 01:12 AM
04WJny
Registered User
1987 YJ Wrangler 
 
Join Date: Feb 2010
Location: Long Island
Posts: 614
looks good. i like tht color too
04WJny is offline  
post #10 of Old 07-01-2010, 01:52 AM
k00s
Registered User
2004 TJ Wrangler 
 
Join Date: Aug 2009
Location: South Africa
Posts: 25
looking good
k00s is offline  
post #11 of Old 09-09-2010, 07:07 AM Thread Starter
jeffa187
Registered User
2001 TJ Wrangler 
 
Join Date: Jul 2009
Location: Lubbock, TX
Posts: 249
I haven't updated in a while and my jeep is a little different now.

Tube Fenders, Super 35, HD tie rod and drag link, 35" KM2's and a few other odds and ends.





Now Im having a problem maybe someone could help me with. I used the 3/4" led's for side blinkers. And even though they are a two wire light I TRIED using them as parking lights. My goal was to use them as a parking light only and not flash. However, when I hooked them up to the 3rd wire they still flash. Does anyone know what the problem is?

If all else fails I was going to just splice in to the power on my headlights so that anytime my headlights are the parking light led's would come on.

Any thoughts are appreciated!
jeffa187 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
My 03 Build Thread timcfuller TJ Wrangler Technical Forum 82 09-20-2012 09:10 PM
'04 RME TJ Build Thread imbezol TJ Wrangler Technical Forum 216 01-02-2012 12:15 PM
My YJ Build Thread obsessedjeeper YJ Wrangler Technical Forum 14 07-01-2010 01:22 AM
Just Another YJ Build Thread MYYJ93 YJ Wrangler Technical Forum 13 01-29-2010 10:23 PM
My Build Thread ech0sh4y YJ Wrangler Technical Forum 18 05-09-2008 02:26 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome