No power to my 2005 wrangler - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > No power to my 2005 wrangler

BLACK FRIDAY SPECIALS!! You asked, we deliver!Rough Country Lift Kits and Parts!XJ Rail Sale!

Reply
Unread 06-30-2010, 10:37 AM   #1
norville
Member
 
norville's Avatar
1997 TJ Wrangler 
 
Join Date: Mar 2009
Location: pa
Posts: 251
No power to my 2005 wrangler

help, me out folks. I went to goto lunch today. I turned the key I had a 1/2 of blip of the starter and then nothing... nothing at all. I do not have light, radio alarms...ect. The only light I have is the under hood light nothing else. The gauges are acting all weird flipping around and stuff.. please help me out. I pulled the power wire on the battery for now.

bob

__________________
rollin' in the slow lane

thanks

bob
norville is offline   Reply With Quote Quick reply to this message
Unread 06-30-2010, 10:39 AM   #2
Sundowner
Part-Time Swami
 
Sundowner's Avatar
2003 TJ Wrangler 
 
Join Date: May 2009
Location: The Republic of Dave
Posts: 6,335
Check your battery, battery terminals and connectors first.
__________________
If it's worth doing, then it's worth overdoing.

The Republic of Dave: Bringing you the finest in simian testing supplies.

The build, the gear, and the mileage: The Wasteland Survival Guide
Sundowner is offline   Reply With Quote Quick reply to this message
Unread 06-30-2010, 10:45 AM   #3
biffgnar
Web Wheeler
 
biffgnar's Avatar
2006 TJ Wrangler 
 
Join Date: May 2008
Location: Westchester, NY
Posts: 14,101
Quote:
Originally Posted by norville View Post
help, me out folks. I went to goto lunch today. I turned the key I had a 1/2 of blip of the starter and then nothing... nothing at all. I do not have light, radio alarms...ect. The only light I have is the under hood light nothing else. The gauges are acting all weird flipping around and stuff.. please help me out. I pulled the power wire on the battery for now.

bob
How old is your battery? Sounds exactly like how my 06 behaved when my battery gave out. Trip to Sears for a Diehard Platinum P-4 and all was good.
__________________
Thank you Dave Cole, Dynomax, Falken and all the Spec Class sponsors!!
biffgnar is offline   Reply With Quote Quick reply to this message
Unread 06-30-2010, 11:46 AM   #4
TJ311
Registered User
2001 TJ Wrangler 
 
Join Date: Mar 2009
Location: Fort Collins
Posts: 378
Quote:
Originally Posted by norville View Post
The only light I have is the under hood light nothing else
You have an under hood light...........that works?!


But seriously, pull off both battery cables, clean and replace and see if it comes back.

Is there a main relay that could have died?
TJ311 is offline   Reply With Quote Quick reply to this message
Unread 06-30-2010, 12:13 PM   #5
norville
Member
 
norville's Avatar
1997 TJ Wrangler 
 
Join Date: Mar 2009
Location: pa
Posts: 251
Thanks all, It was a bad battery. I had 13v under no load as soon as I hit the starter 6v..... were good now

thanks

bob
__________________
rollin' in the slow lane

thanks

bob
norville is offline   Reply With Quote Quick reply to this message
Unread 06-30-2010, 12:55 PM   #6
andy02
Registered User
2004 TJ Wrangler 
 
Join Date: Aug 2007
Location: Lost Wages, NV
Posts: 3,728
Quote:
Originally Posted by TJ311 View Post
You have an under hood light...........that works?!



I was thinking the exact same thing.
__________________
Quote:
Originally Posted by Hendrix
No one really knows the reason for LCOG Jeeps.

Its so short ****s like me and you can still get in.
Quote:
Originally Posted by 2ACR View Post
My issue was I couldn't get the balls centered. I had to use some extra force to get everything lined up right. It didn't take me long.


September 11 2001
Never Forget!
andy02 is offline   Reply With Quote Quick reply to this message
Unread 07-01-2010, 03:19 AM   #7
bojang
Registered User
2005 TJ Wrangler 
 
Join Date: Jan 2009
Location: chicago
Posts: 475
Mine works at the car wash, after I spray it with water, never any other time....
__________________
Chris

Freedom from nags, cranks, government, do-gooders, control-freaks and idiots is all that I ask for.

Never trust a lumpy fart.
bojang is offline   Reply With Quote Quick reply to this message
Reply

Tags
power , battery , alternator , tj , wrangler

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.