Multiple problems all in a row! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > Multiple problems all in a row!

Rough Country Jeep Suspension Deals at Rockridge 4WD!JEEP Gear Change Packages From ROCKRIDGE 4WD. We Are DIFFThe ULTIMATE "Selectable" Locker System! Brough

Reply
Unread 12-26-2014, 12:45 PM   #1
Dans95ZJ
Registered User
1998 TJ Wrangler 
 
Join Date: Nov 2007
Location: So Cal
Posts: 180
Multiple problems all in a row!

So:
Lower radiator hose broke.
Fixed it pretty quickly and now I have no heat.
And also I'm stalling for no reason I can think of.
I changed out the water pump, radiator, and thermostat about 2 years, 10,000 miles ago.
Why am I stalling? Any ideas to keep me busy this weekend?

__________________
Only in My Jeep!
Dans95ZJ is offline   Reply With Quote Quick reply to this message
Unread 12-26-2014, 12:48 PM   #2
MisfitSeven
MAIL Crawler.
 
MisfitSeven's Avatar
1998 TJ Wrangler 
 
Join Date: Feb 2009
Location: Bennington, Nebraska
Posts: 3,935
Was your heat working prior to the hose failure?
__________________
Mail crawling.
MisfitSeven is online now   Reply With Quote Quick reply to this message
Unread 12-26-2014, 01:01 PM   #3
Dans95ZJ
Registered User
1998 TJ Wrangler 
 
Join Date: Nov 2007
Location: So Cal
Posts: 180
Yes it was. But I have to say it never got as hot as my old YJ!
I flushed the whole cooling system after I replaced the hose using the Prestone in-line flush (garden hose connector) and theres a lot of brown crud that came out.
Flushed again the next day and it's pretty clear.
Now I'm wondering if any of that crud clogged up the thermostat. Might have to pop the cover off again and replace the thermostat.
I really can't understand why it stalls now.
__________________
Only in My Jeep!
Dans95ZJ is offline   Reply With Quote Quick reply to this message
Unread 12-26-2014, 01:17 PM   #4
danielbuck
Registered User
2006 TJ Wrangler 
 
Join Date: Mar 2010
Location: Westchester, CA
Posts: 4,673
Is the engine over heating?
__________________
Daniel Buck - [URL="http://www.danielbuck.net"]www.DanielBuck.net[/URL] - [URL="http://www.dnsfail.com"]www.DNSFAIL.com[/URL]
danielbuck is offline   Reply With Quote Quick reply to this message
Unread 12-26-2014, 01:22 PM   #5
Dans95ZJ
Registered User
1998 TJ Wrangler 
 
Join Date: Nov 2007
Location: So Cal
Posts: 180
Not overheating, runs hot - over 210 - then jumps down to 200.
__________________
Only in My Jeep!
Dans95ZJ is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.