Looking for help Code P0303 - JeepForum.com
Reply
 
LinkBack Thread Tools
post #1 of 17 Old 06-20-2011, 03:28 PM Thread Starter
drl650
Registered User
2004 TJ Wrangler 
 
Join Date: Dec 2010
Location: cape coral
Posts: 176
Looking for help Code P0303

I get this code P0303(M) CYLINDER #3 MISFIRE Misfire detected in cylinder #3
2004 Rubicon with 51000 miles.Any one here have this problem? Thanks.

drl650 is offline  
Sponsored Links
Advertisement
 
post #2 of 17 Old 06-20-2011, 04:32 PM
dflesher65
Registered User
2006 LJ Wrangler 
 
Join Date: Mar 2009
Location: Santee
Posts: 68
I posted about 2 weeks ago with the exact same code...I bought some new plugs and reset the computer and now everything is back to normal. Any chance you still have the factory warrenty?
dflesher65 is offline  
post #3 of 17 Old 06-20-2011, 06:13 PM
GOLENJEEPTJ
Running Secretly Amok!
 
GOLENJEEPTJ's Avatar
2002 TJ Wrangler 
 
Join Date: May 2007
Location: Ventura ,CA.
Posts: 9,713
Quote:
Originally Posted by dflesher65 View Post
I posted about 2 weeks ago with the exact same code...I bought some new plugs and reset the computer and now everything is back to normal. Any chance you still have the factory warrenty?
7 Years later?
GOLENJEEPTJ is offline  
post #4 of 17 Old 06-20-2011, 06:15 PM
GOLENJEEPTJ
Running Secretly Amok!
 
GOLENJEEPTJ's Avatar
2002 TJ Wrangler 
 
Join Date: May 2007
Location: Ventura ,CA.
Posts: 9,713
When was your last tuneup? Is probably a plug issue or injector issue.
GOLENJEEPTJ is offline  
post #5 of 17 Old 06-20-2011, 06:20 PM
etterdog
Registered User
1997 TJ Wrangler 
 
Join Date: Jun 2011
Location: Newburg
Posts: 35
If you have coil packs you could pull the #3 coil pack and try switching it with another like #1 and if it brings up a code for #1 the it would be the coil pack. might help narrow it down more for you.
etterdog is offline  
post #6 of 17 Old 06-20-2011, 06:58 PM
Knuckelhead
AFSOC Retired
 
Knuckelhead's Avatar
2000 TJ Wrangler 
 
Join Date: Aug 2005
Location: Colorado
Posts: 19,140
Quote:
Originally Posted by etterdog View Post
If you have coil packs you could pull the #3 coil pack and try switching it with another like #1 and if it brings up a code for #1 the it would be the coil pack. might help narrow it down more for you.
Have you ever looked at the 2000-2006 4.0L coil on rail setup?...
Knuckelhead is offline  
post #7 of 17 Old 06-20-2011, 07:27 PM
etterdog
Registered User
1997 TJ Wrangler 
 
Join Date: Jun 2011
Location: Newburg
Posts: 35
Sorry that's right they're an all in one setup. I haven't worked on them allot. Just trying to help
etterdog is offline  
post #8 of 17 Old 06-21-2011, 08:32 AM
longbluerubi
Registered User
2005 LJ Wrangler 
 
Join Date: Jul 2010
Location: Chapel Hill
Posts: 128
I have an 05 LJ and had a P0303. Did some research, one thing I found you may want to check out due to hot weather now is a TSB about rough idle and P0303 after a 10-20 minute drive in 90+ temps. The TSB info is here: http://www.jeepforum.com/forum/f11/p...isfire-394071/. Pulled the plug, didn't see any issues, I cleared the code and put a piece of plastic tube over the injector (didn't buy the kit) and haven't had problems since, been a while now. Not sure if this is what fixed the problem but it hasn't shown backup again. Just something else to consider.

'05 LJ Unlimited Rubicon
I6 4.0L manual 6-speed
OME 2.5" lift+Nitrocharger Sport shocks
1" BL, JKS adj front & rear trackbars, JKS discos
33" BFG A/T
longbluerubi is offline  
post #9 of 17 Old 06-21-2011, 08:38 AM
Ross
Registered User
2001 TJ Wrangler 
 
Join Date: Dec 2002
Posts: 12,142
Quote:
Originally Posted by longbluerubi View Post
I have an 05 LJ and had a P0303. Did some research, one thing I found you may want to check out due to hot weather now is a TSB about rough idle and P0303 after a 10-20 minute drive in 90+ temps. The TSB info is here: http://www.jeepforum.com/forum/f11/p...isfire-394071/. Pulled the plug, didn't see any issues, I cleared the code and put a piece of plastic tube over the injector (didn't buy the kit) and haven't had problems since, been a while now. Not sure if this is what fixed the problem but it hasn't shown backup again. Just something else to consider.

I had the p303 issue and hot hard start for years, I changed plugs, cleaned the tps, and nothing helped and then I did TSB mentioned above.

I took it to the dealer. I called them to do a little research and they said it only takes a coupled of minutes. They said they would do it for 35 bucks so I let them.

Parts are about 5 bucks and it seems easy. The only question I had was how do you know if you set the injector back in correctly.

My jeep isn't a daily driver and I haven't really had it out and about much so not sure if it actually fixed the problem.

01 TJ, 34 Super Swaper 34x10.5 bias, Winch, locked, belly up, some armor, 4.0, 5spd
Ross is offline  
post #10 of 17 Old 06-21-2011, 09:50 AM
Knuckelhead
AFSOC Retired
 
Knuckelhead's Avatar
2000 TJ Wrangler 
 
Join Date: Aug 2005
Location: Colorado
Posts: 19,140
Quote:
Originally Posted by Ross View Post
The only question I had was how do you know if you set the injector back in correctly.
You don't remove the injector when performing this TSB...
Knuckelhead is offline  
post #11 of 17 Old 06-21-2011, 10:19 AM
longbluerubi
Registered User
2005 LJ Wrangler 
 
Join Date: Jul 2010
Location: Chapel Hill
Posts: 128
Quote:
Originally Posted by Ross View Post
The only question I had was how do you know if you set the injector back in correctly.
I didn't remove the injector. I read the instructions on the TSB and it basically gave you something two wrap around where the injector goes in, so I just slipped a small piece of the black, split ribbed electrical conduit on it, figured that would deflect enough of the heat away. Haven't had the problem since, so thinking that may have done it (I have a 17 minute drive to/from work so I'm frequently in that 10-20 minute heat soak time).

'05 LJ Unlimited Rubicon
I6 4.0L manual 6-speed
OME 2.5" lift+Nitrocharger Sport shocks
1" BL, JKS adj front & rear trackbars, JKS discos
33" BFG A/T
longbluerubi is offline  
post #12 of 17 Old 06-21-2011, 11:38 AM
Ross
Registered User
2001 TJ Wrangler 
 
Join Date: Dec 2002
Posts: 12,142
Well ****!
__________________________________________________ ___________________________________
Parts required:
56028371AA Ignition Wire Shield

Repair procedure:
1. Cut insulator sleeve, p/n 56028371AA, to make two (2) insulator sleeves about 25-30 mm (1 in.) in length. See diagram.
2. Install one sleeve around injector #3, with the slit on the upward facing side of the injector. Install the other sleeve with the slit on the downward facing side of the injector.
3. Confirm sleeve is flush to intake manifold surface around injector.
4. Check injector #3 wire and ensure that the injector is rotated to a 2 o'clock position.
TSB for the cold start rough idle and P0303 code: TSB 18-010-01
__________________________________________________ _______________________________


I say that and just thought I had to remove the injector.

01 TJ, 34 Super Swaper 34x10.5 bias, Winch, locked, belly up, some armor, 4.0, 5spd
Ross is offline  
post #13 of 17 Old 06-21-2011, 12:24 PM
FJ40convert7
Registered User
2004 TJ Wrangler 
 
Join Date: Feb 2011
Location: Fort Myers
Posts: 41
I have an 04 Rubicon that just gave me that code on friday. Changed the plugs and have not had an issue YET. Cheap fix so far!
FJ40convert7 is offline  
post #14 of 17 Old 06-21-2011, 12:30 PM
Ross
Registered User
2001 TJ Wrangler 
 
Join Date: Dec 2002
Posts: 12,142
Quote:
Originally Posted by FJ40convert7 View Post
I have an 04 Rubicon that just gave me that code on friday. Changed the plugs and have not had an issue YET. Cheap fix so far!
If it is the same issue you will know. If the motor is hot, it is a hot day, and you jeep is harder to start and then runs like crap for about 30 seconds you will probably benefit from this TSB.

01 TJ, 34 Super Swaper 34x10.5 bias, Winch, locked, belly up, some armor, 4.0, 5spd
Ross is offline  
post #15 of 17 Old 06-21-2011, 01:17 PM
Knuckelhead
AFSOC Retired
 
Knuckelhead's Avatar
2000 TJ Wrangler 
 
Join Date: Aug 2005
Location: Colorado
Posts: 19,140
Quote:
Originally Posted by Ross View Post
If it is the same issue you will know. If the motor is hot, it is a hot day, and you jeep is harder to start and then runs like crap for about 30 seconds you will probably benefit from this TSB.
It worked for my 2000 Sport...
Knuckelhead is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
P0303, and nothing else TheHeretic TJ Wrangler Technical Forum 12 12-09-2010 06:21 PM
Code P0303 mcastro70 TJ Wrangler Technical Forum 5 09-04-2010 09:32 AM
Overheat then P0303 code aerojeeptj TJ Wrangler Technical Forum 1 08-22-2010 12:24 AM
loud engine tap and code p0303 mytj TJ Wrangler Technical Forum 3 01-14-2010 11:47 PM
Check Engine Light on...P0303 is the code udrainville TJ Wrangler Technical Forum 6 08-03-2007 07:11 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome