post #1 of Old 05-22-2011, 10:41 AM Thread Starter
kempracing
Registered User
1991 YJ Wrangler 
 
Join Date: Mar 2011
Location: leroy
Posts: 21
LJ idle problem

I have a 06 wrangler unlimited and its having an idle problem, sometimes it will idle fine at about 800rpm, and then it will jump up to 1200 to 1400 , can anyone tell me where to start looking for the problem, I have check the intake for a leak by spraying starting fluid around it and nothing , I have looked at the vac. lines but can find anything that looks bad , can someone HELP ME










l

kempracing is offline  
post #2 of Old 05-22-2011, 10:49 AM
TheBoogieman
Disturbed!
 
TheBoogieman's Avatar
2003 TJ Wrangler 
 
Join Date: Aug 2006
Location: CharlottesHELL
Posts: 32,194
TheBoogieman is offline  
post #3 of Old 05-22-2011, 10:54 AM
GOLENJEEPTJ
Running Secretly Amok!
 
GOLENJEEPTJ's Avatar
2002 TJ Wrangler 
 
Join Date: May 2007
Location: Ventura ,CA.
Posts: 9,712
Yep... it sound throttle body related.
GOLENJEEPTJ is online now  
post #4 of Old 05-22-2011, 01:22 PM
Garza
Vendor
 
Garza's Avatar
2005 LJ Wrangler 
 
Join Date: Mar 2010
Location: Las Vegas
Posts: 1,534
I cleaned mine this morning so it's funny I stumbled upon this thread.

That link above will start you in the right direction....our '04-'06 TJ/LJ's are a tad different. I'm just posting this in case you want to clean it. I highly recommend unplugging all sensor harnesses on the TB and completely removing it to clean it. It is very simple!! You will need some torx bits if you already don't.


Here are some pics of what you will be looking at. As you can see mine was dirty, BUT my engine is running fine. I simply woke up this morning and decided I wanted to clean it I cleaned mine all up with throttle body cleaner. I did pull the o-rings off the IAC before I cleaned it. I didn't take any after pics because it's kind of self explanatory. If you have any questions feel free to ask.

OH and FWIW.....I will completely blame the previous K&N filter I had on there for my IAC even getting this dirty at only 36K!!!!

Ricky




Garza is offline  
post #5 of Old 05-23-2011, 07:54 PM Thread Starter
kempracing
Registered User
1991 YJ Wrangler 
 
Join Date: Mar 2011
Location: leroy
Posts: 21
Thank you all that put a post on here about my problem , I took it apart tonight and clean it out , it was worst than the one that garza posted , Now my LJ is idling the way its suppose to , So THANK YOU VERY MUCH !!!!!
kempracing is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
88 2.5l. idle problem!!! thejohnson486 YJ Wrangler Technical Forum 3 03-02-2011 12:55 PM
91 YJ Idle Problem YJ_Rick YJ Wrangler Technical Forum 3 03-18-2009 08:37 AM
92 YJ Idle Problem ANJEEP69 YJ Wrangler Technical Forum 1 08-19-2008 10:47 AM
FINALLY! fixed idle problem and stalling problem Big-n-Broke-YJ YJ Wrangler Technical Forum 4 02-28-2006 07:50 PM
Idle Problem mikeyhaken TJ Wrangler Technical Forum 1 03-03-2002 10:02 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome