Knockin Comin from Front of motor - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > Knockin Comin from Front of motor

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits Rough Country Jeep Suspension Deals at Rockridge 4WD!

Reply
Unread 04-12-2008, 05:40 PM   #1
MercuryTec
Registered User
2004 TJ Wrangler 
 
Join Date: Mar 2008
Location: Fl
Posts: 234
Knockin Comin from Front of motor

When i started my 4.0 L my ears were not pleased. i heard a very bad knockin sound . Cleared up mostly after 20 sec but now i can here it tick for about 15 secs then goes away for little while or some times come and goes agian . I Believe it may be come from Vavles or posibly from somethin belt driven. Any help would be nice

MercuryTec is offline   Reply With Quote
Unread 04-12-2008, 05:43 PM   #2
tangofox007
Web Wheeler
 
Join Date: May 2005
Location: GA
Posts: 5,911
Could be the harmonic balancer.
tangofox007 is offline   Reply With Quote
Unread 04-12-2008, 05:43 PM   #3
MercuryTec
Registered User
2004 TJ Wrangler 
 
Join Date: Mar 2008
Location: Fl
Posts: 234
How would it be clicking though ?
MercuryTec is offline   Reply With Quote
Unread 04-12-2008, 05:44 PM   #4
MercuryTec
Registered User
2004 TJ Wrangler 
 
Join Date: Mar 2008
Location: Fl
Posts: 234
Also sounds like it may drop about 50 rpm or so
MercuryTec is offline   Reply With Quote
Unread 04-12-2008, 07:08 PM   #5
MercuryTec
Registered User
2004 TJ Wrangler 
 
Join Date: Mar 2008
Location: Fl
Posts: 234
Bump any 1
MercuryTec is offline   Reply With Quote
Unread 04-12-2008, 09:06 PM   #6
snstj
Registered User
1997 TJ Wrangler 
 
Join Date: Jan 2008
Location: washington
Posts: 227
tic sound with a drop in rpm could be a bad plug wire,look at the wires at night you might be able to see the spark jumping to ground. the knock on start up may be more serious, i would have a tech you trust look at it.
snstj is offline   Reply With Quote
Unread 04-12-2008, 09:09 PM   #7
MercuryTec
Registered User
2004 TJ Wrangler 
 
Join Date: Mar 2008
Location: Fl
Posts: 234
Dont have plug wires i have The distrubter less ignition
MercuryTec is offline   Reply With Quote
Unread 04-12-2008, 09:12 PM   #8
snstj
Registered User
1997 TJ Wrangler 
 
Join Date: Jan 2008
Location: washington
Posts: 227
my bad! is it coil on plug, they have boots and can leak.
snstj is offline   Reply With Quote
Unread 04-12-2008, 09:21 PM   #9
87warrior
Registered User
2003 TJ Wrangler 
 
Join Date: Sep 2004
Location: Junction City, Kansas
Posts: 1,590
When I owned a YJ, I was able to stretch the timming chain that would slap the timming chain cover. I replaced the gear set and chain. However this would not "go away" after warming up.

I would suggest isolating the problem. Grab a crowbar and place the pointed end at various places on the engine block/head with it running. Place your ear at the curved part of the crowbar listening for the particular noise you are hearding. When you isolate the noise it will be easier to diagnose and fix.
__________________
03 Rubicon(Rubicon build)
92 Comanche (92/99 Comanche Project)
86 Comanche (Heavy Four)
87warrior is offline   Reply With Quote
Unread 04-12-2008, 09:51 PM   #10
MercuryTec
Registered User
2004 TJ Wrangler 
 
Join Date: Mar 2008
Location: Fl
Posts: 234
Well i was just doing that but with a slide hammer with weitgh removed i swear coming from #1 cyl at valve cover vavle problem like i said it realy bad at a cold start up
MercuryTec is offline   Reply With Quote
Unread 04-12-2008, 10:39 PM   #11
MercuryTec
Registered User
2004 TJ Wrangler 
 
Join Date: Mar 2008
Location: Fl
Posts: 234
Alright its not spark arching 100% sure i do know wat spark arching sounds like , and i checked anyways its well dark out nothin arching to block . Broke out the trusty slide hammer agian . When i go to the cyl num 1 valve cover bolt i can here the tick clear as day it goes slight tick to a pretty loud 1 . I checked all the other cylinders , dont seem to be making the loud tick a slight 1 but not loud so im pretty sure its #1cyl .
MercuryTec is offline   Reply With Quote
Unread 04-12-2008, 10:42 PM   #12
MercuryTec
Registered User
2004 TJ Wrangler 
 
Join Date: Mar 2008
Location: Fl
Posts: 234
Think i should just take valve cover of or bring it back to the dealer for the 5th time in last month it is still under powertrain warranty.
MercuryTec is offline   Reply With Quote
Unread 04-13-2008, 01:25 AM   #13
ErnieG
Registered User
1998 TJ Wrangler 
 
Join Date: Jun 2007
Location: Ft Carson, colorado
Posts: 218
sounds like a dirty lifter to me.. take the valve cover off and run the engine for a few secs see if you can isolate the noise that way
__________________
98 tj nothing special im too poor :(
ErnieG is offline   Reply With Quote
Unread 04-13-2008, 09:24 AM   #14
MercuryTec
Registered User
2004 TJ Wrangler 
 
Join Date: Mar 2008
Location: Fl
Posts: 234
Think i should go ahead and do it even though under warranty i can see them sayin not covered anyways . Any 1 know if the vavle cover gasket going to hold up when i remove the valve cover ?
MercuryTec is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.