just a water pump question - JeepForum.com
 
LinkBack Thread Tools
post #1 of 5 Old 07-04-2013, 01:56 AM Thread Starter
romiin
Registered User
2000 TJ Wrangler 
 
Join Date: Sep 2006
Location: canada
Posts: 121
just a water pump question

I noticed my jeep leaking antifreeze when I shut it off. when its running it stops leaking. its dripping off the harmonic balancer. i took out the pump, but of course you wreck the gasket so I am not sure if it was a gasket problem. any one had this happen. the little seep hole on the top of the pump was'nt seeping any fluid, all the hoses look good thermostat isn't leaking. I'm kinda stumped.

2000 tj 4L


00 sahara
romiin is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 07-04-2013, 02:01 AM
Necko2529
Registered User
2003 TJ Wrangler 
 
Join Date: May 2011
Location: Brookfield
Posts: 2,569
Did you reinstall the pump with a new gasket? Is it still leaking?

Rokmen TT, Rokmen control arms, Novak NV241 cable shifter, JKS 1.25" BL + 1" MML.

Anybody can take advice if it doesn't interfere with their plan.

RIP "Prescott 19" Prescott Fire Department
Necko2529 is offline  
post #3 of 5 Old 07-04-2013, 09:49 AM
marka2k
Registered User
2006 WK 
 
Join Date: Dec 2011
Location: Tulsa
Posts: 636
I had a similar issue with my 2000 WJ I6 the thermostat housing where the top radiator hose attaches was eaten away at the lip and coolant was seeping out from there, I ended up replacing the housing (Autozone $10) and hose since it was soft in the area where the coolant was leaking, since you already pulled the pump I would replace the gasket and reinstall and see as mentioned above, if its still doing it check the thermostat housing.

Hope this helps

Silver WK Club #46
06 WK Overland

04 Rubicon

2000 Grand Cherokee

2006 Commander Limited - Wife's
marka2k is offline  
post #4 of 5 Old 07-04-2013, 08:21 PM Thread Starter
romiin
Registered User
2000 TJ Wrangler 
 
Join Date: Sep 2006
Location: canada
Posts: 121
necko, I think your onto something there. But as luck would have it, the pump had a life time warrenty. so I put a new pump in, doesnt leak anymore. I did think too it might of been the gasket. The original pump started leaking at about 60,000 miles. this after market one(made in china) had about 85,000 miles on it. so i thought it was time to change the pump. so much for original equipment being better

thanks for the input

00 sahara
romiin is offline  
post #5 of 5 Old 07-04-2013, 08:42 PM
Necko2529
Registered User
2003 TJ Wrangler 
 
Join Date: May 2011
Location: Brookfield
Posts: 2,569
As long as its not leaking all should be well. If leaking out the weep hole the pump is bad if between the block and pump i would suspect the gasket is bad...

Good luck.

Rokmen TT, Rokmen control arms, Novak NV241 cable shifter, JKS 1.25" BL + 1" MML.

Anybody can take advice if it doesn't interfere with their plan.

RIP "Prescott 19" Prescott Fire Department
Necko2529 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome