Just bought an 05 Wrangler and having a few major issues need help quick - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > Just bought an 05 Wrangler and having a few major issues need help quick

Poison Spyder DeFender Inner Fender KitsCess Recovery Gear Snatch Tow Strap OffRoad @ ROCKRIDGE4WDJEEP Gear Change Packages From ROCKRIDGE 4WD. We Are DIFF

Reply
Unread 06-12-2011, 12:02 AM   #1
evanmullins1986
Registered User
2005 TJ Wrangler 
 
Join Date: Jun 2011
Location: Kingsport, TN
Posts: 6
Just bought an 05 Wrangler and having a few major issues need help quick

I purchased a 2005 Jeep Wrangler with 85,000 miles on it about a month ago. Thinking it would be a fun vehicle to own and drive well it has quickly became a nightmare !!

I had only had it 3 days and the plastic position clip that secures the linkage to the gear selector broke, then yesterday I had to have a water pump replaced because it was leaking (when NOT under preasure) and now I have another issue and dont know what is going on.

For a week or so I noticed it was kind of missing and also had a squeak coming from the rear drivers side as the brake peddle was applied and let out ( not al the time but sometimes) NOW starting today it has an even rougher idle the rpms fall suddenly from the normal idle range to practically nothing then rise to about 1200 then back to normal then down again. ( this also is not something that is continues) The rough idle however is almost constant in any gear. It seems to smooth out to almost normal when the A/C compresor is engaged but will almost stall when it is turned off but recovers. Also there seems to be a very slight hesitation when the gas peddle is applied.

I have been told this could be several things but would like to hear some opinions. I checked for a vac leak using carb cleaner on the engine but it doesnt seem to have one. I really need this Jeep running properly ASAP so all advice is desperatley needed!!

Also another issue that is a real pain is that my two center vents dont blow out any air on A/C, heat, fan, doesn't matter. The other vents all work properly so if anyone can help there I thank you also.

evanmullins1986 is offline   Reply With Quote
Unread 06-12-2011, 04:50 AM   #2
4banged
Registered User
2003 TJ Wrangler 
 
Join Date: May 2010
Location: connecticut
Posts: 694
What engine do you have? I recently replaced the waterpump on my 03 wrangler 2.4l engine when I did the timing belt...the 1st time I did it I was off a tooth on the timing belt and it ran but I knew it wasn't right (idle was weird and not as much power) so I did it again and got it perfect - runs great now.
As for the ac vents...mine had that issue when I test drove it at the dealer I bought it from and he took care of it ...said it was a fuse but I'm not sure where its located.
Good luck...hope you have a good set of tools...these things like to be worked on. Highly recommend a fridge with beer in the garage to keep you hydrated ;-)
4banged is offline   Reply With Quote
Unread 06-12-2011, 05:52 AM   #3
rockwallchamp09
Registered User
1997 TJ Wrangler 
 
Join Date: Sep 2010
Location: Buckley, WA
Posts: 58
ever heard of the lemon law i think whomever sold it to you broke said law was it from dealership by any chance id would send it back unless you did this the first day you got it
mud-run.jpg  
rockwallchamp09 is offline   Reply With Quote
Unread 06-12-2011, 08:38 AM   #4
Garza
Vendor
 
Garza's Avatar
2005 LJ Wrangler 
 
Join Date: Mar 2010
Location: Las Vegas, NV
Posts: 1,439
Try this first for your idle problem.

http://www.jeepforum.com/forum/f9/lj.../#post11584239

RG
__________________
'05 LSJ
www.4lowparts.com
Black Magic Brakes
Garza is online now   Reply With Quote
Unread 06-12-2011, 10:15 AM   #5
evanmullins1986
Registered User
2005 TJ Wrangler 
 
Join Date: Jun 2011
Location: Kingsport, TN
Posts: 6
The Jeep is the 4.0 L. I did buy it from a used car dealer
evanmullins1986 is offline   Reply With Quote
Unread 06-12-2011, 11:48 AM   #6
Smeg
Registered User
2006 TJ Wrangler 
 
Join Date: Jul 2010
Location: Newport News, Virginia
Posts: 350
Quote:
Originally Posted by rockwallchamp09 View Post
ever heard of the lemon law i think whomever sold it to you broke said law was it from dealership by any chance id would send it back unless you did this the first day you got it
Lemon law usually pertains to new cars, not 7 year old cars. Good luck with that.

Quote:
Tennessee Lemon Law 55-24-202. Nonconforming vehicles - Reports - Repairs.
If a new motor vehicle does not conform to all applicable express warranties and the consumer reports the nonconformity, defect or condition to the manufacturer, its agent or its authorized dealer during the term of protection, the manufacturer, its agent or its authorized dealer shall correct the nonconformity, defect or condition at no charge to the consumer, notwithstanding the fact that such repairs are made after the expiration of such term. Any corrections or attempted corrections undertaken by an authorized dealer under the provisions of this section shall be treated as warranty work and billed by the dealer to the manufacturer in the same manner as other work under warranty is billed.
History
http://www.lemonlawamerica.com/Tenne...w-Statutes.htm

Also, most dealers have a 30-90 warranty, might see what they will honor, unless, it was marked "As is"
__________________
'06 TJ Yellow nothing special
'12 WK2 Laredo Black w/Shiny pretty chrome all over it - Wife's
Smeg is offline   Reply With Quote
Unread 06-12-2011, 12:24 PM   #7
Richd1963
Senior Member
 
Richd1963's Avatar
2005 TJ Wrangler 
 
Join Date: Apr 2009
Location: Pasadena, CA
Posts: 737
Allot of good info here. I would definitely be checking everything on that jeep since taking ownership. Used car lots usually just do the bare minimum to get a car sold. I would start by inspecting all the spark plug wires, air filter spark plugs. I am not sure how mechanically inclined yo are, but the Throttle body cleaning maybe something you would want to inspect and consider.
Don't be too discouraged. It sounds like just a case of a little bad luck is all. Sometimes *hit happens coincidentally and you just hit it at that time. I bet if you get a few of these minor bugs worked out, you will be more than happy with your TJ. The brakes probably should get a good inspection too as well as all fluid levels in the differentials and transfer case. Have it gone through and if you don't have proof of any recent services, I would start having them done so you will have a benchmark for the future. I know it costs money, even if you can do it yourself. The materials are somewhat costly especially if you use the recommended ones, which I strongly recommend. But in the long run, I think you will be pleased, it will just be a little time before you get some peace of mind.

This is one of the draw backs with buying a previously owned vehicle from some one or place that will not fully warranty the vehicle for any reasonable length of time. Hence the brake light warranty and this usually results in the seller not taking that great of care of such vehicle. Whereas the dealer and new vehicles are well maintained and taken care of, because they really don't want you coming back, and since it is warranty work, they really don't make much money on the jobs, although the MFR reimburses the dealership for warranty repairs. Of course I am getting off track and am sorry, just needed to show difference in benefits between buying used vs. NEW.

Save up and do the most important services first and so on. We all wish you luck and success.
__________________
Rich G. 2005 Wrangler 4.0 6-Speed.
just4effect 10" single sub, enclosure and amp 4 sale. PM me if interested, local only
Richd1963 is offline   Reply With Quote
Unread 06-12-2011, 01:54 PM   #8
200xva
Registered User
2002 TJ Wrangler 
 
Join Date: Feb 2011
Location: beaufort, sc
Posts: 61
i went out mudding the other day and about a weak later the jeep started ideling crazy on start up alot like you what you described changed airfilter and runs like a champ. by looking at the air filter it didnt look that bad but for 13 dollars figured i would try it first. anyway just something else to look at.
200xva is offline   Reply With Quote
Unread 06-12-2011, 04:14 PM   #9
evanmullins1986
Registered User
2005 TJ Wrangler 
 
Join Date: Jun 2011
Location: Kingsport, TN
Posts: 6
Thanks for all the great replies. The jeep doesn't seem to idle and hesitate all the time. It just kind of comes and goes. Take it does have a miss in it from needing plugs which I plan to change tomorrow but the bad rpm stumble just occurs on occasion. I put seafoam in the fuel so I am hoping that helps. I am also going to spray the throttle body out.

I am still trying to find the reason the vents don't work so any input on that is greatly needed ! I am having trouble locating the vacuum hoses and canister under the hood. Does anyone have a pic of this or a video of how to check them ? I am not much of a mechanic but I am tired of spending money on this thing so I appreciate your knowledge.
evanmullins1986 is offline   Reply With Quote
Unread 06-12-2011, 05:31 PM   #10
nmj48
Registered User
2005 TJ Wrangler 
 
Join Date: Mar 2009
Location: canada
Posts: 255
the mode door actuators (directs air to your vents) are vacuum operated. the vacuum reservoir is located under the battery tray. on the drivers side of the intake ( kind of underneath it) there is a vacuum line that pops off sometimes. this line runs along the top of the firewall to the reservoir under the battery.
nmj48 is offline   Reply With Quote
Unread 06-12-2011, 06:07 PM   #11
Recoil
Registered User
1988 MJ Comanche 
 
Join Date: Oct 2007
Location: Indiana
Posts: 1,864
Look straight at your engine. You will see the air tube coming out of the throttle body quick is mounted to the intake manifold. On the right side of the I take manifold towards the middle the should be a vacuum line plugged in. If all you see is a nipple coming off the manifold find the line and plug it in. Then watch your idle balance out and you vents work properly.


I hope this fixes your problem
__________________
www.indyorv.com

\/ \/ \/
EPIC
Recoil is offline   Reply With Quote
Unread 06-12-2011, 06:50 PM   #12
evanmullins1986
Registered User
2005 TJ Wrangler 
 
Join Date: Jun 2011
Location: Kingsport, TN
Posts: 6
I am still having trouble locating the vacuum can. My battery is on the passenger side but I don't see the vac lines. Sorry I know dumb of me !
evanmullins1986 is offline   Reply With Quote
Unread 06-12-2011, 08:32 PM   #13
nmj48
Registered User
2005 TJ Wrangler 
 
Join Date: Mar 2009
Location: canada
Posts: 255
remove the battery and the battery tray, the reservoir is underneath

http://www.jeep4x4center.com/jeep-service-manuals/Jeep_Wrangler_TJ/2003/Heating_and_Air_Conditioning.swf#toolbar=0

check out the link, its for 2003 but yours should be the same. vacuum reservor is on pg 31. the link also contains procedures to test it

Last edited by nmj48; 06-12-2011 at 08:43 PM.. Reason: added link
nmj48 is offline   Reply With Quote
Unread 06-12-2011, 09:02 PM   #14
Richd1963
Senior Member
 
Richd1963's Avatar
2005 TJ Wrangler 
 
Join Date: Apr 2009
Location: Pasadena, CA
Posts: 737
I know on my 4.0 when the vacuum hose comes off the intake manifold, it renders the vent controls on my ac and heat in operable. I go out and re attach the hose and everything works fine. My hose is worn out and the rubber doesn't quite grab and hold like it used to. I used a super small zip Tye to restore some tightness to the hose and it hasn't come lose since. But anytime my controls go to crap, that's where I look. its just across and under the master cyl.
__________________
Rich G. 2005 Wrangler 4.0 6-Speed.
just4effect 10" single sub, enclosure and amp 4 sale. PM me if interested, local only
Richd1963 is offline   Reply With Quote
Unread 06-12-2011, 09:13 PM   #15
robncar
We Got The Cup, AGAIN!!!
 
robncar's Avatar
2005 TJ Wrangler 
 
Join Date: Nov 2005
Location: La Verne, CA
Posts: 8,251
Clean the IAC (I-dle A-ir C-ontroller) on the throttle body. On the '05 you'll need a T-20 torx driver, a small mirror will help you see the single torx screw, a tooth brush, and a large can of throttle body cleaner.

Don't get discouraged, once you get the little things sorted out you'll be fine.

Sent from my DROID2 using JeepForum
robncar is offline   Reply With Quote
Reply

Tags
rough idle , rpm increase , stall issue , vents
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.