Jeep wont rev up. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > Jeep wont rev up.

Smittybilt Products at Oconee Off-Road!Trick Tabs - NalinMFG.comCCOR is your 1 stop source for everything Jeep!

Reply
Unread 11-15-2010, 01:29 PM   #1
Farmkid
Registered User
1997 TJ Wrangler 
 
Join Date: May 2010
Location: Jackson, AL, Alabama
Posts: 195
Jeep wont rev up.

This morning on my way home my jeep started spittin and sputtern. Then it would clear up and start running normal again. It done this about 2 different times before it finally let me down. The engine will idle but misses, it wont rev up beyond about 2000 rpms. It wont even pull itself foward. I checked the codes and nothing pops up. When it idles it sounds like it it having trouble sucking air because the air box intake is very loud and doesn't sound normal.

Farmkid is offline   Reply With Quote
Unread 11-15-2010, 01:35 PM   #2
05TurboS2K
Registered User
2004 TJ Wrangler 
 
Join Date: Dec 2008
Location: Corona, CA
Posts: 1,737
Check for spark by pulling the plugs one by one and cranking a little to test spark.

Next test for fuel, there's a nut on the fuel rail just remember its fairly high pressure.

Double check there's nothing causing it to starve for air, AND make sure the exhaust isn't clogged such as a CAT that's plugged.

I'd think you'd be throwing a code from most of these but stranger things have happened.

Anyone more knowledgeable care to chime in?
05TurboS2K is offline   Reply With Quote
Unread 11-15-2010, 01:40 PM   #3
Farmkid
Registered User
1997 TJ Wrangler 
 
Join Date: May 2010
Location: Jackson, AL, Alabama
Posts: 195
I can assure it's not the cat as the previous owner handled that situation. This morning while I was waiting to get pulled home I tapped on the IAC while it was idling and it seemed to clear up and idle smooth for a couple of seconds but went right back to running rough.
Farmkid is offline   Reply With Quote
Unread 11-15-2010, 01:59 PM   #4
GOLENJEEPTJ
Running Secretly Amok!
 
GOLENJEEPTJ's Avatar
2002 TJ Wrangler 
 
Join Date: May 2007
Location: Ventura ,CA., California
Posts: 9,672
When is the last time you did a complete tune up?I would check first cap and rotor,plugs,wires,cleaning the throttle body,air filter,etc.
GOLENJEEPTJ is offline   Reply With Quote
Unread 11-15-2010, 02:01 PM   #5
GOLENJEEPTJ
Running Secretly Amok!
 
GOLENJEEPTJ's Avatar
2002 TJ Wrangler 
 
Join Date: May 2007
Location: Ventura ,CA., California
Posts: 9,672
Sounds like a possible 02 sensor also.
GOLENJEEPTJ is offline   Reply With Quote
Unread 11-15-2010, 02:05 PM   #6
j_niko
Registered User
2000 TJ Wrangler 
 
Join Date: Nov 2009
Location: Cleveland
Posts: 1,165
Change dist cap and rotor. Possibly wires, but there would have to be more than one bad to make it do that, I would think.


Also, does it seem to do it worse when it is raining or there is moisture in the air?
__________________
2000 - Sahara
1997 - Sahara
j_niko is offline   Reply With Quote
Unread 11-15-2010, 02:10 PM   #7
Farmkid
Registered User
1997 TJ Wrangler 
 
Join Date: May 2010
Location: Jackson, AL, Alabama
Posts: 195
I did a tune up about complete tune up about 3000 miles ago. Yes it was raining this morning. That crossed my mind this morning but couldn't figure it out.
Farmkid is offline   Reply With Quote
Unread 11-15-2010, 02:15 PM   #8
GOLENJEEPTJ
Running Secretly Amok!
 
GOLENJEEPTJ's Avatar
2002 TJ Wrangler 
 
Join Date: May 2007
Location: Ventura ,CA., California
Posts: 9,672
Does it react the same whether the engine is cold or warmed up.
GOLENJEEPTJ is offline   Reply With Quote
Unread 11-15-2010, 02:16 PM   #9
GOLENJEEPTJ
Running Secretly Amok!
 
GOLENJEEPTJ's Avatar
2002 TJ Wrangler 
 
Join Date: May 2007
Location: Ventura ,CA., California
Posts: 9,672
What did your tune up consist of?Elaborate.
GOLENJEEPTJ is offline   Reply With Quote
Unread 11-15-2010, 02:27 PM   #10
Farmkid
Registered User
1997 TJ Wrangler 
 
Join Date: May 2010
Location: Jackson, AL, Alabama
Posts: 195
Plugs, wires, cap, rotor, air filter. It ran fine this morning until it got to normal temp. It was starting to rain this morning if that helps.
Farmkid is offline   Reply With Quote
Unread 11-15-2010, 02:30 PM   #11
j_niko
Registered User
2000 TJ Wrangler 
 
Join Date: Nov 2009
Location: Cleveland
Posts: 1,165
I'll stick with dist cap
__________________
2000 - Sahara
1997 - Sahara
j_niko is offline   Reply With Quote
Unread 11-15-2010, 03:25 PM   #12
GOLENJEEPTJ
Running Secretly Amok!
 
GOLENJEEPTJ's Avatar
2002 TJ Wrangler 
 
Join Date: May 2007
Location: Ventura ,CA., California
Posts: 9,672
Try unplugging the upstream 02 sensor and see if it revs.
GOLENJEEPTJ is offline   Reply With Quote
Unread 11-15-2010, 04:13 PM   #13
Farmkid
Registered User
1997 TJ Wrangler 
 
Join Date: May 2010
Location: Jackson, AL, Alabama
Posts: 195
Got up this evening and went to crank it up. It ran perfect for about 20 seconds then went back to sounding like it only has 3cyl out of the 6 working
Farmkid is offline   Reply With Quote
Unread 11-15-2010, 04:16 PM   #14
slafferty
Registered User
2000 TJ Wrangler 
 
Join Date: Sep 2008
Location: Kimbolton, Ohio
Posts: 1,403
i say its a cat..
__________________
'00 TJ, 4.0, nv3550 spd, E-lockers Front and Rear, 4.88 gears. Homebuilt Bumpers/ tube doors.. Homebuilt Long Arm in the making... 35 inch MT-R's ordered[QUOTE=RUBtjICON;9622056]If you arent scratching it, you arent trying hard enough :tea:[/QUOTE]

[U][I][B]MY BUILD THREAD[/B][/I][/U]
[URL="http://www.jeepforum.com/forum/f22/slaffertys-2000-tj-build-1121555/index2.html"][COLOR="RoyalBlue"][SIZE="4"]http://www.jeepforum.com/forum/f22/slaffertys-2000-tj-build-1121555/index2.html[/SIZE][/COLOR][/URL]
slafferty is offline   Reply With Quote
Unread 11-15-2010, 04:45 PM   #15
Farmkid
Registered User
1997 TJ Wrangler 
 
Join Date: May 2010
Location: Jackson, AL, Alabama
Posts: 195
There is no cat.
Farmkid is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.