JEEP just died. . . . please help - JeepForum.com
Reply
 
LinkBack Thread Tools
post #1 of 22 Old 01-11-2009, 12:24 PM Thread Starter
Ajl9791
Registered User
2004 TJ Wrangler 
 
Join Date: Aug 2007
Location: CT
Posts: 203
JEEP just died. . . . please help

Hey everyone , make a long story short. In the past few weeks my 04 rubicon has had "labored" starts.I though it was a battery on the way out so I purchased a new Legend 75 at NAPA yesterday and put it in.My old battery was the original and I figured 5 years ..its time.Fired it up with the new battery and it still seemed like it didnt have the great turnover speed that it always did.Went to work at 4 in the am and it started ok, going home ..not great.Then I pulled into my parking spot and figured Id try it again and it barely turned over.Interior ,radio ,gauge cluster ,fan ,fuel pump ,everything works .Tried it again ...nothing , no click , no noise at all.Checked every fuse, dont know if the starter relay crapped out(any way to check?) ,checked connections to the starter ,battery all the electrical.Is my starter gone? 63K .Any help would be great,I have to "drive" this rig to work tomorrow..or not .Thanks guys


Last edited by Ajl9791; 01-11-2009 at 12:37 PM.
Ajl9791 is offline  
Sponsored Links
Advertisement
 
post #2 of 22 Old 01-11-2009, 12:26 PM
GOLENJEEPTJ
Running Secretly Amok!
 
GOLENJEEPTJ's Avatar
2002 TJ Wrangler 
 
Join Date: May 2007
Location: Ventura ,CA.
Posts: 9,713
Can you jump start it still or no?
GOLENJEEPTJ is offline  
post #3 of 22 Old 01-11-2009, 12:27 PM
visa
Registered User
1994 YJ Wrangler 
 
Join Date: Jan 2009
Location: wyoming
Posts: 99
whats the oil look like? high compresion
visa is offline  
post #4 of 22 Old 01-11-2009, 12:28 PM
GOLENJEEPTJ
Running Secretly Amok!
 
GOLENJEEPTJ's Avatar
2002 TJ Wrangler 
 
Join Date: May 2007
Location: Ventura ,CA.
Posts: 9,713
What????^^
GOLENJEEPTJ is offline  
post #5 of 22 Old 01-11-2009, 12:29 PM Thread Starter
Ajl9791
Registered User
2004 TJ Wrangler 
 
Join Date: Aug 2007
Location: CT
Posts: 203
I havent tried I just got home ,jumped on the forum , it seems to have plenty of power to everything ,no starter click though.
Ajl9791 is offline  
post #6 of 22 Old 01-11-2009, 12:30 PM Thread Starter
Ajl9791
Registered User
2004 TJ Wrangler 
 
Join Date: Aug 2007
Location: CT
Posts: 203
oil is alittle bit low , I use mobil 1 10W30
Ajl9791 is offline  
post #7 of 22 Old 01-11-2009, 12:30 PM
PILL
Registered User
1997 TJ Wrangler 
 
Join Date: May 2008
Location: Texas
Posts: 1,002
Is it a standard? If so, have you tried bump starting it?

Member 134 of the White Jeep Club
31" BFG A/T's, 130w KC Hilites
PILL is offline  
post #8 of 22 Old 01-11-2009, 12:31 PM Thread Starter
Ajl9791
Registered User
2004 TJ Wrangler 
 
Join Date: Aug 2007
Location: CT
Posts: 203
during this battery thing the jeep seemed to not be running the best .I just thought on my way home that the power wasnt really there...not sure though could be in my head
Ajl9791 is offline  
post #9 of 22 Old 01-11-2009, 12:32 PM
GOLENJEEPTJ
Running Secretly Amok!
 
GOLENJEEPTJ's Avatar
2002 TJ Wrangler 
 
Join Date: May 2007
Location: Ventura ,CA.
Posts: 9,713
Try a jump start! If not able too ,I'm going to say starter.Check the connections at starter also!

Last edited by GOLENJEEPTJ; 01-11-2009 at 12:42 PM.
GOLENJEEPTJ is offline  
post #10 of 22 Old 01-11-2009, 12:32 PM Thread Starter
Ajl9791
Registered User
2004 TJ Wrangler 
 
Join Date: Aug 2007
Location: CT
Posts: 203
havent tried a bump start
Ajl9791 is offline  
post #11 of 22 Old 01-11-2009, 12:33 PM
GOLENJEEPTJ
Running Secretly Amok!
 
GOLENJEEPTJ's Avatar
2002 TJ Wrangler 
 
Join Date: May 2007
Location: Ventura ,CA.
Posts: 9,713
If your running on a bad or low battery, it can affect the performance.
GOLENJEEPTJ is offline  
post #12 of 22 Old 01-11-2009, 12:33 PM Thread Starter
Ajl9791
Registered User
2004 TJ Wrangler 
 
Join Date: Aug 2007
Location: CT
Posts: 203
I'll give the jump start a go. thanks guys
Ajl9791 is offline  
post #13 of 22 Old 01-11-2009, 12:35 PM Thread Starter
Ajl9791
Registered User
2004 TJ Wrangler 
 
Join Date: Aug 2007
Location: CT
Posts: 203
I just don't understand putting a new battery in yesterday that it died with little warning
Ajl9791 is offline  
post #14 of 22 Old 01-11-2009, 12:35 PM Thread Starter
Ajl9791
Registered User
2004 TJ Wrangler 
 
Join Date: Aug 2007
Location: CT
Posts: 203
<---- no cables S@#T
Ajl9791 is offline  
post #15 of 22 Old 01-11-2009, 12:43 PM
GOLENJEEPTJ
Running Secretly Amok!
 
GOLENJEEPTJ's Avatar
2002 TJ Wrangler 
 
Join Date: May 2007
Location: Ventura ,CA.
Posts: 9,713
Is your voltmeter showing charging when engine runs?Is the cel on?
GOLENJEEPTJ is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
My jeep died blackrimstj TJ Wrangler Technical Forum 14 09-18-2008 01:05 PM
My Jeep just died... Neversober YJ Wrangler Technical Forum 11 07-23-2007 07:04 AM
Jeep died kevin A Whitler YJ Wrangler Technical Forum 9 05-25-2007 10:23 PM
Jeep died on me RockinXJ TJ Wrangler Technical Forum 8 09-19-2006 12:16 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome