JEEP just died. . . . please help - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > JEEP just died. . . . please help

Cess Recovery Gear Snatch Tow Strap OffRoad @ ROCKRIDGE4WD15 x 8 Black D-Window Steel Wheels Set of 4Magnaflow SS Cat Back Exhaust System, Street, High Clearan

Reply
Unread 01-11-2009, 12:24 PM   #1
Ajl9791
Registered User
2004 TJ Wrangler 
 
Join Date: Aug 2007
Location: CT
Posts: 203
JEEP just died. . . . please help

Hey everyone , make a long story short. In the past few weeks my 04 rubicon has had "labored" starts.I though it was a battery on the way out so I purchased a new Legend 75 at NAPA yesterday and put it in.My old battery was the original and I figured 5 years ..its time.Fired it up with the new battery and it still seemed like it didnt have the great turnover speed that it always did.Went to work at 4 in the am and it started ok, going home ..not great.Then I pulled into my parking spot and figured Id try it again and it barely turned over.Interior ,radio ,gauge cluster ,fan ,fuel pump ,everything works .Tried it again ...nothing , no click , no noise at all.Checked every fuse, dont know if the starter relay crapped out(any way to check?) ,checked connections to the starter ,battery all the electrical.Is my starter gone? 63K .Any help would be great,I have to "drive" this rig to work tomorrow..or not .Thanks guys


Last edited by Ajl9791; 01-11-2009 at 12:37 PM..
Ajl9791 is offline   Reply With Quote
Unread 01-11-2009, 12:26 PM   #2
GOLENJEEPTJ
Running Secretly Amok!
 
GOLENJEEPTJ's Avatar
2002 TJ Wrangler 
 
Join Date: May 2007
Location: Ventura ,CA., California
Posts: 9,672
Can you jump start it still or no?
GOLENJEEPTJ is offline   Reply With Quote
Unread 01-11-2009, 12:27 PM   #3
visa
Registered User
1994 YJ Wrangler 
 
Join Date: Jan 2009
Location: wyoming
Posts: 99
whats the oil look like? high compresion
visa is offline   Reply With Quote
Unread 01-11-2009, 12:28 PM   #4
GOLENJEEPTJ
Running Secretly Amok!
 
GOLENJEEPTJ's Avatar
2002 TJ Wrangler 
 
Join Date: May 2007
Location: Ventura ,CA., California
Posts: 9,672
What????^^
GOLENJEEPTJ is offline   Reply With Quote
Unread 01-11-2009, 12:29 PM   #5
Ajl9791
Registered User
2004 TJ Wrangler 
 
Join Date: Aug 2007
Location: CT
Posts: 203
I havent tried I just got home ,jumped on the forum , it seems to have plenty of power to everything ,no starter click though.
Ajl9791 is offline   Reply With Quote
Unread 01-11-2009, 12:30 PM   #6
Ajl9791
Registered User
2004 TJ Wrangler 
 
Join Date: Aug 2007
Location: CT
Posts: 203
oil is alittle bit low , I use mobil 1 10W30
Ajl9791 is offline   Reply With Quote
Unread 01-11-2009, 12:30 PM   #7
PILL
Registered User
1997 TJ Wrangler 
 
Join Date: May 2008
Location: Texas
Posts: 1,002
Is it a standard? If so, have you tried bump starting it?
__________________
Member 134 of the White Jeep Club
31" BFG A/T's, 130w KC Hilites
PILL is offline   Reply With Quote
Unread 01-11-2009, 12:31 PM   #8
Ajl9791
Registered User
2004 TJ Wrangler 
 
Join Date: Aug 2007
Location: CT
Posts: 203
during this battery thing the jeep seemed to not be running the best .I just thought on my way home that the power wasnt really there...not sure though could be in my head
Ajl9791 is offline   Reply With Quote
Unread 01-11-2009, 12:32 PM   #9
GOLENJEEPTJ
Running Secretly Amok!
 
GOLENJEEPTJ's Avatar
2002 TJ Wrangler 
 
Join Date: May 2007
Location: Ventura ,CA., California
Posts: 9,672
Try a jump start! If not able too ,I'm going to say starter.Check the connections at starter also!

Last edited by GOLENJEEPTJ; 01-11-2009 at 12:42 PM..
GOLENJEEPTJ is offline   Reply With Quote
Unread 01-11-2009, 12:32 PM   #10
Ajl9791
Registered User
2004 TJ Wrangler 
 
Join Date: Aug 2007
Location: CT
Posts: 203
havent tried a bump start
Ajl9791 is offline   Reply With Quote
Unread 01-11-2009, 12:33 PM   #11
GOLENJEEPTJ
Running Secretly Amok!
 
GOLENJEEPTJ's Avatar
2002 TJ Wrangler 
 
Join Date: May 2007
Location: Ventura ,CA., California
Posts: 9,672
If your running on a bad or low battery, it can affect the performance.
GOLENJEEPTJ is offline   Reply With Quote
Unread 01-11-2009, 12:33 PM   #12
Ajl9791
Registered User
2004 TJ Wrangler 
 
Join Date: Aug 2007
Location: CT
Posts: 203
I'll give the jump start a go. thanks guys
Ajl9791 is offline   Reply With Quote
Unread 01-11-2009, 12:35 PM   #13
Ajl9791
Registered User
2004 TJ Wrangler 
 
Join Date: Aug 2007
Location: CT
Posts: 203
I just don't understand putting a new battery in yesterday that it died with little warning
Ajl9791 is offline   Reply With Quote
Unread 01-11-2009, 12:35 PM   #14
Ajl9791
Registered User
2004 TJ Wrangler 
 
Join Date: Aug 2007
Location: CT
Posts: 203
<---- no cables S@#T
Ajl9791 is offline   Reply With Quote
Unread 01-11-2009, 12:43 PM   #15
GOLENJEEPTJ
Running Secretly Amok!
 
GOLENJEEPTJ's Avatar
2002 TJ Wrangler 
 
Join Date: May 2007
Location: Ventura ,CA., California
Posts: 9,672
Is your voltmeter showing charging when engine runs?Is the cel on?
GOLENJEEPTJ is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.