Idle sputtering -possible leak? - JeepForum.com
 
LinkBack Thread Tools
post #1 of 2 Old 10-04-2010, 10:34 AM Thread Starter
anglucky21
Registered User
2003 TJ Wrangler 
 
Join Date: Aug 2010
Location: seattle
Posts: 1
Idle sputtering -possible leak?

'03 wrangler 4.0L

Okay I've searched all threads and I thought I should just start my own thread to get an answer for my problem.

Few weeks ago my jeep was slowly losing it's power. The check engine light came on and the code indicated my TPS. I replaced it (mind you it was a &*#$ cause of those screws) and I gained some of the power back but when i start my jeep it had a very high idle and eventually went down. So I cleaned my TB with TB cleaner and the IAC. It still has a high idle At start but very much improved after cleaning but while my jeep is stopped/parked my idle goes up and down. Help it's driving me nuts!

Also, I don't know I this is related but I have a slight leak under my front passenger side. It's kind of behind the tire any ideas?

Thank you for anyones help!

anglucky21 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 10-04-2010, 10:38 AM
mistertierney
Registered User
1998 XJ Cherokee 
 
Join Date: Nov 2008
Location: Cloverdale, BC
Posts: 150
I'm having similar problems. Hopefully someone will post an answer other than change your O2 sensors.

nick
mistertierney is offline  
Reply

Tags
engine , idle , leak , tps

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
idle issues sputtering 4.0 Macklin96 YJ Wrangler Technical Forum 12 11-04-2009 09:44 AM
Rough idle/sputtering on '91 (2.5l) TrynPas YJ Wrangler Technical Forum 2 07-18-2009 11:45 AM
sputtering at idle jeepsteve TJ Wrangler Technical Forum 4 11-10-2006 01:38 PM
95 2.5L High Idle & Sputtering TimWelty YJ Wrangler Technical Forum 2 11-18-2004 04:22 PM
low, sputtering idle rodgersmc YJ Wrangler Technical Forum 9 02-19-2002 06:07 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome