I gots the shakes! - Page 2 - JeepForum.com
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > I gots the shakes!

Black Friday Sales Continue!FS: Wranger BRIGHT License Plate LED! Just $3! Great value6th annual beat your wife to the credit cards sale!!

Unread 06-28-2010, 12:49 AM   #16
Registered User
2006 TJ Wrangler 
Join Date: Jul 2009
Location: , Northern Virginia
Posts: 1,315
Checked the mounts, they are tight and the bushings are good. Checked and cleaned the plugs, regapped them as well.

Whos got more ideas?

[QUOTE=KHoff90;11392897]Has anyone really been far even as decided to use even go want to do look more like?[/QUOTE]
NoVaHunter is offline   Reply With Quote Quick reply to this message

idle , shaking

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools

Suggested Threads

Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.