HVAC issues - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > HVAC issues

The NEW Revolution Gear and Axle from 4LowParts.comTHE NEW! VANCO DUAL MODE 15/16″ Big Brake Kit w/BlaEngo winches available at www.rockridge4wd.com! Free shipp

Reply
Unread 09-17-2013, 07:13 PM   #1
thejohnson486
Registered User
2000 TJ Wrangler 
 
Join Date: Nov 2010
Location: Rogers, AR, Arkansas
Posts: 136
HVAC issues

So I'm having that crazy melting problem with the hvac controls.... so I replaced the switches the Climate control and the Fan Speed Selector. I also replaced the blower motor. well I get all of this done after fixing the Previous owner hack job. and the blower is not working. any ideas where to start? I think its something with the switch but not sure.

thejohnson486 is offline   Reply With Quote
Unread 09-17-2013, 07:48 PM   #2
Hammond_Egger
Registered User
2001 TJ Wrangler 
 
Join Date: Jun 2010
Location: Delaware, Delaware
Posts: 119
Check the blower motor resistor and the wiring/relay going to the blower motor. Mine melted his year.
I went to the junkyard and pulled the whole harness from a Cherokee (same as TJ, and there are tons of Cherokee's in junkyards).
Hammond_Egger is offline   Reply With Quote
Unread 09-17-2013, 08:01 PM   #3
Knuckelhead
AFSOC Retired
 
Knuckelhead's Avatar
2000 TJ Wrangler 
 
Join Date: Aug 2005
Location: Colorado
Posts: 14,955
Are the HVAC panel plugs (or any other) melted?...
Knuckelhead is offline   Reply With Quote
Unread 09-18-2013, 02:41 AM   #4
nichelsond
Registered User
2001 TJ Wrangler 
 
Join Date: Aug 2012
Location: Cozad, Nebraska
Posts: 75
Good luck,
Here is my thread .... hope it helps! I would suggest to do the relays ... I did

http://www.jeepforum.com/forum/f9/bl...ssues-1552426/
nichelsond is offline   Reply With Quote
Unread 09-18-2013, 04:55 PM   #5
thejohnson486
Registered User
2000 TJ Wrangler 
 
Join Date: Nov 2010
Location: Rogers, AR, Arkansas
Posts: 136
So I have power at the hvac climate Congolese but as soon I chose anything like defrosting my voltmeter is showing no volts I have no clue if its the switch or some sort of ground issue
thejohnson486 is offline   Reply With Quote
Unread 09-18-2013, 04:56 PM   #6
thejohnson486
Registered User
2000 TJ Wrangler 
 
Join Date: Nov 2010
Location: Rogers, AR, Arkansas
Posts: 136
I pulled the relay it was hot
thejohnson486 is offline   Reply With Quote
Unread 09-18-2013, 07:29 PM   #7
thejohnson486
Registered User
2000 TJ Wrangler 
 
Join Date: Nov 2010
Location: Rogers, AR, Arkansas
Posts: 136
Fixed iit was the relay thanks for all tour help.
thejohnson486 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.