post #1 of Old 10-13-2008, 09:07 AM Thread Starter
Buford
Registered User
1998 TJ Wrangler 
 
Join Date: Aug 2008
Location: Italy
Posts: 97
Heat - no heat....... Heat - no heat

Sometimes I have heat, sometimes nothing. What typically happens when this occurs? I know I'm not the only one and with winter around the corner, I want to figure it out now. Me thinks its a switch or such and is simple to fix, I just don't know where to even look. Thanks


1998 Wrangler Sport - 3" Full traction lift w/ quick discos, 1" front spacers, 33" TSL, dynomax exhaust/K&N filter, KC longrange bumper/windshield lights, Hi-lift, BestTop Sunrider soft top, Kicker speakers front/back, AMSOIL oil in all drivetrain.
Buford is offline  
post #2 of Old 10-13-2008, 09:20 AM
ScottHarr_TJ
Registered User
2010 WK 
 
Join Date: Apr 2007
Location: Georgia
Posts: 727
more than likely its your blower resistor switch. pretty cheap to fix by yourself. i went to the stealership and bought a new one and took out the old one behind my glove box, and switched the old one for the new one. worked like a charm. trust me that heat is crucial in the winter.

00' TJ-sold
'10 WK
Blue Jeep Club Memeber #132?
My Custom Back Seat Box Build
ScottHarr_TJ is offline  
post #3 of Old 10-13-2008, 10:26 AM Thread Starter
Buford
Registered User
1998 TJ Wrangler 
 
Join Date: Aug 2008
Location: Italy
Posts: 97
Quote:
Originally Posted by plharrison View Post
more than likely its your blower resistor switch. pretty cheap to fix by yourself. i went to the stealership and bought a new one and took out the old one behind my glove box, and switched the old one for the new one. worked like a charm. trust me that heat is crucial in the winter.
do you have a picture of where it is located and part number for it? Thanks for the reply

1998 Wrangler Sport - 3" Full traction lift w/ quick discos, 1" front spacers, 33" TSL, dynomax exhaust/K&N filter, KC longrange bumper/windshield lights, Hi-lift, BestTop Sunrider soft top, Kicker speakers front/back, AMSOIL oil in all drivetrain.
Buford is offline  
post #4 of Old 10-13-2008, 11:05 AM
mellentine
Registered User
2001 TJ Wrangler 
 
Join Date: Jul 2008
Location: Hecho En Mexico
Posts: 25
Last winter I noticed my heat would work when driving down the road, but while sitting at an idle in the commutter rail parking lot waiting on a train, the heat would go cold. I would rev the engine to 2K RPM, and after a couple seconds the heat would return. Turns out I had a slow leak on the bottom of my radiator, and I was low on fluid. When I filled it up, heat worked all the time.
mellentine is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
No heat, then heat 2005X TJ Wrangler Technical Forum 6 10-17-2008 11:45 PM
No heat RacecaR YJ Wrangler Technical Forum 5 02-12-2006 10:43 AM
no air at all *heat or a/c* rustedrootbeer TJ Wrangler Technical Forum 7 03-24-2005 06:00 PM
No Heat! youngjeeper11 YJ Wrangler Technical Forum 22 03-01-2005 03:32 PM
Very Little Heat 92wrangler YJ Wrangler Technical Forum 16 01-17-2005 01:50 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome