Gen-right gas tank install problem - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > Gen-right gas tank install problem

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineDan's Old as Dirt Birthday Sale!GEARSHADE Pocket Tops in stock and available at ROCKRIDGE

Reply
Unread 08-02-2010, 09:24 PM   #1
VikesTJman
Registered User
2004 TJ Wrangler 
 
Join Date: Jun 2008
Location: So. St. Paul, Minnesota
Posts: 366
Gen-right gas tank install problem

Alright guys, we put in the new 19.5 Gen-right Crawler gas tank, and ran into a severe problem. Put 5 gallons in. Got her runnin, then down the road she died. Since then, we found a pinched line, fixed it, and now she will start after primin a few times, but won't stay running. All was well when starting the build, but sat for 7 months and can't put the finger on it. Modified the evap system, maybe that is the problem? I will get some pics of the set up with the evap if someone thinks that is it. Thanks for the help and looking into this.

__________________
‎"The Democracy will cease to exist when we take from those who are willing to work and give to those who are not." -Thomas Jefferson

My Jeep Build:

http://www.jeepforum.com/forum/f22/t...13/index3.html
VikesTJman is offline   Reply With Quote
Unread 08-02-2010, 09:55 PM   #2
meatlord
Animals taste good
 
meatlord's Avatar
2005 TJ Wrangler 
 
Join Date: Dec 2009
Location: western Iowa
Posts: 886
Did the same mod to mine 4 months ago, and the evap relocate. No issues thus far with codes/driveability.

By the way, how did the front Hi-Lines go? Shoot me some pics inside and outside of fenders.
__________________
05 Rubicon "Big Stupid" / 99 XJ on 31s "Nurple" FOR SALE. / 07 WK Limited CRD GDE Hot Tuned DPF delete. / 00 TJ "One Shot Wonder"/ 03 Nissan SE-R 6 speed V spec. / 00 Suzuki DR650.
meatlord is offline   Reply With Quote
Unread 08-02-2010, 11:23 PM   #3
breckboarder55
Web Wheeler
 
breckboarder55's Avatar
1999 TJ Wrangler 
 
Join Date: Sep 2007
Location: Houston/ College Station, TX
Posts: 1,066
Double check the fuel pump harness
__________________
To Veterans past and present, thank you for your service!
99 Jeep Wrangler-Just another TJ on 33"s
55 Dodge Royal Lancer- Resto Project
87 Mazda RX-7 Turbo II-Built.
87 Mazda RX-7 SE-Burn Victim
01 Honda S2000DD

Last edited by breckboarder55; 08-03-2010 at 10:05 AM..
breckboarder55 is offline   Reply With Quote
Unread 08-03-2010, 07:04 AM   #4
Bennettj13
Web Wheeler
 
Bennettj13's Avatar
2005 TJ Wrangler 
 
Join Date: Mar 2008
Location: Pendleton, IN
Posts: 5,372
Did you bend the fuel float? That could be causing an improper reading. Did you make sure there wasn't anything in the tank, you might have clogged the fuel filter.
__________________
::SELLING HALF OF MY JEEP::

http://www.jeepforum.com/forum/f33/?uid=152304

Rear Currie 4" coils - 190 shipped. (They've been sitting in the back of my Jeep for mock up but won't work out for me.)

Hornblasters Shocker S4 horn set with some extras $210 shipped. (It is not OBA, just an accessory for OBA)

"LCOG" isn't cheap and it certainly isn't easy. If you think so, you are doing it wrong. If you aren't willing to put in the effort, don't label your build "LCOG". You are just a cheap ******bag.

IndyORV- Dick and fart jokes, titties, throttle, flops, beer, tater balls, and good times.
Bennettj13 is offline   Reply With Quote
Unread 08-03-2010, 10:34 AM   #5
VikesTJman
Registered User
2004 TJ Wrangler 
 
Join Date: Jun 2008
Location: So. St. Paul, Minnesota
Posts: 366
It runs and primes fine. Just after a minute of running, it chokes off like its getting no fuel. It's throwing the P0463 code. Looked it up and going off of that. The float is fine. The harness had a clip that was broke and we zip tied it together, so we were going to mess with that, see if maybe that was the issue, and the filter might still come into play after some more troubleshooting, it just could be so many things.
__________________
‎"The Democracy will cease to exist when we take from those who are willing to work and give to those who are not." -Thomas Jefferson

My Jeep Build:

http://www.jeepforum.com/forum/f22/t...13/index3.html
VikesTJman is offline   Reply With Quote
Unread 08-03-2010, 02:15 PM   #6
VikesTJman
Registered User
2004 TJ Wrangler 
 
Join Date: Jun 2008
Location: So. St. Paul, Minnesota
Posts: 366
Called gen-right and they said there is a vacuum being caused inside the tank. Time to check for kinks or pinches in any of the lines.
__________________
‎"The Democracy will cease to exist when we take from those who are willing to work and give to those who are not." -Thomas Jefferson

My Jeep Build:

http://www.jeepforum.com/forum/f22/t...13/index3.html
VikesTJman is offline   Reply With Quote
Unread 08-06-2010, 04:31 PM   #7
VikesTJman
Registered User
2004 TJ Wrangler 
 
Join Date: Jun 2008
Location: So. St. Paul, Minnesota
Posts: 366
Got ahold of the engineering dept. at genright. turns out i had the wrong tank, and there is a missing evap vacuum line on the tank i needed, and the pump hole is too small too. Ordered a new one for the right year and hopefully that will fix the problem.
__________________
‎"The Democracy will cease to exist when we take from those who are willing to work and give to those who are not." -Thomas Jefferson

My Jeep Build:

http://www.jeepforum.com/forum/f22/t...13/index3.html
VikesTJman is offline   Reply With Quote
Unread 08-06-2010, 04:35 PM   #8
meatlord
Animals taste good
 
meatlord's Avatar
2005 TJ Wrangler 
 
Join Date: Dec 2009
Location: western Iowa
Posts: 886
So much for having the lines switched, huh?
__________________
05 Rubicon "Big Stupid" / 99 XJ on 31s "Nurple" FOR SALE. / 07 WK Limited CRD GDE Hot Tuned DPF delete. / 00 TJ "One Shot Wonder"/ 03 Nissan SE-R 6 speed V spec. / 00 Suzuki DR650.
meatlord is offline   Reply With Quote
Unread 08-06-2010, 04:39 PM   #9
VikesTJman
Registered User
2004 TJ Wrangler 
 
Join Date: Jun 2008
Location: So. St. Paul, Minnesota
Posts: 366
Yea. Lucky i talked to the engineer. Unlucky it was a wrong tank.
__________________
‎"The Democracy will cease to exist when we take from those who are willing to work and give to those who are not." -Thomas Jefferson

My Jeep Build:

http://www.jeepforum.com/forum/f22/t...13/index3.html
VikesTJman is offline   Reply With Quote
Unread 08-06-2010, 06:14 PM   #10
breckboarder55
Web Wheeler
 
breckboarder55's Avatar
1999 TJ Wrangler 
 
Join Date: Sep 2007
Location: Houston/ College Station, TX
Posts: 1,066
That's inconvenient hope, they comped your shipping...
__________________
To Veterans past and present, thank you for your service!
99 Jeep Wrangler-Just another TJ on 33"s
55 Dodge Royal Lancer- Resto Project
87 Mazda RX-7 Turbo II-Built.
87 Mazda RX-7 SE-Burn Victim
01 Honda S2000DD
breckboarder55 is offline   Reply With Quote
Unread 08-08-2010, 09:33 PM   #11
VikesTJman
Registered User
2004 TJ Wrangler 
 
Join Date: Jun 2008
Location: So. St. Paul, Minnesota
Posts: 366
The other tank that was wrong was too shallow. Make sure you get the right model for the right year jeep you got with the gen-right tanks. Got a new one (the right one), got all lines hooked up and no leaks. Engine still dies. After testing the fuel pressure at the fuel rail, and the amperage to the pump, and pressure coming from the pump, all signs point to the pump gone bad. Gettin a new one tomorrow, and will follow up with results after testing.
__________________
‎"The Democracy will cease to exist when we take from those who are willing to work and give to those who are not." -Thomas Jefferson

My Jeep Build:

http://www.jeepforum.com/forum/f22/t...13/index3.html
VikesTJman is offline   Reply With Quote
Unread 08-09-2010, 06:42 PM   #12
VikesTJman
Registered User
2004 TJ Wrangler 
 
Join Date: Jun 2008
Location: So. St. Paul, Minnesota
Posts: 366
The pump had gone out. Replaced it and still died. Pulled the assembly apart and found the rubber check valve on the bottom had carmelized and hardened. Removed the washer holding the check valve and the check valve out, now it runs like she used to. SSSHHEEEE'SSSSSS ALLLLIIIIIIIIIIIIIIIVVVEEEEEEEE!!!!!!!!!!!!
__________________
‎"The Democracy will cease to exist when we take from those who are willing to work and give to those who are not." -Thomas Jefferson

My Jeep Build:

http://www.jeepforum.com/forum/f22/t...13/index3.html
VikesTJman is offline   Reply With Quote
Reply

Tags
gen-right , gas , fuel , tank
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.