Gauges and radio stopped working!! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > Gauges and radio stopped working!!

ANOTHER Rockridge4wd Creation!! Spare Tire Carrier Delete Cess Recovery Gear Snatch Tow Strap OffRoad @ ROCKRIDGE4WD15 x 8 Black D-Window Steel Wheels Set of 4

Reply
Unread 02-04-2013, 01:02 PM   #1
Dantheshan
Registered User
2000 TJ Wrangler 
 
Join Date: Nov 2008
Location: Illinois - Cook County
Posts: 164
Gauges and radio stopped working!!

Hey guys,

I have read through some other forums on this issue and I cant seem to come up with a solution that works.

I noticed a puddle in my passenger footwell after some heavy rain and then discovered that my gauges or radio wouldn't come on. I am unsure how the water got in, but I have driven it in pouring rain with the top down before with no problem. However, every once in a while the gauges and radio will start working while I am driving, but only for a couple of seconds.

I have checked the fuses, especially the IOD (#20 i think) but it is fine. Idk why they would just stop but turn on randomly sometimes. Loose wires somewhere??

Thanks!

Dantheshan is offline   Reply With Quote
Unread 02-04-2013, 03:20 PM   #2
Rubi4MyMrs
Tks 4 the upgrade MoodyJP
 
Rubi4MyMrs's Avatar
2005 LJ Wrangler 
 
Join Date: Mar 2011
Location: Trails of, Nevada
Posts: 2,376
Is that the only 2 things that don’t work? Is it the OEM radio?

The IOD fuse is 25 & supplies B+ power to the radio, cluster, courtesy lights & underhood light. If the courtesy lights & underhood light work it is not the IOD circuit. The gauges & radio both are supposed to only work with the key on so that also points away from the IOD fuse. I don’t see those 2 circuits having anything in common unless other things aren’t working when the radio & gauges are out.
Rubi4MyMrs is offline   Reply With Quote
Unread 02-04-2013, 05:09 PM   #3
Dantheshan
Registered User
2000 TJ Wrangler 
 
Join Date: Nov 2008
Location: Illinois - Cook County
Posts: 164
The courtesy lights do not work either. It is an aftermarket radio but I have had it in there for over a year now. I did some more research and I am going to pull the gauge cluster and radio and see if there are any loose wires. I read the cluster prongs on the wiring harness sometimes dont touch and you have to bend them, so I am going to try that.

I hope I can figure it out.
Dantheshan is offline   Reply With Quote
Unread 02-04-2013, 09:38 PM   #4
Rubi4MyMrs
Tks 4 the upgrade MoodyJP
 
Rubi4MyMrs's Avatar
2005 LJ Wrangler 
 
Join Date: Mar 2011
Location: Trails of, Nevada
Posts: 2,376
True about the cluster connections but don't see how that would affect the radio unless the wiring to the radio is non-OEM connections & tied into the cluster wiring. Worth pulling the radio to see how it is wired in.
Rubi4MyMrs is offline   Reply With Quote
Unread 02-04-2013, 10:07 PM   #5
OR-TJ
Registered User
1999 TJ Wrangler 
 
Join Date: Mar 2011
Location: Tigard, Oregon
Posts: 214
Last time that happened to me was I blew one of the big fuses under the hood cuz I made the rookie mistake of snipping multiple wires at once... so check the fuses

Edit: nvm I missed the part where you checked the fuses already whoops
OR-TJ is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.