Error Code P0420 & P0432 - What could it be??? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > Error Code P0420 & P0432 - What could it be???

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineThe Solution to Radius Arm Bind - Meet Lock-N-LoadFS: Jeep Fog Light LED Bulbs! Several Brightness Options!

Reply
Unread 03-10-2010, 05:14 PM   #1
jrdewitt
Registered User
2004 TJ Wrangler 
 
Join Date: Mar 2010
Location: SoCal
Posts: 20
Error Code P0420 & P0432 - What could it be???

Got a question i'm hoping you guys can help me out with... Check engine light came on with codes 420 & 432 which translate to "Catalyst 1/1 efficiency below required level" & "Catalyst 2/1 efficiency below required level" respectively. Thought I figured it out when i noticed a broken vac line on top of the engine, but after replacing and reseting the computer the codes popped back up within 55 miles. Thought it could be the spark plugs (come to find out they were the original NGKs from 80K miles ago) so I swapped out the plugs. Same thing within 55 miles. My next thought is replacing the two O2 sensors after the precats, but I figured i'd tap the wealth of knowledge that is JF before I continue to fumble around blindly. Thanks!

jrdewitt is offline   Reply With Quote Quick reply to this message
Unread 03-10-2010, 07:04 PM   #2
Gonda
Registered User
2000 TJ Wrangler 
 
Join Date: Feb 2010
Location: Michigan
Posts: 9
An exhaust leak can cause both of these codes to set. I would start there. Then I would look at replacing the upstream O2 sensor.

I am assuming you engine runs OK...no misfire. If this is in question, check the plugs and the compression first.
Gonda is offline   Reply With Quote Quick reply to this message
Unread 03-20-2010, 01:28 PM   #3
jrdewitt
Registered User
2004 TJ Wrangler 
 
Join Date: Mar 2010
Location: SoCal
Posts: 20
Just went to the stealership and blew 977.00 on the factory replacement precat/downpipe/cat assembly. Ripped the old one off and looked down the tubes... lets just say it was one of those "Well there's your problem" moments! Only driven about 18 miles since, but could immediately feel and hear the difference! 977.00 is painful, but so is 9mpg and failing smog!
jrdewitt is offline   Reply With Quote Quick reply to this message
Unread 07-19-2010, 02:28 PM   #4
jrdewitt
Registered User
2004 TJ Wrangler 
 
Join Date: Mar 2010
Location: SoCal
Posts: 20
Just a quick update, passed SMOG with 0 problems... the tech said it was one of the cleanest exhaust readouts he has ever seen.
jrdewitt is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.