Engine clicking every morning after startup... - Page 2 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > Engine clicking every morning after startup...

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineSavvy Billet LED Tail LightsCurrie

Reply
Unread 07-09-2010, 06:36 PM   #16
LJameson
Registered User
1990 YJ Wrangler 
 
Join Date: Jun 2008
Location: Elizabeth Lake, CA
Posts: 3,765
Also, just an FYI. This is in my Factory Service Manual for my CJ7. It's on a problem tree for the valvetrain on a 258; which is identical to the 4.0's:



__________________
1990 YJ-The wheeler
2015 JK- The DD
LJameson is offline   Reply With Quote Quick reply to this message
Unread 07-10-2010, 07:15 PM   #17
bjjfoshizzy
Registered User
2002 TJ Wrangler 
 
Join Date: Apr 2005
Location: San Diego, California
Posts: 446
Great, thanks guys!
bjjfoshizzy is offline   Reply With Quote Quick reply to this message
Unread 09-18-2010, 10:07 AM   #18
bjjfoshizzy
Registered User
2002 TJ Wrangler 
 
Join Date: Apr 2005
Location: San Diego, California
Posts: 446
Still haven't figure this out. The clicking has went from every now and then to happening almost on every start up now. Still goes away after a couple of minutes. I'm not very mechanical so I'm probably going to have a mechanic look at it.

Any other ideas on what could be causing this? I'll point out to the mechanic to check the areas mentioned above. Any ideas on how expensive this could be if it is something listed above?... or anything else?
bjjfoshizzy is offline   Reply With Quote Quick reply to this message
Unread 09-18-2010, 04:56 PM   #19
hustler905
Registered User
2002 TJ Wrangler 
 
Join Date: Mar 2010
Location: Canada, Eh! Aboot here!, Ontario
Posts: 3,674
Mine was a cracked weld on one of the cats. I put a stainless clamp on it to test until I got my neighbour to weld it again.
hustler905 is offline   Reply With Quote Quick reply to this message
Unread 09-18-2010, 05:02 PM   #20
Jerry Bransford
Administrator
 
Jerry Bransford's Avatar
2004 TJ Wrangler 
 
Join Date: Jan 2003
Location: Escondido, California, California
Posts: 60,883
Is there a Fram oil filter involved? If so, try swapping it with a good quality oil filter like Wix, AC-Delco Duraguard, Purolator PureOne, etc. Frams are notorious for leaking the top-end oil back down through the oil filter's check valve which allows a dry engine start.
__________________
Getting Savvy...

Coolest offroad magazine ever! CRAWL Magazine

When you have a choice, buy American.


TJ
HOLIDAY THEMED GIVEAWAY!
Jerry Bransford is online now   Reply With Quote Quick reply to this message
Unread 09-18-2010, 05:52 PM   #21
bjjfoshizzy
Registered User
2002 TJ Wrangler 
 
Join Date: Apr 2005
Location: San Diego, California
Posts: 446
Hey Jerry... been awhile! Nope, no fram oil filter. I have a Mobil 1 filter in there right now. Any problems with those?
bjjfoshizzy is offline   Reply With Quote Quick reply to this message
Unread 09-18-2010, 05:55 PM   #22
Jerry Bransford
Administrator
 
Jerry Bransford's Avatar
2004 TJ Wrangler 
 
Join Date: Jan 2003
Location: Escondido, California, California
Posts: 60,883
Hey I just noticed it's you! So you're back in SD for the surf? No problems with the Mobil 1 filter.
__________________
Getting Savvy...

Coolest offroad magazine ever! CRAWL Magazine

When you have a choice, buy American.


TJ
HOLIDAY THEMED GIVEAWAY!
Jerry Bransford is online now   Reply With Quote Quick reply to this message
Unread 09-18-2010, 06:21 PM   #23
bjjfoshizzy
Registered User
2002 TJ Wrangler 
 
Join Date: Apr 2005
Location: San Diego, California
Posts: 446
Yeah, back for the surf! Just been taking it easy and trying to find some work. Things have been good... can't complain. If you ever need a extra hand with anything, let me know! Catch you later.
bjjfoshizzy is offline   Reply With Quote Quick reply to this message
Reply

Tags
engine noise , click , start-up , TJ

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.