Cylinder 6 Misfire - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > Cylinder 6 Misfire

NEW JK WRANGLER GRAB BARS NOW at ROCKRIDGE4WDRear Disc Brake Conversion Kit- TJ,YJ,XJSWAG 50 Cal Ammo Can Mount With M2A1 Can

Reply
Unread 02-25-2010, 05:14 PM   #1
ramil89
Registered User
2004 TJ Wrangler 
 
Join Date: Sep 2009
Location: OREGON
Posts: 61
Cylinder 6 Misfire

Hey guys,

My glorious check engine light came on...again. Before it came on and said I had a cylinder 6 misfire, so I replaced all of my spark plugs, wires, distributor cap, and rotor. It ran smoother for a couple of days, then the engine light came back on and it feels "laggy" or it hesitates when I drive. I have a bad clutch as well that I'm replacing on Sunday, but I'm trying to distinct the difference between my engine and clutch problems. I went to my local Oil Can Henry's today for them to plug in the diagnostic tester, and what do you know- cylinder 6 misfire again. I'm confused on what else can be done, or what my other problems could be. I obviously have a inline 6, 4.0L engine. Thanks in advance!

ramil89 is offline   Reply With Quote
Unread 02-25-2010, 05:30 PM   #2
Savvy
Vendor
2014 JK Wrangler 
 
Join Date: Aug 2007
Location: Tustin, CA - Orange County
Posts: 6,512
Quote:
Originally Posted by ramil89 View Post
Hey guys,

My glorious check engine light came on...again. Before it came on and said I had a cylinder 6 misfire, so I replaced all of my spark plugs, wires, distributor cap, and rotor. It ran smoother for a couple of days, then the engine light came back on and it feels "laggy" or it hesitates when I drive. I have a bad clutch as well that I'm replacing on Sunday, but I'm trying to distinct the difference between my engine and clutch problems. I went to my local Oil Can Henry's today for them to plug in the diagnostic tester, and what do you know- cylinder 6 misfire again. I'm confused on what else can be done, or what my other problems could be. I obviously have a inline 6, 4.0L engine. Thanks in advance!
Problems I have seen before that caused a 0306. Exhaust leak, bad plug, bad valve, bad plug wire, bad injector.
__________________
Email me for the fastest response: gman@savvyoffroad.com

Like us on Facebook FACEBOOK.COM/SAVVYOFFROAD

The ONLY place to get Savvy/Currie Lifts and parts! The best price and support!

Now with Lifetime Guarantee Lifetime Guarantee - See Here

http://www.savvyoffroad.com

Savvy Spartan 2004 LJ

2014 JKU Test Mule

2006 LJ Unlimited Black Hole

2005 LJ Test Mule

2003 TJ Project Unrolled
2003 TJ Project Click Here
Savvy is offline   Reply With Quote
Unread 02-25-2010, 06:06 PM   #3
GOLENJEEPTJ
Running Secretly Amok!
 
GOLENJEEPTJ's Avatar
2002 TJ Wrangler 
 
Join Date: May 2007
Location: Ventura ,CA., California
Posts: 9,672
X2... and that would probably be the only thing.How many miles on motor?Try switching the plug and the wire.I know it's a pain in the *** but you can get bad one of each.You could always pull a compression check also.
GOLENJEEPTJ is offline   Reply With Quote
Unread 02-25-2010, 07:08 PM   #4
Gonda
Registered User
2000 TJ Wrangler 
 
Join Date: Feb 2010
Location: Michigan
Posts: 9
What did the plug look like that you took out of #6? Can you post a pic?
Gonda is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.