console lights flicker - Jeep dies when cold - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > console lights flicker - Jeep dies when cold

Savvy/Currie Aluminum Control ArmsRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits ZONE 4.25" combo lift for TJ available at Rockridge4w

Reply
Unread 09-27-2014, 04:50 PM   #1
clcrump
Registered User
 
Join Date: Jul 2013
Posts: 7
console lights flicker - Jeep dies when cold

Everyone, my 2002 wrangler has been dying when I first start it and it runs at idle. The console lights flicker sporadically and then it just dies. Once the car is warmed up - to say 200 degrees, it does fine - even at idle. I've cleaned the Idle Air Control and the intake manifold. I don't think its the IAC. I think its an electrical problem because of the console lights flickering - any suggestions? On a side not, I'm not a mechanic, but I can do most small mechanical jobs on my own.
Curt

clcrump is offline   Reply With Quote Quick reply to this message
Unread 09-27-2014, 06:56 PM   #2
Jerry Bransford
Administrator
 
Jerry Bransford's Avatar
2004 TJ Wrangler 
 
Join Date: Jan 2003
Location: Escondido, California, California
Posts: 60,875
The first thing i'd try is remove both battery connectors and wire brush the battery posts and inside of the connectors until they are bright and shiny clean. Then reinstall them and tighten them securely enough so they can't be moved/rotated by hand. You can buy a wire battery cleaning brush for $3-4 that has both the male and female brushes needed to clean the posts and connectors.
__________________
Getting Savvy...

Coolest offroad magazine ever! CRAWL Magazine

When you have a choice, buy American.


TJ
HOLIDAY THEMED GIVEAWAY!
Jerry Bransford is offline   Reply With Quote Quick reply to this message
Unread 09-27-2014, 07:31 PM   #3
clcrump
Registered User
 
Join Date: Jul 2013
Posts: 7
Okay. Thanks Jerry. I'll try that first.
clcrump is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.