Check engine light on, suspected misfire...Already serviced 2 days ago for this... - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > Check engine light on, suspected misfire...Already serviced 2 days ago for this...

Stainless Steel Door Hinge PinsPoly Door Hinge BushingsIntroducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 04-10-2009, 12:53 PM   #1
Mudpuppy09
Registered User
2001 TJ Wrangler 
 
Join Date: Apr 2009
Location: Moscow, ID
Posts: 15
Check engine light on, suspected misfire...Already serviced 2 days ago for this...

OK here it is a week later. Problem reoccured after one day of very nice driving down Snake River Canyon great gas mileage for a TJ, and no real problems until today... Easy start up, ran fine until
about 11 - 14 miles out of driveway and some sputtering occured and I thought no gigantic deal, and then engine light comes on flashing, I ignore it because I am already aware of the issue...and
on way to work. I slow down around corner and begin to accelerate in 2nd gear to gain speed to shift to 3rd, and before I can even shift the thing bucks like a bronco, and decelerated and then rapidly accelerated again, and did this several times until I got it shifted into 3rd and it still seemed
like it wanted to buck. Felt like I was being rammed into by another car. This occured to me after the 1st can of Heet, and cleared up after 2nd can of heat and reoccured, and now third can of Heet and still having a problem. as previous post stated it has already been to the dealer last week and extortionately charged 555.12 for spark plug change, supposed tune up, removal of codes, throttle body cleaned, emissions system cleaner added, and also injectors cleaned. I am not really pleased that the dealer would rip me like this and they will hear about it. Just hope the thing will keep me going from point a to b until then.


Last edited by Mudpuppy09; 04-13-2009 at 05:02 PM..
Mudpuppy09 is offline   Reply With Quote
Unread 04-10-2009, 01:26 PM   #2
BlazinJack
Registered User
2006 TJ Wrangler 
 
Join Date: Oct 2008
Location: Denver
Posts: 592
what kinda milage we lookin at here? it is slightly possible that you might need new injectors. ive never really liked the injector cleaners, even the set up dealerships use to clean them, and ive heard several people that have done that have issues again in a short time. usually the fix is new injectors. other than that, id take it make to the dealler and have them try the injector cleaner again (for free!!) and re diagnose the problem again (for free!) but dont be surprised if the answer is "needs injectors" unless the codeis completely unrelated and coincidently a different problem that causes misfiring (coils, sparkplugs, computer issues, ect...)
__________________
"No beer and no t.v. make Jack something something..."
Colorado Jeep Club #145!!
Black Jeep Society
BlazinJack is offline   Reply With Quote
Unread 04-10-2009, 01:30 PM   #3
GOLENJEEPTJ
Running Secretly Amok!
 
GOLENJEEPTJ's Avatar
2002 TJ Wrangler 
 
Join Date: May 2007
Location: Ventura ,CA., California
Posts: 9,678
The fact that they said you needed your injectors cleaned was a joke! I suggest to take it back and make good on your outrageous bill. Welcome to JF.
GOLENJEEPTJ is offline   Reply With Quote
Unread 04-13-2009, 01:50 PM   #4
Mudpuppy09
Registered User
2001 TJ Wrangler 
 
Join Date: Apr 2009
Location: Moscow, ID
Posts: 15
Thanks guys...good to be amongst fellow Jeepheads....I am so friggin pissed off, at the dealer I had to hide my gun! Just kidding, but you know the feeling! Dang thing started running good again yesterday after a can of
Heet, and then again this morning started to misfire and sputter at a 1/2 tank level and when I went to accelerate out of 2nd gear to shift to 3rd it felt like I was being rear ended and then it would accelerate and rapidly decelerate again...Is it the computer module? Or is the work they did on the dang thing cosmetic and they didn't do crap for the problem just to milk someone they thought was a sucker? Responses back would
be appreciated.
Mudpuppy09 is offline   Reply With Quote
Unread 04-13-2009, 01:55 PM   #5
GOLENJEEPTJ
Running Secretly Amok!
 
GOLENJEEPTJ's Avatar
2002 TJ Wrangler 
 
Join Date: May 2007
Location: Ventura ,CA., California
Posts: 9,678
Is the lite back on?Maybe a camshaft sensor going?Possibly a bad 02 sensor?When it's intermittent it's hard to say!I still say take it back to them.You dropped a lot of money there the last time,to have it turn around and do this!
GOLENJEEPTJ is offline   Reply With Quote
Unread 04-13-2009, 01:56 PM   #6
Mudpuppy09
Registered User
2001 TJ Wrangler 
 
Join Date: Apr 2009
Location: Moscow, ID
Posts: 15
Quote:
Originally Posted by BlazinJack View Post
what kinda milage we lookin at here? it is slightly possible that you might need new injectors. ive never really liked the injector cleaners, even the set up dealerships use to clean them, and ive heard several people that have done that have issues again in a short time. usually the fix is new injectors. other than that, id take it make to the dealler and have them try the injector cleaner again (for free!!) and re diagnose the problem again (for free!) but dont be surprised if the answer is "needs injectors" unless the codeis completely unrelated and coincidently a different problem that causes misfiring (coils, sparkplugs, computer issues, ect...)
154000+ miles...
Mudpuppy09 is offline   Reply With Quote
Unread 04-13-2009, 01:58 PM   #7
GOLENJEEPTJ
Running Secretly Amok!
 
GOLENJEEPTJ's Avatar
2002 TJ Wrangler 
 
Join Date: May 2007
Location: Ventura ,CA., California
Posts: 9,678
Well you definitley have some miles posted.
GOLENJEEPTJ is offline   Reply With Quote
Unread 04-13-2009, 02:00 PM   #8
Mudpuppy09
Registered User
2001 TJ Wrangler 
 
Join Date: Apr 2009
Location: Moscow, ID
Posts: 15
yeah the light is back on....What is so weird it ran excellent yesterday when the tank was full, accelerated well uphill, no bogging no hard deceleration acceleration jerkiness and then today for it to act like this?
When they first scoped it they told me it could be water in the tank because I had lost my gascap unawares and ran it for a couple of days in the snow and rain. But that would be a hell of a lot of water and to put 3 cans of gas dryer/antifreeze in the tank is really really excessive and should have cleared the problem by now.
I guess I may need to get an attorney if they try to screw with me this week. Until then I will have to attempt to nurse it back and forth to work until Wednesday... or do you think the problem is more severe?
Mudpuppy09 is offline   Reply With Quote
Unread 04-13-2009, 02:02 PM   #9
Mudpuppy09
Registered User
2001 TJ Wrangler 
 
Join Date: Apr 2009
Location: Moscow, ID
Posts: 15
and when I had the code checked it was again a P0301 cylinder 1 misfire...no other codes except
for the EVA,CAT,O2....but was told those will come up as probable causes....well then why didn't they replace the sensors after changing out my spark plugs....I am friggin frustrated.
Mudpuppy09 is offline   Reply With Quote
Unread 04-13-2009, 02:09 PM   #10
BlazinJack
Registered User
2006 TJ Wrangler 
 
Join Date: Oct 2008
Location: Denver
Posts: 592
have you ever changed the fuel pump? im kinda wondering if your pump is going bad or the fuel filter is clogged.
__________________
"No beer and no t.v. make Jack something something..."
Colorado Jeep Club #145!!
Black Jeep Society
BlazinJack is offline   Reply With Quote
Unread 04-13-2009, 02:35 PM   #11
Unlimited04
This post/info=my opinion
 
Unlimited04's Avatar
2004 LJ Wrangler 
 
Join Date: Dec 2005
Location: Colorado
Posts: 23,305
camshaft sensor is my guess. i would have started there long before injector cleaner. FYI, the cleaning the throttle body and intake system is stupid easy, takes literally 15 minutes with a rattle can of "carb/throttle body cleaner", you can do it in the middle of an apartment parking lot if you have to.
Unlimited04 is offline   Reply With Quote
Unread 04-13-2009, 03:58 PM   #12
tavic
Registered User
2010 JK Wrangler 
 
Join Date: Apr 2009
Location: Oklahoma City, OK
Posts: 1,733
I had the same issue come up after i had performed a tune up, come to find out the spark plugs were not torqued properly.
tavic is offline   Reply With Quote
Unread 04-13-2009, 04:35 PM   #13
Mudpuppy09
Registered User
2001 TJ Wrangler 
 
Join Date: Apr 2009
Location: Moscow, ID
Posts: 15
So if it is the cam sensor...is this a cheap fix? Throttle body has already been cleaned, and fuel injectors were cleaned....so they say...$555.12 and still having the issue...I ought to run this Jeep right up their asses until they pay me back my money or do the work right!
Mudpuppy09 is offline   Reply With Quote
Unread 04-13-2009, 04:40 PM   #14
Unlimited04
This post/info=my opinion
 
Unlimited04's Avatar
2004 LJ Wrangler 
 
Join Date: Dec 2005
Location: Colorado
Posts: 23,305
Quote:
Originally Posted by Mudpuppy09 View Post
So if it is the cam sensor...is this a cheap fix? Throttle body has already been cleaned, and fuel injectors were cleaned....so they say...$555.12 and still having the issue...I ought to run this Jeep right up their asses until they pay me back my money or do the work right!
i'd take it back to the dealership, bring your reciept and ask for the service manager.

tell him/her you brought the jeep in 2 days ago with said issues, they perscribed whatever treatment for X dollars (show him reciept). then say, the Jeep is still got issues, same problems, same stuff, etc They charged you $555 for nothing. see what they say. Jeep is in trouble right now, they want you to spend money at their stealership. use this to your advantage - if they can't fix the problem right the first time, then you don't need to spend your money there. Be polite, and make sure to let the manager know this without directly stating it.
Unlimited04 is offline   Reply With Quote
Unread 04-13-2009, 05:03 PM   #15
Mudpuppy09
Registered User
2001 TJ Wrangler 
 
Join Date: Apr 2009
Location: Moscow, ID
Posts: 15
updated my original thread....anyone have any more suggestions....if it is cam sensor or crank sensor or O2 sensor are these items I can replace myself?
Mudpuppy09 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.