A/C vents not working - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > A/C vents not working

JK Vent Covers - NalinMFGRing & Pinion's, Lockers, 4340 Axles, Install Kits, BaTJ 5.25" Speaker Adapters - NalinMFG

Reply
Unread 07-14-2014, 11:00 AM   #1
silv1010
Registered User
2004 TJ Wrangler 
 
Join Date: Mar 2014
Location: Westfield, New Jersey
Posts: 49
A/C vents not working

so i need my vents to gimme some nice cool air but it only blows through the windshield and my feet but not towards me any help as to what may be the problem? looks to me like an easy fix just cant find the problem

thanks a lot will post pics

silv1010 is offline   Reply With Quote
Unread 07-14-2014, 02:00 PM   #2
prjohnson
Registered User
2002 TJ Wrangler 
 
Join Date: May 2008
Location: Marietta, GA
Posts: 563
Could be one of those little arms behind the dash, or in my case it was a vacuum leak under the hood.
prjohnson is offline   Reply With Quote
Unread 07-14-2014, 03:57 PM   #3
JWebber
Registered User
1999 TJ Wrangler 
 
Join Date: Aug 2011
Location: Lewisville, Texas
Posts: 879
check the main vac line running from intake manifold to firewall. It splits with a tee fitting and another line runs under battery tray to a vac resavoir.
Check all lines for cracks in plastic line and rubber fittings, if all seems good then look into blend door motor.
JWebber is offline   Reply With Quote
Unread 07-14-2014, 09:11 PM   #4
silv1010
Registered User
2004 TJ Wrangler 
 
Join Date: Mar 2014
Location: Westfield, New Jersey
Posts: 49
thanks for the update guys will take pics and search tmrw morning
silv1010 is offline   Reply With Quote
Unread 07-15-2014, 05:45 PM   #5
silv1010
Registered User
2004 TJ Wrangler 
 
Join Date: Mar 2014
Location: Westfield, New Jersey
Posts: 49
fixed and works perfectly i just hav to go easy on the actuators because i dont want tht breaking now.

it was the a vacum line leak or in simple werds the tube snapped.

cudnt find it under the battery bc mine was wired in the firewall.

a bit of electricall tape and zip tie and poof im ready for summer in august

pics below

http://s1218.photobucket.com/user/si...EP%20AC%20MALF
silv1010 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.