A/C Heater Dial Issues - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > A/C Heater Dial Issues

Introducing MONSTALINERô UV Permanent DIY Roll On Bed LineSavvy Billet LED Tail LightsLight up the holidays with LED lights from JeepHut

Reply
Unread 08-20-2006, 09:00 AM   #1
BlueTeeJay
Registered User
 
Join Date: Aug 2006
Posts: 204
A/C Heater Dial Issues

I've got a 2000 TJ Sport with which I've had no problems with at all up until now. The dial that controls the direction of the air/heat has stopped clicking into position and I can feel my A/C on all the time! Air comes from all the vents no matter what position the switch is in. Has anyone had this happen before? What's the fix?
I'd really like to fix it myself, I took it to a garage across from where I work and the mechanic told me it'd take at least an hour and 75$ just to get in behind the dash. Chicks in Jeeps = dollars for them!

BlueTeeJay is offline   Reply With Quote Quick reply to this message
Unread 08-20-2006, 10:17 AM   #2
stogie25
Registered User
1997 TJ Wrangler 
 
Join Date: Apr 2006
Location: Denver, Colorado
Posts: 1,451
BlueTeeJay, your problem is slightly different from what I was experiencing, but the write up below should help you troubleshoot your problem. I have posted this write up several times. It will walk you through a lot of the TJ vacuum system for the climate controls.

Crawl under the dash on your drivers side and watch the vacuum activated switches as the dash switch is changed. If necessary post your observations. It sounds like the flapper is not moving. This could be due to either the flapper itself being jammed, or a vacuum leak either in or before the switches.

Good luck,




I hope this helps anyone whose vents and or heat doesn't blow, or anyone whose vents stop working when entering the highway or going up a steep hill.

I am the original owner of a 1997 TJ. I (also known as the loose nut on the steering wheel) am one of the few original pieces left on my Jeep. Recently I have discovered several other pieces of original equipment, all of which control the direction of air from my vents and heater. My tale starts about five years ago when my dashboard vents stopped blowing. My under dash heater and defroster still worked, so I just blew the problem off. This year my under dash heater stopped working, leaving me with only the defroster. Something had to be done.

I started at the control switch. I found the vacuum lines attached to the back of it, and blew them out with a football needle and my garage air compressor. I also found a splice in the line behind the glove box. I cleaned that out as well. I insured that everything was correctly seated and tried the vents and heater. No dice.

Undeterred, I started poking around under the dash. I discovered three vacuum activated switches with arms attached that control the air direction. They did not budge when the control was set to either vent or heat, and the input to them showed vacuum on the gauge. I was able to manually move them, thereby changing the direction of the air. I knew I was close. I contorted myself into a two hundred and fifty pound pretzel, and changed them out. This took about an hour, and cost about a hundred dollars. To my great disdain, there was still no air blowing through the vents or under dash heater. The switches at least tried to move (a definite improvement) but it seemed the vacuum was not quite strong enough to move the arms.

I crawled back under the dash and traced all the vacuum lines, identifying the black one as the source vacuum. It penetrated the firewall on the passenger side, not far from the battery. It went to a three way junction. One of the lines from the junction went predictably to the intake manifold near the rear of the drivers side. The other line went under the battery where it was broken. I sealed it up with a nail. Upon checking, I had full control of my air direction.

This did not feel like a complete repair with a nail plugging up a mystery vacuum line, so I perused a used car lot nearby and found another 97 Wrangler. I crawled under and traced the line to a vacuum reserve container near the bottom of the Jeep. My next stop was the auto parts store for a few feet of vacuum line. The problem seemed to be fixed.

That night I went to pick up a friend to take to the bar, and when entering the highway my vents stopped working and defaulted back to the defroster. As soon as I let off the gas a little it went back to vents. I remembered the Jeep doing this many years ago when the vents worked, and remembered that it was annoying then. Now I was emotionally involved with this repair and had no intention of letting this annoyance continue. I searched the internet, and learned that I was not the only person with this problem. I could not find anyone who had posted a solution. The internet was of some help, as it directed me to a Jeep TSB that told of a one directional vacuum valve in line with the feed, but did not give a part number. I called a friend at Jeep, who informed me that he had the same problem. He hoped I was successful at finding a solution for both of us. He diligently kept working on his part the solution until he found a part number from the Cherokee, which we figured would work. Due to the remote location of my friend at Jeep, I had to stop by a local dealership to pick up the part. It cost about seven dollars. While at the dealership, I told the parts people about my problem, and asked if they had ever heard of similar problems, and they told me that the Grand Cherokee has a small reserve reservoir in line with the vacuum source supplementing the larger reserve container. For another eleven dollars I figured I would try that as well.

I got home, replaced the valve, which was a slightly different part, and installed the in line reservoir, which plugged directly into the valve. I test drove the Jeep several times on the highway, and was unable to make it fail. I was also able to turn off the motor with the key in the accessory position, and keep the vents blowing, something I donít ever remember the Jeep doing before. It is supposed to snow tomorrow morning, and I look forward to having the heat blow at me for the first time in years.

Jordan
__________________
Jarhead Jeep Club
O|||||||O
97 Black TJ (one owner), BFG KM2 35s, 4.7L Stroker, ARB's, Dana60 rear, Dana30HP Front Warn manual hub conversion, 6 inch mostly Tera long arm lift. Rhino lined tub. Allied Rock 8 beadlocks. Tera-Low 4:1. Sanden OBA. Sniperfab tube fenders.

My Build Thread http://www.jeepforum.com/forum/f22/m.../#post12717920
stogie25 is offline   Reply With Quote Quick reply to this message
Unread 08-20-2006, 08:34 PM   #3
99TJSport
Registered User
2008 JK Wrangler 
 
Join Date: Jul 2004
Location: Front Royal, VA
Posts: 1,101
If the selector is no longer clicking, I would start out by checking the knob. They're famous for cracking inside, which causes them to spin on the shaft instead of actually turning it. This happened on my 99 and it got stuck on AC in the middle of winter. $5 for a new knob and I was back in business.
__________________
Jeff
08 Rubicon Unlimited, 2.5TF Lift, 285/70/17 BFG KM2s, lots of skids, MyGig, and both sets of doors/tops.

Parrothead Jeepers Union #24
99TJSport is offline   Reply With Quote Quick reply to this message
Unread 08-20-2006, 08:41 PM   #4
wcurleyq
Registered User
 
Join Date: May 2006
Location: Douglasville Ga
Posts: 345
X2 on the above. Check the knob.
wcurleyq is offline   Reply With Quote Quick reply to this message
Unread 09-03-2006, 10:20 AM   #5
abnormal
Platinum Member
 
abnormal's Avatar
1996 XJ Cherokee 
 
Join Date: May 2005
Location: Just around the corner...
Posts: 1,790
I seem to be having the same problem with my switch. It has play in it now and when I change from one setting to another it doesnt seem to always change vents. I looked at the controls to see it I could get the knob off and it doesent want to come off. Is there a trick to getting it off?

__________________
DURTYROK CAROLINA OFFROAD
abnormal is offline   Reply With Quote Quick reply to this message
Unread 09-06-2006, 06:17 AM   #6
abnormal
Platinum Member
 
abnormal's Avatar
1996 XJ Cherokee 
 
Join Date: May 2005
Location: Just around the corner...
Posts: 1,790
bump......

__________________
DURTYROK CAROLINA OFFROAD
abnormal is offline   Reply With Quote Quick reply to this message
Unread 09-06-2006, 11:45 AM   #7
ASUsax
Registered User
2002 TJ Wrangler 
 
Join Date: Jan 2006
Location: AZ
Posts: 1,148
Quote:
Originally Posted by scubajeeps
I seem to be having the same problem with my switch. It has play in it now and when I change from one setting to another it doesnt seem to always change vents. I looked at the controls to see it I could get the knob off and it doesent want to come off. Is there a trick to getting it off?

Yeah, sometimes mine doesn't 'switch'. I have to move it a little more to get it to change positions. More of an annoyance than a real problem.
__________________
Blue Jeep Club Member #197
'02 TJ - 33" BFG MT's's, some armor, yadda yadda. 2" BDS lift/1"BL
'94 ZJ - May it rest in pieces.
ASUsax is offline   Reply With Quote Quick reply to this message
Unread 09-07-2006, 02:17 PM   #8
theiastcowboy
Registered User
 
Join Date: Dec 2004
Posts: 38
stogie 25 you are the man!!! I haven't been able to get my freakin fan to work right in months. I had a crack in the same hose under the battery, fixed it up with some tape just to see if that was the problem and Blamo, the fans work! O and I also have the jacked up knob, I'm getting ready to order a new one, that should fix your problem. O and if your having a hard time pulling it off just try some pliers, but that may break it so.... it's up to you.
theiastcowboy is offline   Reply With Quote Quick reply to this message
Unread 03-25-2012, 11:49 PM   #9
mark24armstrong
Registered User
 
Join Date: Dec 2011
Posts: 3
Stogie25 thanks. I am new to the forum and new to jeeps and this helped me fix my jeep in about 5 minutes. Vacum hose under the battery was split and came off the box in the fender well. Again THANKS SO MUCH.
mark24armstrong is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.