Blinker turns on when braking?? - JeepForum.com

 
LinkBack Thread Tools
post #1 of 10 Old 08-23-2013, 10:23 PM Thread Starter
mikedff23
Registered User
 
Join Date: Jun 2008
Location: New Jersey
Posts: 286
Blinker turns on when braking??

Any clue? I'm assuming I have a short but I'm not sure where I should start looking.

mikedff23 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 08-24-2013, 08:56 AM
Jerry Bransford
Administrator
 
Jerry Bransford's Avatar
2004 TJ Wrangler 
 
Join Date: Jan 2003
Location: Escondido, California
Posts: 68,391
Quote:
Originally Posted by mikedff23 View Post
Any clue? I'm assuming I have a short but I'm not sure where I should start looking.
That is caused by a lazy turn signal switch not quite returning all the way back to center after completing a turn. A slight nudge of the turn signal towards its center position will stop the turn signal light from illuminating when you step on the brake pedal.

Replacing the turn signal switch is the permanent fix.

When you have a choice, buy American made.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Jerry Bransford is online now  
post #3 of 10 Old 08-24-2013, 10:31 AM Thread Starter
mikedff23
Registered User
 
Join Date: Jun 2008
Location: New Jersey
Posts: 286
*smacks head* I've replaced the turn signal x3. Normally it was just getting stuck on. Now when I hit the brakes. The left side indicator flashes everytime I hit the brakes.
mikedff23 is offline  
 
post #4 of 10 Old 08-24-2013, 10:49 AM
sc00bz
Registered User
1997 TJ Wrangler 
 
Join Date: May 2011
Location: Jackson
Posts: 693
Quote:
Originally Posted by Jerry Bransford View Post
That is caused by a lazy turn signal switch not quite returning all the way back to center after completing a turn. A slight nudge of the turn signal towards its center position will stop the turn signal light from illuminating when you step on the brake pedal.

Replacing the turn signal switch is the permanent fix.
This. Mine has done the same thing for a couple of years and a slight nudge up will stop it until I utilize the left turn signal again.

Sent from my GSIII using HeepForum

97 TJ with some stuff.
sc00bz is offline  
post #5 of 10 Old 08-25-2013, 08:08 AM
LubbTJ
Registered User
1997 TJ Wrangler 
 
Join Date: Jul 2013
Location: lubbock
Posts: 165
Same problem with mine.. however mine doesn't do it every time.. seems to happen more often when it's really humid out, or it's just rained. I'm guessing the moisture creates a contact issue.
LubbTJ is offline  
post #6 of 10 Old 08-25-2013, 09:37 AM
TheBoogieman
Disturbed
 
TheBoogieman's Avatar
2003 TJ Wrangler 
 
Join Date: Aug 2006
Location: CharlottesHELL
Posts: 34,970
Multi-function switch.Buy a better quality one.
TheBoogieman is offline  
post #7 of 10 Old 08-26-2013, 07:04 PM
steelslinger
Registered User
2004 TJ Wrangler 
 
Join Date: Aug 2013
Location: Bradenton
Posts: 56
I had my signal indicator light up on my gauge cluster when I turned the headlights on only when it rained. My left front signal lens was getting water in it shorting the marker to signal circuit. Check your tail lamps bulb contacts for rusty appearance.
steelslinger is offline  
post #8 of 10 Old 06-19-2017, 12:36 PM
DstroyrOfWrldz
Registered User
1999 TJ Wrangler 
 
Join Date: Jul 2010
Location: Colorado Springs
Posts: 238
Does your left turn signal work while you're on the brakes with this issue? Mine stops clicking and both front and rear left turn signals light up solid when I brake.

Sent from my SAMSUNG-SM-J320AZ using Tapatalk

Joe
1999 Wrangler Sahara
2005 Wrangler Unlimited (Sold 9/2012)
DstroyrOfWrldz is offline  
post #9 of 10 Old 06-19-2017, 12:45 PM
DylanC7410
Registered User
2006 TJ Wrangler 
 
Join Date: Dec 2016
Location: Orlando
Posts: 75
Mine does the same thing every now and again...haha I thought it was my jeep lol I just nudge it everytime it happens...I have high quality metal cloak led signals and thats when it first started happening which was right after i replace my stock fenders to metalcloaks with their signals,....
DylanC7410 is offline  
post #10 of 10 Old 06-20-2017, 10:19 AM
DstroyrOfWrldz
Registered User
1999 TJ Wrangler 
 
Join Date: Jul 2010
Location: Colorado Springs
Posts: 238
Yeah, nudging it works when I'm not using the turn signal, but when I am using it, nudging it would be turning it off. So when this is happening, my left turn signal doesn't flash if I'm using the brakes, it's just on solid.

At first I thought it was a grounding issue so I cleaned up and reinstalled the taillight screws, and I thought it was fixed for a couple of days but then it started again.

Joe
1999 Wrangler Sahara
2005 Wrangler Unlimited (Sold 9/2012)
DstroyrOfWrldz is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome