Bad TPS, can that cause backfiring? - JeepForum.com

 
LinkBack Thread Tools
post #1 of 11 Old 02-13-2005, 08:54 PM Thread Starter
jfallken
Registered User
 
Join Date: Oct 2004
Posts: 60
Bad TPS, can that cause backfiring?

Upon suggestion, I replaced my CPS, it didn't resolve the issue. Next stab would be at the TPS. Here are the symptoms:
Started idleing a little off, just a little rough, next time I tried to start it, it was real bad, requiring %50 throttle to stay running, sounded like it was missing on at least 2 holes.
Checked spark, ok. Pulled all the plugs, checked wires/cap/rotor, everything ok.
Getting plenty of fuel however I haven't hooked up a pressure gauge to the line, but the pump works fine and plenty gas comes out of the valve.
Now when I try to start it I have to put the gas pedal to the floor to get it to fire, and keep it at about %50 to stay running. Most times at start up it will just backfire.
I replaced the Crank Pos. Sensor, there was no change.

I'm not sure if its the tps, has anybody out there experienced a backfire situation with a bad TPS at start up? Any suggestions on my next course of action?

BTW, no codes, hooked it up to a OBD II scanner/ monitor and nothing came up or looked out of the ordinary. I have never wanted to see a check engine light so bad before!!!!!!!!


99 wrangler
d44 front
d44 rear w trac-lock
3.73 gears
3 sp auto, looking for anything else
jfallken is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 02-13-2005, 09:18 PM
under_psi
Registered User
2006  
 
Join Date: Jun 2004
Location: the deep south
Posts: 698
i got a code when my TPS went bad. my only symptoms were stalling and sputtering when i depressed the clutch, and some poor acceleration charachteristics....i got no backfiring if that is any help to you...

What's coming through is alive. What's holding up is a mirror. But what's singing songs is a snake looking to turn this piss to wine. They're both totally void of hate, but killing me just the same. The snake behind me hisses what my damage could have been. My blood before me begs meopen up my heart again. And I feel this coming over like a storm again. considerately. Venomous voice, tempts me, drains me, bleeds me, leaves me cracked and empty. Drags me down like some sweet gravity.
under_psi is offline  
post #3 of 11 Old 02-13-2005, 09:19 PM
JSBlu974X4
Registered User
2005 LJ Wrangler 
 
Join Date: Feb 2003
Location: Ellicott City MD
Posts: 2,218
i have the same problem with mine right now, i can drive it but it backfires and kicks alot, check engine light flashes on when it happens, RPM guages goes wack when it happens, you have the same problems?mine happens over bumps a lot as well

2005 Unlimited Rubicon Hard N Soft Tops, Clayton Long Arm on RE Coils, Warn Bumper/Tire Carrier, Warn Winch N Bumper, Currie Steering, JKS Quicker Disconnects, JKS Front Trac Bar, Bilsteins, CO2 System..Yada Yada Yada
JSBlu974X4 is offline  
post #4 of 11 Old 02-13-2005, 09:47 PM
cptn_mrgn78
Registered User
 
cptn_mrgn78's Avatar
2005 LJ Wrangler 
 
Join Date: Jul 2002
Location: Colorado Springs,Co
Posts: 679
Check your exhaust manifolds for cracks. Mine finally cracked and it was showing the same symptoms.

RIP: '97 TJ with 2in Teraflex with QD's. 32in AT's. Hi-lift jack, two 10in subs and a 500 watt amp. 150watt KC Daylighters. Avalanche Engineering Rocker Knockers.

New: '05 Unlimited
cptn_mrgn78 is offline  
post #5 of 11 Old 02-13-2005, 09:53 PM Thread Starter
jfallken
Registered User
 
Join Date: Oct 2004
Posts: 60
Quote:
Originally Posted by JSBlu974X4
i have the same problem with mine right now, i can drive it but it backfires and kicks alot, check engine light flashes on when it happens, RPM guages goes wack when it happens, you have the same problems?mine happens over bumps a lot as well
Have you checked the codes? Its real easy, theres a sticky at the top of the forum with instructions.. That should point you in the right direction.... I wish my damn light would come on
Make my damn life a lot easier and cheaper..

99 wrangler
d44 front
d44 rear w trac-lock
3.73 gears
3 sp auto, looking for anything else
jfallken is offline  
post #6 of 11 Old 02-13-2005, 09:55 PM Thread Starter
jfallken
Registered User
 
Join Date: Oct 2004
Posts: 60
Quote:
Originally Posted by cptn_mrgn78
Check your exhaust manifolds for cracks. Mine finally cracked and it was showing the same symptoms.
Checked that already, good suggestion though. I checked all the o2 wires for damage also..

99 wrangler
d44 front
d44 rear w trac-lock
3.73 gears
3 sp auto, looking for anything else
jfallken is offline  
post #7 of 11 Old 02-13-2005, 10:28 PM
bigjohnwhodatis
Registered User
 
bigjohnwhodatis's Avatar
 
Join Date: Nov 2003
Location: The Nasty 'Nati
Posts: 328
Quote:
Originally Posted by under_psi
i got a code when my TPS went bad. my only symptoms were stalling and sputtering when i depressed the clutch, and some poor acceleration charachteristics....i got no backfiring if that is any help to you...
Exactly the same for me. Not one backfire. Doesn't sound like a TPS issue to me.

2" RE BB/Tera 3" Front Coils
1"BL/MML
33x12.5 Dunlop Radial Mud Rovers
Warn M8000
Jeeperman Rock Sliders
Big dreams and a little wallet
bigjohnwhodatis is offline  
post #8 of 11 Old 02-13-2005, 11:14 PM
jeeptj00boy
Registered User
 
jeeptj00boy's Avatar
 
Join Date: Sep 2004
Location: California
Posts: 373
Yeah that sounds like the tps to me, I did the same damn thing
jeeptj00boy is offline  
post #9 of 11 Old 02-13-2005, 11:27 PM
bigjohnwhodatis
Registered User
 
bigjohnwhodatis's Avatar
 
Join Date: Nov 2003
Location: The Nasty 'Nati
Posts: 328
Come to think of it, if it were any of these electrical sensors, how would it not throw a code?

2" RE BB/Tera 3" Front Coils
1"BL/MML
33x12.5 Dunlop Radial Mud Rovers
Warn M8000
Jeeperman Rock Sliders
Big dreams and a little wallet
bigjohnwhodatis is offline  
post #10 of 11 Old 02-13-2005, 11:40 PM
MR.CLIFFORD
Registered User
 
MR.CLIFFORD's Avatar
2006 TJ Wrangler 
 
Join Date: Jul 2003
Location: Wichita
Posts: 2,284
Garage
take off the tps and clean it. Clean the whole throttle body while you're at it. Make sure the IAC isn't sticking.

Custom signature
MR.CLIFFORD is offline  
post #11 of 11 Old 02-14-2005, 12:45 PM
JSBlu974X4
Registered User
2005 LJ Wrangler 
 
Join Date: Feb 2003
Location: Ellicott City MD
Posts: 2,218
i cleaned my throttle body and all, mine backfires, will stall, no codes arleady checked, light only comes on when it glitches. fuel guage will go to empty until it happens again

2005 Unlimited Rubicon Hard N Soft Tops, Clayton Long Arm on RE Coils, Warn Bumper/Tire Carrier, Warn Winch N Bumper, Currie Steering, JKS Quicker Disconnects, JKS Front Trac Bar, Bilsteins, CO2 System..Yada Yada Yada
JSBlu974X4 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Backfiring 2.5L RebuildRookie YJ Wrangler Technical Forum 41 04-08-2010 10:34 AM
2.5L backfiring MooseMarine YJ Wrangler Technical Forum 3 07-27-2009 10:45 AM
Backfiring TJ kmj153 TJ Wrangler Technical Forum 4 02-12-2008 01:39 AM
Backfiring? tjbrotha TJ Wrangler Technical Forum 5 07-01-2006 10:26 AM
Backfiring 4x4chef YJ Wrangler Technical Forum 1 05-12-2006 09:03 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome