Antifreeze Smell/ Temp Gauge - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > Antifreeze Smell/ Temp Gauge

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFS: Wranger BRIGHT License Plate LED! Just $3! Great valueIntroducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 12-31-2012, 10:13 AM   #1
chadschroeder01
Registered User
2004 TJ Wrangler 
 
Join Date: Mar 2007
Location: Indiana
Posts: 5
Antifreeze Smell/ Temp Gauge

Hi, I have actually been dealing with this for almost 2 years. (i mean the coolant smell and trying to figure it out)

Basically i smell coolant. I am not seeing very much coolant loss. But its not my everyday driver. I have replaced the Radiator with a Griffin solid aluminum one, both hoses and the Rad Cap. I have no smell inside the Jeep, no signs in the oil or exhaust.

But just recently, my temp gauge started going from the center dot (210) to a little bit over, then moves to under 210 a little then back. Then it will stay there for a couple of miles or so then start moving again.

I have seen a little coolant on the radiator above the lower hose, before i replaced the radiator the coolant was on the other side.

I am currently (as i write this) pressure testing the TJ. Its i guess what you'd call a warm pressure test. I did release the pressure, coolant is warm, engine is warm. I am losing pressure very slowly. I think that is normal while its cooling down? (correct me if i am wrong)

Non the less i am not seeing any obvious leakage.

I am planning on doing a cold test when its been off for a while.

Any suggestions would be appreciated. Thanks in advance.

chadschroeder01 is offline   Reply With Quote
Unread 12-31-2012, 10:15 AM   #2
mdm
Farm Wheeler
2000 TJ Wrangler 
 
Join Date: Apr 2005
Location: Elkmont, AL
Posts: 9,703
Coolant on the lower hose is usually either a hose problem or the water pump leaking out the weep hole on the bottom of the pump.
__________________
Keep in mind that free advice can frequently be worth less than you pay for it.
mdm is offline   Reply With Quote
Unread 12-31-2012, 10:20 AM   #3
chadschroeder01
Registered User
2004 TJ Wrangler 
 
Join Date: Mar 2007
Location: Indiana
Posts: 5
Quote:
Originally Posted by mdm View Post
Coolant on the lower hose is usually either a hose problem or the water pump leaking out the weep hole on the bottom of the pump.
To clarify, I don't have coolant on the lower hose. Its above the hose, on the radiator between the fan shroud and the radiator. Sorry

Also, i am not saying your wrong because i can't check the weep hole because i can't get to it. But i have been dealing with this since 6/2011 and if it was the water pump it seems like it should have went out by now?

Thanks
chadschroeder01 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.