99 Wrangler Sport 4.0L Stall - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > 99 Wrangler Sport 4.0L Stall

Stainless Steel Door Hinge PinsPoly Door Hinge BushingsDual Color LED Light Bars White/Amber

Reply
Unread 05-23-2011, 10:56 AM   #1
tribalcross
Registered User
1999 TJ Wrangler 
 
Join Date: Dec 2010
Location: Richmond, VA
Posts: 30
99 Wrangler Sport 4.0L Stall

So for the past week, my TJ has been developing a stall. It first happened when I was just beginning to accelerate from stop. I tried to crank her back, and it took several tries, but she turned over and I was on my way. A couple days later, doing about 60mph on the highway, the engine died. I put her in neutral, stepped on the clutch, cranked the key, and she fired right back up, while I was still moving. I put her in 5th and was on my way. On my morning commute today, stuck in stop-and-go, she died again. I cranked her back up and she was fine for the rest of the drive.

Given that is is happening regardless of speed, gear, or RPMs, I'm somewhat at a loss. She has a crank sensor that is less than a year old, and I have yet to replace the fuel pump for that notorious check-valve failure symptom that happens so frequently. Fuel pump has worked fine thus far (it just allows fuel to drain back into the tank upon shut-off, so I let the pump cycle for a few seconds before I crank the next time). A friend has also suggested a cleaning and/or replacement of the TPS...but I have no check-engine light. I had to replace my mom's TPS on her 01 Sahara a couple years back, and she had awful fuel consumption and a CEL; neither of which I'm experiencing.

So, if there are any suggestions out there, or "hey, I had that!" notions from my fellow Jeepers, please point in the direction you best advise. Thanks in advance!

tribalcross is offline   Reply With Quote
Unread 05-23-2011, 11:02 AM   #2
black05tj
Registered User
2004 WJ 
 
Join Date: Jun 2006
Location: Indiana
Posts: 484
Mine has done that a few times. A couple of them it finally decided it would not start. Crawled under the hood and started squeezing connections together to make sure they are tight. I'm pretty confident that mine is the CPS not getting a good connection. It will go a few weeks, and start having trouble. I will squeeze this connector back together (on the back of the intake) and it will be fine for a few weeks until it vibrates loose again.

I don't get any lights either, just dies without warning. You might check there. I keep meaning to clean my connections and try to better secure the wiring to keep it from coming loose, but what can I say, it's running for now and I'm lazy.
__________________
If you see Hobbes, tell him I said "Hi".
black05tj is offline   Reply With Quote
Unread 05-23-2011, 11:52 AM   #3
kash
Registered User
2000 TJ Wrangler 
 
Join Date: Jan 2006
Location: Northeast PA
Posts: 134
Check your coil pack. I had all these random stalls as well. Turned out it was a coil pack gone bad. Funny thing, never got a code directly related tot he coil pack.
__________________
Kash

ESSERE
UMANO
kash is offline   Reply With Quote
Unread 05-23-2011, 12:37 PM   #4
little_Jeep
Registered User
1998 TJ Wrangler 
 
Join Date: Nov 2006
Location: Louisville, KY
Posts: 5,907
Your engine just dies..... no loss of power first, just as if someone turned the key off? Have you noticed Jeep requiring an ever so slightly longer crank at first start of the day, then normal starts? If you have any (no all) of the above, don't rule that Crankshaft Sensor out, just yet as when they start to fail, they do some weird stuff.
little_Jeep is offline   Reply With Quote
Unread 05-23-2011, 12:49 PM   #5
tribalcross
Registered User
1999 TJ Wrangler 
 
Join Date: Dec 2010
Location: Richmond, VA
Posts: 30
I can feel the stall coming for a second or two...usually when throttle is closed, RPMs sit at 800-900 rpms and idles smoothly. When it's going to stall, the Jeep fights it, but begins to shudder and then engine shuts down. The length of cranking for a cold start is something I cannot study; I've got to let it sit in "ON" for a few seconds to allow the fuel pump to get going, otherwise I'll crank for what seems like forever. This is because the fuel pump check valve has been shot for a year, and I haven't replaced it yet. Going to clean the TPS with a rag and carb cleaner, and get a fuel pressure gauge on it later this week. I have a feeling that fuel pump is running on its last legs...
tribalcross is offline   Reply With Quote
Unread 05-23-2011, 08:36 PM   #6
oakmckinley
Registered User
1999 TJ Wrangler 
 
Join Date: Mar 2010
Location: Minneapolis, MN
Posts: 1,446
My CPS on my XJ went out and the first one installed was junk, only lasted a couple weeks. Replaced it (again)and it's been good for 3+ years now.
Also as mentioned above check the connection.
__________________
1999 TJ
2000 XJ Cherokee
2010 Mustang
1964 Ford Fairlane 500
oakmckinley is offline   Reply With Quote
Unread 05-26-2011, 02:24 PM   #7
Landseer
Registered User
 
Join Date: Jun 2006
Location: Central Virginia
Posts: 146
Our 98 is behaving very, very similarly.
Its automatic as opposed to your manual.

Like somebody throws a switch!
Might feel it stutter a tiny bit prior.
Can't decide if it wants to stall, then silence, rolls to the side of the road.

Happened yesterday 3 miles out, running in cruise at 60.
Then, turned around, happened 4 times on the drive back home, slow speed.

Seems electrical because I loose speedo.

Sometimes it starts back, sometimes takes sitting / half dozen tries.

Has had 4 coils, 3 CPS, 3 Cam postion sensors, O2 sensors and so on.

Feels a bit like loosing CPS crank position sensor. Have NAPA/Eichlin installed.

I'd expect more stutter if it were fuel pump.

Going out to driveway now to run it and wiggle harnesses.

Edit 7/19/ 2011 --- Found mine --- Random Die / No Start --- Finally Solved!
__________________
98 Sahara
Landseer is offline   Reply With Quote
Reply

Tags
cel , stall , tj , tps
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.