97 Wrangler Rough Idle while stopped - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > 97 Wrangler Rough Idle while stopped

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineThe ULTIMATE "Selectable" Locker System! BroughFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 06-22-2010, 05:35 PM   #1
jes229445
Registered User
1997 TJ Wrangler 
 
Join Date: Jul 2009
Location: SC
Posts: 8
97 Wrangler Rough Idle while stopped

Every time I come to a stop my Jeep start running like I have a miss in the engine (2.5). Driving along it runs great. Also if I come to a stop with the AC on it's even worst and my oil pressure drops to zero. Changed plugs, wires, rotor and dist cap, oil changed and cleaned throttle body and IAC. Any more suggestions.

Thanks for any help

jes229445 is offline   Reply With Quote
Unread 06-22-2010, 06:27 PM   #2
jmpowie
Registered User
1997 TJ Wrangler 
 
Join Date: Apr 2010
Location: somersworth NH
Posts: 143
any codes?
jmpowie is offline   Reply With Quote
Unread 06-22-2010, 07:08 PM   #3
Sundowner
Part-Time Swami
 
Sundowner's Avatar
2003 TJ Wrangler 
 
Join Date: May 2009
Location: The Republic of Dave
Posts: 5,899
Fill in your profile so we know what else you're equipped with!

1. What oil are you using?
2. Have you checked/changed injectors?
3. Did you check the harness/connections to the IAC?
4. Did you check the harness/connections to the TPS?
5. As previously posted, any codes showing?
__________________
If it's worth doing, then it's worth overdoing.

The Republic of Dave: Bringing you the finest in simian testing supplies.

The build, the gear, and the mileage: The Wasteland Survival Guide
Sundowner is offline   Reply With Quote
Unread 06-23-2010, 01:45 PM   #4
jes229445
Registered User
1997 TJ Wrangler 
 
Join Date: Jul 2009
Location: SC
Posts: 8
I'm getting a code for multiple misfire. I had a friend tell me if could be the speed sensor, since I changed from 29's to 31's. My speedometer is still dead on, and I don't see what that would have to do with anything.
jes229445 is offline   Reply With Quote
Unread 11-29-2011, 07:36 PM   #5
big_block_rober
Registered User
1997 TJ Wrangler 
 
Join Date: Nov 2011
Location: Lakewood, OH
Posts: 11
ruff idle

check your wiring harness on the back of the motor, this is a common problem,
the wiring harness rubs and chaffs on the back of the block and valve cover. pull the wire loom off and check the wires for cracks and worn spots. hope this helps
big_block_rober is offline   Reply With Quote
Unread 12-01-2011, 09:52 AM   #6
autopc25
Registered User
1997 TJ Wrangler 
 
Join Date: Jan 2010
Location: il
Posts: 483
Check for vacuum leaks. Do a search, lots written about it.

Good Luck
autopc25 is offline   Reply With Quote
Reply

Tags
rough idle
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.