4WD dash light not working - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > 4WD dash light not working

*VOTE NOW Help Metalcloak Giveaway an XJ Suspension*Premium LED Lighting by VISION X, Proudly sold at ROCKRIDGIntroducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 04-07-2006, 11:21 PM   #1
MyRig is Yellow
Registered User
 
Join Date: Aug 2005
Posts: 93
4WD dash light not working

i just had some major work done to the jeep, and now when i engage 4WD it doesnt light up on my dash,is there a wire or sensor that controls this that i can take a look at to see if its disconnected or something along those lines?

__________________
[COLOR=Yellow]02 TJ, 4.5 RE Lift, Ford 8.8, ARB, 4.88, Chromoly shafts & joints, 35 X 12.5 MT/R's, PSC Crusher corners and rockers, Warn Xi 9000, AA SYE, TW Drive shaft, Custom bumpers, JKS 1.25" BL, JKS Quicker Disco's, Flush tails, Herculined tub, Kilby on board air, Currie Tie Rod System, and so much more[/COLOR]

[URL=http://www.cardomain.com/ride/2068914]http://www.cardomain.com/ride/2068914[/URL]
MyRig is Yellow is offline   Reply With Quote
Unread 04-07-2006, 11:42 PM   #2
Stormtrooper
Registered User
2000 TJ Wrangler 
 
Join Date: Jan 2004
Location: Vista, CA
Posts: 296
Ya, there is a connectorized switch on the transfer case that turns on the dash indicator lamp. If your Tcase was removed, there's a good chance they forgot to reconnect the switch when they put it all back together. You'll have to crawl under, find the loose connector and plug it into the tcase 4wd indicator switch.
__________________
Cheers, Steve
Stormtrooper is offline   Reply With Quote
Unread 04-09-2006, 10:26 AM   #3
MyRig is Yellow
Registered User
 
Join Date: Aug 2005
Posts: 93
well i looked underneath pretty thouroughly and everything was connected, i forgot to mention before i had the new 8.8 put in that i took a pretty good dunk into some water and was stuck in the water for about 24 hours. i took the dash apart and the bulb was fine. any other suggestions?
__________________
[COLOR=Yellow]02 TJ, 4.5 RE Lift, Ford 8.8, ARB, 4.88, Chromoly shafts & joints, 35 X 12.5 MT/R's, PSC Crusher corners and rockers, Warn Xi 9000, AA SYE, TW Drive shaft, Custom bumpers, JKS 1.25" BL, JKS Quicker Disco's, Flush tails, Herculined tub, Kilby on board air, Currie Tie Rod System, and so much more[/COLOR]

[URL=http://www.cardomain.com/ride/2068914]http://www.cardomain.com/ride/2068914[/URL]
MyRig is Yellow is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.