4WD dash light not working - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > 4WD dash light not working

ROCK BOTTOM prices on LIFT KITS at Rockridge4wd!! WANT TO December Specials at Jeephut.comAlloy usa heavy duty ball joint kits

Reply
Unread 04-08-2006, 12:21 AM   #1
MyRig is Yellow
Registered User
 
Join Date: Aug 2005
Posts: 93
4WD dash light not working

i just had some major work done to the jeep, and now when i engage 4WD it doesnt light up on my dash,is there a wire or sensor that controls this that i can take a look at to see if its disconnected or something along those lines?

__________________
[COLOR=Yellow]02 TJ, 4.5 RE Lift, Ford 8.8, ARB, 4.88, Chromoly shafts & joints, 35 X 12.5 MT/R's, PSC Crusher corners and rockers, Warn Xi 9000, AA SYE, TW Drive shaft, Custom bumpers, JKS 1.25" BL, JKS Quicker Disco's, Flush tails, Herculined tub, Kilby on board air, Currie Tie Rod System, and so much more[/COLOR]

[URL=http://www.cardomain.com/ride/2068914]http://www.cardomain.com/ride/2068914[/URL]
MyRig is Yellow is offline   Reply With Quote Quick reply to this message
Unread 04-08-2006, 12:42 AM   #2
Stormtrooper
Registered User
2000 TJ Wrangler 
 
Join Date: Jan 2004
Location: Vista, CA
Posts: 296
Ya, there is a connectorized switch on the transfer case that turns on the dash indicator lamp. If your Tcase was removed, there's a good chance they forgot to reconnect the switch when they put it all back together. You'll have to crawl under, find the loose connector and plug it into the tcase 4wd indicator switch.
__________________
Cheers, Steve
Stormtrooper is offline   Reply With Quote Quick reply to this message
Unread 04-09-2006, 11:26 AM   #3
MyRig is Yellow
Registered User
 
Join Date: Aug 2005
Posts: 93
well i looked underneath pretty thouroughly and everything was connected, i forgot to mention before i had the new 8.8 put in that i took a pretty good dunk into some water and was stuck in the water for about 24 hours. i took the dash apart and the bulb was fine. any other suggestions?
__________________
[COLOR=Yellow]02 TJ, 4.5 RE Lift, Ford 8.8, ARB, 4.88, Chromoly shafts & joints, 35 X 12.5 MT/R's, PSC Crusher corners and rockers, Warn Xi 9000, AA SYE, TW Drive shaft, Custom bumpers, JKS 1.25" BL, JKS Quicker Disco's, Flush tails, Herculined tub, Kilby on board air, Currie Tie Rod System, and so much more[/COLOR]

[URL=http://www.cardomain.com/ride/2068914]http://www.cardomain.com/ride/2068914[/URL]
MyRig is Yellow is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.