4.0 Acting weird - JeepForum.com
 
LinkBack Thread Tools
post #1 of 8 Old 02-26-2009, 09:57 PM Thread Starter
Redneck924
Registered User
1999 TJ Wrangler 
 
Join Date: Oct 2008
Posts: 79
4.0 Acting weird

so i have this problem a couple times now...i went to crank the jeep today and thought it was cranked and let off of the key and it died....went to recrank it and i have to hold the pedal to keep it running.....well i held it for bout 5min letting it idle up and backed up then it died when i hit the brake....made it to where i was goin and it idled fine.....went to leave and it was real rough sounding and jumpin around.....any suggestions would be greatly appriciated

Redneck924 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 02-26-2009, 10:09 PM
wes19d
Registered User
2005 TJ Wrangler 
 
Join Date: Dec 2004
Location: Lexington NC/FT HOOD TX
Posts: 884
Throttle position sensor maybe

05 RUBI
wes19d is offline  
post #3 of 8 Old 02-27-2009, 12:26 AM
Deere9670
Registered User
2002 TJ Wrangler 
 
Join Date: Jan 2008
Location: Lockport, IL
Posts: 89
any cheak engine light or codes?
Deere9670 is offline  
post #4 of 8 Old 02-27-2009, 02:11 AM
willness33
Registered User
1999 TJ Wrangler 
 
Join Date: Aug 2008
Location: Charlotte,NC
Posts: 365
Sticky/dirty IAC.
willness33 is offline  
post #5 of 8 Old 02-27-2009, 10:58 AM Thread Starter
Redneck924
Registered User
1999 TJ Wrangler 
 
Join Date: Oct 2008
Posts: 79
wheres the IAC located at? im waitin on my tax return to do a full tune-up on this motor......does anybody run the Livewire wires......i ran them on my old chevy i had and liked them just didnt know about there jeep stuff.....www.performancedistributors.com
Redneck924 is offline  
post #6 of 8 Old 02-27-2009, 11:35 AM
wes19d
Registered User
2005 TJ Wrangler 
 
Join Date: Dec 2004
Location: Lexington NC/FT HOOD TX
Posts: 884
Its located on the throttle body held in by two bolts, it has an electrical connection running to it.

05 RUBI
wes19d is offline  
post #7 of 8 Old 02-27-2009, 11:45 AM
LJameson
Registered User
1990 YJ Wrangler 
 
Join Date: Jun 2008
Location: Central Oregon!
Posts: 3,829
Search the forum for IAC Cleaning. Lots of good write ups, and it's really simple.

1990 YJ-The wheeler
2015 JK- The DD
LJameson is online now  
post #8 of 8 Old 02-27-2009, 12:59 PM
Jonny Jeep
Web Wheeler
 
Jonny Jeep's Avatar
1997 TJ Wrangler 
 
Join Date: Feb 2007
Location: Manchester
Posts: 5,362
Sounds pretty much like it could also be a bad battery. Might be worth charging it then getting it tested - it's also what the FSM states to do when trying to sort out any electrically related problem.

Online factory service manuals and parts lists - http://www.jeep4x4center.com/knowledge-base/index.htm
If it doesn't work properly, look for the service manual link at the bottom of the page.
Jonny Jeep is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
5 speed acting weird in reverse PR_XJ1994 YJ Wrangler Technical Forum 5 08-28-2008 06:22 PM
YJ acting a little weird.... Tallanasty YJ Wrangler Technical Forum 2 02-12-2008 10:26 AM
Air Conditioning Acting Weird jwomack TJ Wrangler Technical Forum 7 06-29-2007 09:19 PM
headlights acting weird johnWJ TJ Wrangler Technical Forum 7 02-26-2006 04:17 PM
My AC fan blower is acting weird... axia TJ Wrangler Technical Forum 2 02-14-2005 06:07 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome