2005 Jeep Rubicon w/ Benz NSG-370-6 speed manual tranny problems - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > 2005 Jeep Rubicon w/ Benz NSG-370-6 speed manual tranny problems

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFS: Wranger BRIGHT License Plate LED! Just $3! Great valueOfficial Chassis Saver Rust Preventive Truck & Auto Un

Reply
Unread 11-11-2011, 07:31 PM   #1
firefly88
Registered User
2005 TJ Wrangler 
 
Join Date: Nov 2011
Location: Columbia, SC
Posts: 6
2005 Jeep Rubicon w/ Benz NSG-370-6 speed manual tranny problems

Hello,

I have a 2005 Jeep Rubicon with a Benz NSG-370 6 speed manual transmission.


In about 2007, she began to jump/bump/or pop violently out of first geat from a standing stop. I have tried everything in the tranny: switching to Penzoil Synchromesh & Royal Purple's Synchromax. Right now I am using Royal Purple & it is has given me the best results so far. As a rule, I change my tranny oil once a year.

Both have worked better than the standard NV3550 Mopar Manual Transmission Fluid. I don't know why this fluid was recommended for a completely different transmission & particuarly a Benz transmission. But I am not an auto expert.

I also find that if I go into Neutral after a stop & then shift into 1st before accelerating & hold to the stick, it is less likely to happen. Also, a higher rev prior to acelleration from a standing stop seems to help. It could (?) be that I am not paying attention & don't do the things I mentioned or I am not shifting all the way into 1st gear.

I have also been told I could have a bad synchronizer for 1st gear & that there is a Chrysler TSB on this problem, but Chrysler is not likely to tell you about it.

Has anyone else out there had this problem? When it occurs, is sounds & feels like someone has hit you in the rear end & the transmission has jumped back into Neutral. It is that violent as its worst.

Any thoughts or suggestions for me & how much it would cost to have this problem corrected?

Again many thanks in advance for your help,

firefly88

firefly88 is offline   Reply With Quote
Unread 11-11-2011, 07:59 PM   #2
grnsporty
Registered User
2006 TJ Wrangler 
 
Join Date: Oct 2007
Location: virginia
Posts: 183
I have had this also happen quite a few times. It's been months since the last one though.
grnsporty is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.