2001 Jeep TJ 4.0 turns over but wont start. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > 2001 Jeep TJ 4.0 turns over but wont start.

FS: Jeep Fog Light LED Bulbs! Several Brightness Options! SPARTAN LOCKERS are on sale BIG TIME at ROCKRIDGE 4WD!Yukon Ultimate 35 axle kit for c/clip axles with Yukon Zip

Reply
Unread 02-08-2011, 09:54 AM   #1
MOTOWNTJ
Registered User
2001 TJ Wrangler 
 
Join Date: Dec 2010
Location: MORGANTOWN, WV
Posts: 8
2001 Jeep TJ 4.0 turns over but wont start.

My 2001 TJ turns over but will not start and run. Replaced the crank shaft positioning sensor and still nothing. Just topped off fuel before this started. When I turn the key on I no longer hear the fuel pump kick on. Checked fuses and relays they seem fine. Check the valve on the fuel line near the injector and no fuel comes out. Is there anythig else I should check before i go digging into the fuel tank to replace the fuel pump.

MOTOWNTJ is offline   Reply With Quote
Unread 02-08-2011, 10:15 AM   #2
j_niko
Registered User
2000 TJ Wrangler 
 
Join Date: Nov 2009
Location: Cleveland
Posts: 1,165
Check to make sure there is voltage getting to the fuel pump.
__________________
2000 - Sahara
1997 - Sahara
j_niko is offline   Reply With Quote
Unread 02-08-2011, 10:18 AM   #3
Wheelin98TJ
JEEP FREAK
 
Wheelin98TJ's Avatar
1998 TJ Wrangler 
 
Join Date: Apr 2004
Location: , Southeast MI
Posts: 24,357
Check for spark.

When spark is not present, the fuel pump will eventually be cut off.
Wheelin98TJ is offline   Reply With Quote
Unread 03-14-2011, 11:00 AM   #4
MOTOWNTJ
Registered User
2001 TJ Wrangler 
 
Join Date: Dec 2010
Location: MORGANTOWN, WV
Posts: 8
I have left the jeep sit a while. I just recently started to work it again. I jumped a wire from the fuse box under the hood at the fuel pump relay and the fuel pump kicks on and sends fuel to the fuel rail. However I am not getting any spark at the coil rail. I have replaced the crank shaft positioning senor and cam shaft positing senor. Do any of you think that the coil rail is bad or posibly the computer. I dont know what else could to check. I hooked the jeep up ot an OBD II scanner and it will not show any codes, just "no link." All my connctions look clean and no wires that i have found seem to be broke or exposed.
MOTOWNTJ is offline   Reply With Quote
Unread 03-25-2011, 11:42 AM   #5
MOTOWNTJ
Registered User
2001 TJ Wrangler 
 
Join Date: Dec 2010
Location: MORGANTOWN, WV
Posts: 8
Replaced the ingnition coil and still nothing, so I guess Iam going to further check all the wiring under the hood for any damage. If that does not turn up anything i guess its off to the dealership for diagnostic. Any other input would be appreciated.
MOTOWNTJ is offline   Reply With Quote
Unread 05-06-2011, 05:20 PM   #6
jkretzer
Registered User
 
Join Date: May 2011
Location: sharpsburg, md
Posts: 3
any results, i am having the same issue right now? thanks
jkretzer is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.