2/2 Sensor Slow Response(Oxygen Sensor code P0159) - JeepForum.com

 
LinkBack Thread Tools
post #1 of 10 Old 09-15-2011, 01:48 PM Thread Starter
Erik T.
Registered User
 
Erik T.'s Avatar
2001 TJ Wrangler 
 
Join Date: Feb 2006
Posts: 2,774
2/2 Sensor Slow Response(Oxygen Sensor code P0159)

Had a Check Engine light come on, ran the codes and its the P 0159 for slow oxygen sensor.

I tried searching, couldn't find anything on how to fix the slow sensor. Do I just replace it(them?).


-Erik.

Quote:
Originally Posted by mrblaine View Post
Hack work? :rofl: You just described half the modified jeeps on this board.
Erik T. is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 09-15-2011, 01:50 PM
biffgnar
Moderator
 
biffgnar's Avatar
2006 TJ Wrangler 
 
Join Date: May 2008
Location: Westchester, NY
Posts: 19,243
Just replace

#feelthejohnson
biffgnar is offline  
post #3 of 10 Old 09-15-2011, 02:25 PM Thread Starter
Erik T.
Registered User
 
Erik T.'s Avatar
2001 TJ Wrangler 
 
Join Date: Feb 2006
Posts: 2,774
Can I run like this for a few days? Or should I just park it til I can get to it?

-Erik.

Quote:
Originally Posted by mrblaine View Post
Hack work? :rofl: You just described half the modified jeeps on this board.
Erik T. is offline  
post #4 of 10 Old 09-15-2011, 02:27 PM
timberwolf0122
Registered User
2005 LJ Wrangler 
 
Join Date: Mar 2009
Location: Elmore(dor)
Posts: 19,218
Your fine to drive it.

Atheist Jeep Club Member #2
Doctor Who has died 13 times, is on his 14th regeneration and has a time machine, beat that Jesus.
timberwolf0122 is offline  
post #5 of 10 Old 09-15-2011, 03:50 PM
JWebber
Registered User
1999 TJ Wrangler 
 
Join Date: Aug 2011
Location: Lewisville
Posts: 1,394
Sound like it's not getting to temp range and when your PCM goes into open loop for monitoring it's seeing it as slow. Replace it!
JWebber is offline  
post #6 of 10 Old 09-15-2011, 04:25 PM
flying_bosun
Registered User
2006 LJ Wrangler 
 
Join Date: May 2009
Location: 34*24'N, 119*42'W
Posts: 3,892
Quote:
Originally Posted by Erik T. View Post
Can I run like this for a few days? Or should I just park it til I can get to it?
You won't hurt anything driving it, but you may see a marked decrease in fuel economy.

Gear-Calculator Stu Can Help You Part Names and Numbers Dealer Supplied Parts and ask for "Jeep Club" Prices


Quote:
Originally Posted by Ron Paul
“Liberty is lost through complacency and a subservient mindset. When we accept or even welcome automobile checkpoints, random searches, mandatory identification cards, and paramilitary police in our streets, we have lost a vital part of our American heritage. America was born of protest, revolution, and mistrust of government. Subservient societies neither maintain nor deserve freedom for long.”
― Ron Paul
"Did you exchange your walk-on part in the war for a lead role in a cage?"
flying_bosun is offline  
post #7 of 10 Old 09-15-2011, 08:46 PM Thread Starter
Erik T.
Registered User
 
Erik T.'s Avatar
2001 TJ Wrangler 
 
Join Date: Feb 2006
Posts: 2,774
I can live with that. While I drive 3 hours a day to work and back(on top of a ten hour shift), my wife drives my Jeep to her job that is only 3 miles down the road from the house.

I'll get to it this weekend or next then.

Thanks.

-Erik.

Quote:
Originally Posted by mrblaine View Post
Hack work? :rofl: You just described half the modified jeeps on this board.
Erik T. is offline  
post #8 of 10 Old 08-12-2012, 01:54 PM
deesulpwr
Registered User
2001 TJ Wrangler 
 
Join Date: Oct 2007
Location: North Carolina
Posts: 7
I have replaced 2/2 three times, replaced the cats two years ago. I have been fighting P0320, 0300, 0304, 0305, 0306 and 0159. I replaced the Crankshaft position sensor and that code went away. I can't figure this mess out. Jeep runs ok, mileage is a bit off but not real bad. I have tried Mopar and aftermarket sensors. Maybe I need to take it back and have the cats checked? Anyone have suggestions, I buy all my fuel from the same station for all vehicles and the other two have had no issues.
deesulpwr is offline  
post #9 of 10 Old 10-03-2012, 02:18 PM
deesulpwr
Registered User
2001 TJ Wrangler 
 
Join Date: Oct 2007
Location: North Carolina
Posts: 7
Anyone?.... I am still having the same issue. I replaced the CPS twice and that code is gone but I still have the 0300,0304,0305,0306 and 0159. I guess I will take it back and have the cats checked, they were replaced two years ago.
deesulpwr is offline  
post #10 of 10 Old 10-03-2012, 04:01 PM
Rubi4MyMrs
Web Wheeler
 
Rubi4MyMrs's Avatar
2005 LJ Wrangler 
 
Join Date: Mar 2011
Location: Trails of
Posts: 3,217
The misfire is from the back 3 (bank 2) cylinders. Have you replaced the 2/1 O2 sensor? Checked the exhaust for leaks? Bad sensor 1s can mess with the fuel mixture & cause various problems. Bad mileage & misfire on all bank 2 cylinders? No expert but it doesn't sound like cats to me.

BTW, don't use Bosch sensors. Known to give problems & slow response is a common issue.
Rubi4MyMrs is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
o2 sensor slow response LWB1217 TJ Wrangler Technical Forum 7 05-10-2011 08:48 PM
4.0L Misfire/ O2 sensor slow response CaposgrayTJ TJ Wrangler Technical Forum 2 03-27-2011 02:15 PM
Slow O2 sensor response, help needed surfsup887 TJ Wrangler Technical Forum 10 12-13-2010 12:43 PM
Very confused! banck two sensor two oxygen sensor imnotaniceboy TJ Wrangler Technical Forum 5 03-12-2010 04:22 AM
Engine warning light, code P1196 (oxygen sensor) planetlarson TJ Wrangler Technical Forum 1 09-05-2009 11:51 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome