04 tj not a clue what the problem is - JeepForum.com

 
LinkBack Thread Tools
post #1 of 2 Old 03-20-2013, 05:01 PM Thread Starter
Jordaaan905
Registered User
2004 TJ Wrangler 
 
Join Date: Sep 2012
Location: brampton
Posts: 37
04 tj not a clue what the problem is

I have an 04 tj Sahara no wheel/gear/lift upgrades yet it has 104000 kms on it had an oil change within the last month 100000km servicing has not been done the jeep is 5 speed manual the problem is generally after I shift or even start in first it vibrates quite a bit basically feels like I am in to high of a gear 2 U joints were replaced last fall and I have no clue what it could be even when revving it vibrates quite a bit more than usual any ideas as to what it could be

Jordaaan905 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 03-20-2013, 06:41 PM
mukluk
Registered User
2000 TJ Wrangler 
 
Join Date: Oct 2010
Location: Clyde
Posts: 2,038
If the vibration is while you are letting the clutch pedal out, then it sounds like you're experiencing clutch chatter. If the vibration is moreso after the clutch pedal is released, then I'd lean toward worn out engine and transmission mounts.
mukluk is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome